本文へスキップ
ecdsa.com
TLS

TLS のサポートされるグループ|曲線、FFDHE、ML-KEM

IANA レジストリにある TLS 鍵交換の名前付きグループです。楕円曲線、有限体(FFDHE)、ML-KEM、ポスト量子ハイブリッドグループをコードポイント付きで掲載しています。

75 件中 75 件を表示

TLS のサポートされるグループ · 75 件

TLS 鍵交換用の名前付きグループです。楕円曲線、有限体グループ、ML-KEM、ポスト量子のハイブリッドグループを収録しています。

値名称説明推奨参考文献
0x0001sect163k1sect163k1(0x0001)は sect163k1 上の楕円曲線 Diffie–Hellman です。sect163k1DRFC 8422RFC 9847
0x0002sect163r1sect163r1(0x0002)は sect163r1 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0003sect163r2sect163r2(0x0003)は sect163r2 上の楕円曲線 Diffie–Hellman です。sect163r2DRFC 8422RFC 9847
0x0004sect193r1sect193r1(0x0004)は sect193r1 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0005sect193r2sect193r2(0x0005)は sect193r2 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0006sect233k1sect233k1(0x0006)は sect233k1 上の楕円曲線 Diffie–Hellman です。sect233k1DRFC 8422RFC 9847
0x0007sect233r1sect233r1(0x0007)は sect233r1 上の楕円曲線 Diffie–Hellman です。sect233r1DRFC 8422RFC 9847
0x0008sect239k1sect239k1(0x0008)は sect239k1 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0009sect283k1sect283k1(0x0009)は sect283k1 上の楕円曲線 Diffie–Hellman です。sect283k1NRFC 8422
0x000Asect283r1sect283r1(0x000A)は sect283r1 上の楕円曲線 Diffie–Hellman です。sect283r1NRFC 8422
0x000Bsect409k1sect409k1(0x000B)は sect409k1 上の楕円曲線 Diffie–Hellman です。sect409k1NRFC 8422
0x000Csect409r1sect409r1(0x000C)は sect409r1 上の楕円曲線 Diffie–Hellman です。sect409r1NRFC 8422
0x000Dsect571k1sect571k1(0x000D)は sect571k1 上の楕円曲線 Diffie–Hellman です。sect571k1NRFC 8422
0x000Esect571r1sect571r1(0x000E)は sect571r1 上の楕円曲線 Diffie–Hellman です。sect571r1NRFC 8422
0x000Fsecp160k1secp160k1(0x000F)は secp160k1 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0010secp160r1secp160r1(0x0010)は secp160r1 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0011secp160r2secp160r2(0x0011)は secp160r2 上の楕円曲線 Diffie–Hellman です。DRFC 8422RFC 9847
0x0012secp192k1secp192k1(0x0012)は secp192k1 上の楕円曲線 Diffie–Hellman です。secp192k1DRFC 8422RFC 9847
0x0013secp192r1secp192r1(0x0013)は P-192 上の楕円曲線 Diffie–Hellman です。P-192DRFC 8422RFC 9847
0x0014secp224k1secp224k1(0x0014)は secp224k1 上の楕円曲線 Diffie–Hellman です。secp224k1DRFC 8422RFC 9847
0x0015secp224r1secp224r1(0x0015)は P-224 上の楕円曲線 Diffie–Hellman です。P-224DRFC 8422RFC 9847
0x0016secp256k1secp256k1(0x0016)は secp256k1 上の楕円曲線 Diffie–Hellman です。secp256k1NRFC 8422
0x0017注記secp256r1secp256r1(0x0017)は P-256 上の楕円曲線 Diffie–Hellman です。P-256YRFC 8422
0x0018注記secp384r1secp384r1(0x0018)は P-384 上の楕円曲線 Diffie–Hellman です。P-384YRFC 8422
0x0019secp521r1secp521r1(0x0019)は P-521 上の楕円曲線 Diffie–Hellman です。P-521NRFC 8422
0x001AbrainpoolP256r1brainpoolP256r1(0x001A)は brainpoolP256r1 上の楕円曲線 Diffie–Hellman です。brainpoolP256r1NRFC 7027
0x001BbrainpoolP384r1brainpoolP384r1(0x001B)は brainpoolP384r1 上の楕円曲線 Diffie–Hellman です。brainpoolP384r1NRFC 7027
0x001CbrainpoolP512r1brainpoolP512r1(0x001C)は brainpoolP512r1 上の楕円曲線 Diffie–Hellman です。brainpoolP512r1NRFC 7027
0x001D注記x25519x25519(0x001D)は curve25519 上の楕円曲線 Diffie–Hellman です。curve25519YRFC 9846RFC 8422
0x001Ex448x448(0x001E)は curve448 上の楕円曲線 Diffie–Hellman です。curve448YRFC 9846RFC 8422
0x001FbrainpoolP256r1tls13brainpoolP256r1tls13(0x001F)は brainpoolP256r1 上の楕円曲線 Diffie–Hellman です。brainpoolP256r1NRFC 8734
0x0020brainpoolP384r1tls13brainpoolP384r1tls13(0x0020)は brainpoolP384r1 上の楕円曲線 Diffie–Hellman です。brainpoolP384r1NRFC 8734
0x0021brainpoolP512r1tls13brainpoolP512r1tls13(0x0021)は brainpoolP512r1 上の楕円曲線 Diffie–Hellman です。brainpoolP512r1NRFC 8734
0x0022GC256AGC256A(0x0022)は GC256A 上の楕円曲線 Diffie–Hellman です。GC256ANRFC 9189
0x0023GC256BGC256B(0x0023)は GC256B 上の楕円曲線 Diffie–Hellman です。GC256BNRFC 9189
0x0024GC256CGC256C(0x0024)は GC256C 上の楕円曲線 Diffie–Hellman です。GC256CNRFC 9189
0x0025GC256DGC256D(0x0025)は GC256D 上の楕円曲線 Diffie–Hellman です。GC256DNRFC 9189
0x0026GC512AGC512A(0x0026)は GC512A 上の楕円曲線 Diffie–Hellman です。GC512ANRFC 9189
0x0027GC512BGC512B(0x0027)は GC512B 上の楕円曲線 Diffie–Hellman です。GC512BNRFC 9189
0x0028GC512CGC512C(0x0028)は GC512C 上の楕円曲線 Diffie–Hellman です。GC512CNRFC 9189
0x0029curveSM2curveSM2(0x0029)は SM2 上の楕円曲線 Diffie–Hellman です。SM2NRFC 8998
0x0100注記ffdhe2048ffdhe2048(0x0100)は、RFC 7919 で定義された 2048 ビットの有限体 Diffie–Hellman グループです。NRFC 7919
0x0101ffdhe3072ffdhe3072(0x0101)は、RFC 7919 で定義された 3072 ビットの有限体 Diffie–Hellman グループです。NRFC 7919
0x0102ffdhe4096ffdhe4096(0x0102)は、RFC 7919 で定義された 4096 ビットの有限体 Diffie–Hellman グループです。NRFC 7919
0x0103ffdhe6144ffdhe6144(0x0103)は、RFC 7919 で定義された 6144 ビットの有限体 Diffie–Hellman グループです。NRFC 7919
0x0104ffdhe8192ffdhe8192(0x0104)は、RFC 7919 で定義された 8192 ビットの有限体 Diffie–Hellman グループです。NRFC 7919
0x0200MLKEM512MLKEM512(0x0200)は、ML-KEM-512(FIPS 203)だけを使うポスト量子の鍵共有で、従来型の要素は含みません。NRFC-ietf-tls-mlkem-10
0x0201注記MLKEM768MLKEM768(0x0201)は、ML-KEM-768(FIPS 203)だけを使うポスト量子の鍵共有で、従来型の要素は含みません。NRFC-ietf-tls-mlkem-10
0x0202MLKEM1024MLKEM1024(0x0202)は、ML-KEM-1024(FIPS 203)だけを使うポスト量子の鍵共有で、従来型の要素は含みません。NRFC-ietf-tls-mlkem-10
0x0A0AReserved0x0A0A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x11E9SecP256r1MLKEM512SecP256r1MLKEM512(0x11E9)はハイブリッド鍵交換です。共有秘密は secp256r1 と ML-KEM-512 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。P-256Ndraft-rosomakho-tls-ecdhe-mlkem512-00
0x11EAMLKEM512X25519MLKEM512X25519(0x11EA)はハイブリッド鍵交換です。共有秘密は X25519 と ML-KEM-512 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。curve25519Ndraft-rosomakho-tls-ecdhe-mlkem512-00
0x11EB注記SecP256r1MLKEM768SecP256r1MLKEM768(0x11EB)はハイブリッド鍵交換です。共有秘密は secp256r1 と ML-KEM-768 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。P-256NRFC 10024
0x11EC注記X25519MLKEM768X25519MLKEM768(0x11EC)はハイブリッド鍵交換です。共有秘密は X25519 と ML-KEM-768 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。curve25519YRFC 10024
0x11EDSecP384r1MLKEM1024SecP384r1MLKEM1024(0x11ED)はハイブリッド鍵交換です。共有秘密は secp384r1 と ML-KEM-1024 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。P-384NRFC 10024
0x11EEcurveSM2MLKEM768curveSM2MLKEM768(0x11EE)はハイブリッド鍵交換です。共有秘密は curveSM2 と ML-KEM-768 を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。SM2Ndraft-yang-tls-hybrid-sm2-mlkem-03
0x1A1AReserved0x1A1A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x2A2AReserved0x2A2A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x3A3AReserved0x3A3A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x4A4AReserved0x4A4A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x5A5AReserved0x5A5A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x6399X25519Kyber768Draft00X25519Kyber768Draft00(0x6399)はハイブリッド鍵交換です。共有秘密は X25519 と Kyber768 (draft 00) を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。標準化前のコードポイントで、現在は廃止されています。curve25519Ddraft-tls-westerbaan-xyber768d00-02RFC 10024
0x639ASecP256r1Kyber768Draft00SecP256r1Kyber768Draft00(0x639A)はハイブリッド鍵交換です。共有秘密は secp256r1 と Kyber768 (draft 00) を組み合わせて導出されるため、どちらか一方が安全である限り秘密に保たれます。標準化前のコードポイントで、現在は廃止されています。P-256Ddraft-kwiatkowski-tls-ecdhe-kyber-01RFC 10024
0x6A6AReserved0x6A6A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x7A7AReserved0x7A7A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x8A8AReserved0x8A8A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0x9A9AReserved0x9A9A は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xAAAAReserved0xAAAA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xBABAReserved0xBABA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xCACAReserved0xCACA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xDADAReserved0xDADA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xEAEAReserved0xEAEA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xFAFAReserved0xFAFA は「TLS のサポートされるグループ」レジストリの GREASE 値(RFC 8701)です。クライアントがこうした値をランダムに送るのは、サーバーが未知のエントリを無視するようにするためです。実在のアルゴリズムを表すことはありません。NRFC 8701
0xFF01arbitrary_explicit_prime_curvesarbitrary_explicit_prime_curves(0xFF01)は、グループ名を指定する代わりに曲線のパラメーターを明示的に送ることを相手に伝えます。RFC 8422 では、明示的な曲線は非推奨です。NRFC 8422
0xFF02arbitrary_explicit_char2_curvesarbitrary_explicit_char2_curves(0xFF02)は、グループ名を指定する代わりに曲線のパラメーターを明示的に送ることを相手に伝えます。RFC 8422 では、明示的な曲線は非推奨です。NRFC 8422
未割り当ての範囲と予約済みの範囲 · 26 件
範囲ステータス説明
0x0000reservedReserved
0x002A–0x00FFunassignedUnassigned
0x0105–0x01FBunassignedUnassigned
0x01FC–0x01FFprivateReserved for Private Use
0x0203–0x0A09unassignedUnassigned
0x0A0B–0x11E8unassignedUnassigned
0x11EF–0x1A19unassignedUnassigned
0x1A1B–0x2A29unassignedUnassigned
0x2A2B–0x3A39unassignedUnassigned
0x3A3B–0x4A49unassignedUnassigned
0x4A4B–0x5A59unassignedUnassigned
0x5A5B–0x6398unassignedUnassigned
0x639B–0x6A69unassignedUnassigned
0x6A6B–0x7A79unassignedUnassigned
0x7A7B–0x8A89unassignedUnassigned
0x8A8B–0x9A99unassignedUnassigned
0x9A9B–0xAAA9unassignedUnassigned
0xAAAB–0xBAB9unassignedUnassigned
0xBABB–0xCAC9unassignedUnassigned
0xCACB–0xDAD9unassignedUnassigned
0xDADB–0xEAE9unassignedUnassigned
0xEAEB–0xFAF9unassignedUnassigned
0xFAFB–0xFDFFunassignedUnassigned
0xFE00–0xFEFFprivateReserved for Private Use
0xFF00unassignedUnassigned
0xFF03–0xFFFFunassignedUnassigned

出典:Transport Layer Security (TLS) Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 TLS Supported Groups

注目すべき項目の注記

secp256r1

P-256 上の ECDHE で、RFC 8446 がすべての TLS 1.3 実装に必須としている鍵交換です。

secp256r1(23)は、TLS 1.3 の実装がサポートしなければならない(MUST)グループです(RFC 8446 §9.1)。そのため、常に使えるフォールバックになります。キーシェアは 65 バイトの非圧縮形式の点で、TLS 1.3 ではこれらの曲線で圧縮された点の使用が禁止されています。P-256 も参照してください。

secp384r1

P-384 上の ECDHE で、NSA の CNSA 1.0 スイートで必須とされています。

secp384r1(24)は IANA で推奨とされており、CNSA に準拠した構成で使われるグループです。キーシェアは 97 バイトです。ハイブリッドの SecP384r1MLKEM1024 は、CNSA 2.0 への移行に向けてこれを ML-KEM-1024 と組み合わせます。P-384 も参照してください。

x25519

Curve25519 上の楕円曲線 Diffie–Hellman で、TLS 1.3 における従来型の鍵交換のデフォルトです。

x25519(29)は TLS 1.3 で最も一般的なキーシェアで、X25519MLKEM768 の従来型の半分を担います。RFC 8446 §9.1 は、必須の secp256r1 に加えて、実装がこれをサポートすべき(SHOULD)としています。キーシェアは 32 バイトです。Curve25519 も参照してください。

ffdhe2048

RFC 7919 で定義された 2048 ビットの有限体 Diffie–Hellman グループです。

RFC 7919 は、サーバーが選ぶ DHE パラメーターを、固定された 5 つの名前付きグループに置き換えました。従来のパラメーターは 1024 ビットのことが多く、多数のサーバーで共有されていて事前計算が可能な場合もあることが、Logjam 攻撃で示されていました。TLS 1.3 は、これらのグループを supported_groups でネゴシエートします。RFC 10015 §3 は TLS 1.2 で FFDHE の暗号スイートを禁止しているため、現在これらのグループが意味を持つのは TLS 1.3 だけですが、そこでもめったに使われません。

MLKEM768

従来型の要素を含まない ML-KEM-768 単体の、純粋なポスト量子 TLS 鍵交換です。

MLKEM768(513)は FIPS 203 の KEM だけを使います。ML-KEM が破られた場合、セッションを守るものは何もなくなります。Web で X25519MLKEM768 などのハイブリッドが使われているのはそのためです。純粋なポスト量子グループは、ポリシーでポスト量子アルゴリズムのみの使用が求められる環境を対象としています。

SecP256r1MLKEM768

P-256 の ECDHE と ML-KEM-768 のハイブリッドで、NIST 承認の曲線を使い続けなければならない環境向けです。

SecP256r1MLKEM768(0x11EB、RFC 10024)は、P-256 のキーシェアと ML-KEM-768 を組み合わせます。どちらの要素も NIST の承認を受けているため、X25519 を使えない FIPS 認証済みの環境に適しています。

X25519MLKEM768

ブラウザーと主要なサーバーがデフォルトでネゴシエートするハイブリッドのポスト量子鍵交換で、X25519 と ML-KEM-768 を組み合わせたものです。

X25519MLKEM768(0x11EC、RFC 10024)は、ML-KEM-768 のカプセル化鍵と X25519 のキーシェアを 1 つの key_share エントリで送り、2 つの共有秘密を連結します。そのため、どちらかのアルゴリズムが安全である限り、セッションの秘密は保たれます。将来の量子コンピューターによる「harvest now, decrypt later」(今収集し、後で解読する)攻撃から、現在の通信を守ります。IANA はこれを推奨としています。

ClientHello のキーシェアは約 1.2 KB あり、ClientHello が 1 つの TCP セグメントに収まらなくなるため、分割された ClientHello を処理できないミドルボックスの存在が明らかになりました。以前の導入では標準化前のコードポイント X25519Kyber768Draft00(0x6399)が使われていましたが、現在は廃止されています。

すべてのレジストリ