GC256B は、256 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 256 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 128 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。
GC256B は GOST R 34.10-2001 向けに定義され、RFC 4357 §11.4 で id-GostR3410-2001-CryptoPro-A-ParamSet として公開されました。GOST R 34.10-2012 でも paramSetB として引き継がれています(RFC 9215)。素数 2^256 − 617 上の曲線 y² = x³ − 3x + 166 で、位数は素数です。
同じパラメーターが鍵交換用に CryptoPro-XchA としても登録されているため、この曲線には OID が 2 つあります。DNSSEC のアルゴリズム 12(RFC 5933、現在は非推奨)で使われていたほか、TLS ではグループ GC256B として登録されています(RFC 9189、RFC 9367)。
規格での名称
| 規格 | 名称 |
|---|
| IANA TLS (RFC 9189) | GC256B |
| TC 26 | id-tc26-gost-3410-2012-256-paramSetB |
| RFC 4357 | id-GostR3410-2001-CryptoPro-A-ParamSet |
| RFC 4357 | id-GostR3410-2001-CryptoPro-XchA-ParamSet |
ドメインパラメーター
256 ビットの素体 · 約 128 ビットセキュリティ
- 有限体の素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
- 係数 a
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd94
- 係数 b
- 0xa6
- ベースポイントの x 座標
- 0x1
- ベースポイントの y 座標
- 0x8d91e471e0989cda27df505a453f2b7635294f2ddf23e3b122acc99c9e9f1e14
- ベースポイントの位数 n
- 0xffffffffffffffffffffffffffffffff6c611070995ad10045841b09b761b893
- コファクター h
- 0x1
採用例
- GOST R 34.10-2012 signatures
- TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
- Russian government PKI
← すべての曲線