A GC256B é a curva GOST de 256 bits conhecida desde 2006 como CryptoPro-A (id-GostR3410-2001-CryptoPro-A-ParamSet).
GC256B é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 256 bits com um subgrupo de ordem prima de 256 bits e cofator 1; o nível de segurança estimado é de 128 bits. Status: segura, mas regional ou de nicho.
A GC256B foi definida para o GOST R 34.10-2001 e publicada na RFC 4357 §11.4 como id-GostR3410-2001-CryptoPro-A-ParamSet; o GOST R 34.10-2012 a mantém como paramSetB (RFC 9215). Ela é a curva de ordem prima y² = x³ − 3x + 166 sobre o primo 2^256 − 617.
Os mesmos parâmetros estão registrados para troca de chaves como CryptoPro-XchA, e é por isso que a curva tem dois OIDs. O algoritmo 12 do DNSSEC (RFC 5933), hoje obsoleto, a usava, e o TLS a lista como grupo GC256B (RFC 9189, RFC 9367).