Перейти к содержимому
ecdsa.com
ДопустимаяКороткая форма Вейерштрасса

GC256B

GC256B — 256-битная кривая GOST, известная с 2006 года как CryptoPro-A (id-GostR3410-2001-CryptoPro-A-ParamSet).

GC256B — кривая в короткой форме Вейерштрасса y² = x³ + ax + b над 256-битным простым полем с 256-битной подгруппой простого порядка и кофактором 1; оценочный уровень стойкости — 128 бит. Статус: безопасна, но региональная или нишевая.

GC256B определили для GOST R 34.10-2001 и опубликовали в RFC 4357, § 11.4 под именем id-GostR3410-2001-CryptoPro-A-ParamSet; GOST R 34.10-2012 сохраняет её как paramSetB (RFC 9215). Это кривая простого порядка y² = x³ − 3x + 166 над полем по модулю простого числа 2^256 − 617.

Те же параметры зарегистрированы для обмена ключами как CryptoPro-XchA, поэтому у кривой два OID. Её использовал алгоритм 12 в DNSSEC (RFC 5933, ныне устаревший), а в TLS она значится как группа GC256B (RFC 9189, RFC 9367).

Названия в стандартах

СтандартНазвание
IANA TLS (RFC 9189)GC256B
TC 26id-tc26-gost-3410-2012-256-paramSetB
RFC 4357id-GostR3410-2001-CryptoPro-A-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchA-ParamSet

Идентификаторы объектов

Параметры кривой

256-битное простое поле · примерно 128-битная стойкость

Простой модуль поля p
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
Коэффициент a
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd94
Коэффициент b
0xa6
Координата x базовой точки
0x1
Координата y базовой точки
0x8d91e471e0989cda27df505a453f2b7635294f2ddf23e3b122acc99c9e9f1e14
Порядок n базовой точки
0xffffffffffffffffffffffffffffffff6c611070995ad10045841b09b761b893
Кофактор h
0x1

Где используется

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Идентификаторы в реестрах

Поддерживаемые группы TLS
GC256B 0x0023
Схемы подписи TLS
gostr34102012_256b 0x070A
Номера алгоритмов DNSSEC
ECC-GOST 12

Стандарты и ссылки

Все кривые