Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

GC256B

GC256B est la courbe GOST de 256 bits connue depuis 2006 sous le nom de CryptoPro-A (id-GostR3410-2001-CryptoPro-A-ParamSet).

GC256B est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 256 bits, avec un sous-groupe d’ordre premier de 256 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 128 bits. Statut : sûre, mais régionale ou de niche.

GC256B a été définie pour GOST R 34.10-2001 et publiée dans la RFC 4357, §11.4, sous le nom id-GostR3410-2001-CryptoPro-A-ParamSet ; GOST R 34.10-2012 la conserve sous le nom paramSetB (RFC 9215). C’est la courbe d’ordre premier y² = x³ − 3x + 166 définie modulo le nombre premier 2^256 − 617.

Les mêmes paramètres sont enregistrés pour l’échange de clés sous le nom CryptoPro-XchA, d’où les deux OID de la courbe. L’algorithme DNSSEC 12 (RFC 5933, désormais obsolète) l’utilisait, et TLS la répertorie comme groupe GC256B (RFC 9189, RFC 9367).

Noms dans les normes

NormeNom
IANA TLS (RFC 9189)GC256B
TC 26id-tc26-gost-3410-2012-256-paramSetB
RFC 4357id-GostR3410-2001-CryptoPro-A-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchA-ParamSet

Identifiants d’objet

Paramètres de domaine

corps premier de 256 bits · sécurité d’environ 128 bits

Nombre premier p du corps
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd97
Coefficient a
0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffd94
Coefficient b
0xa6
Coordonnée x du point de base
0x1
Coordonnée y du point de base
0x8d91e471e0989cda27df505a453f2b7635294f2ddf23e3b122acc99c9e9f1e14
Ordre n du point de base
0xffffffffffffffffffffffffffffffff6c611070995ad10045841b09b761b893
Cofacteur h
0x1

Utilisée dans

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identifiants dans les registres

Groupes pris en charge par TLS
GC256B 0x0023
Schémas de signature TLS
gostr34102012_256b 0x070A
Numéros d’algorithmes DNSSEC
ECC-GOST 12

Normes et références

Toutes les courbes