TLS と DNS
サーバー用の TLS 設定の生成、有効期間 47 日の証明書への備え、CAA・TLSA・security.txt のレコードの公開、DNSSEC の信頼の連鎖の追跡ができます。お使いのブラウザーがすでにポスト量子 TLS を使っているかの確認や、多数のドメインの一括チェックも可能です。ネットワーク経由で何かを送信する場合は、何を送るかを各ページに正確に明記しています。
9 個のツール
TLS 設定生成ツール
28 種類のサーバー向け SSL 設定
nginx、Apache、HAProxy、Caddy、Postfix、Node.js、Go、Java、.NET に加え、さらに 19 種類のサーバー向けの TLS 設定を、Mozilla のガイドラインを引き継ぐ TLSRef のガイドラインに基づいて生成します。バージョンが対応していればポスト量子鍵交換も設定でき、すでに運用している設定を解説する機能も備えています。
ツールを開く47 日証明書計算ツール
200 → 100 → 47 日への更新を計画
公的に信頼された TLS 証明書の有効期間は、2029 年までに 398 日から 200 日、100 日、そして最終的に 47 日へと短縮されます。これが手持ちの証明書にどう影響するかを確認できます。年間の更新回数とドメイン検証の回数、次の期限、更新ポリシーが通用しなくなる箇所がわかります。
ツールを開くCAA レコード生成ツール
発行できる CA を制限
どの DNS ホスティングや管理画面でも使える CAA レコード(RFC 8659、RFC 8657)を生成します。証明書とワイルドカード証明書を発行できる CA、その ACME アカウントと検証方法を指定できます。さらに、CA が現在 DNS で参照する内容を確認し、CCADB レポートに載っているすべての CA について判定を表示します。
ツールを開くTLSA レコード生成ツール
証明書から DANE レコードを生成
証明書、チェーン、公開鍵、CSR から DANE 用の TLSA レコード(RFC 6698、RFC 7671)を生成します。デフォルトは 3 1 1 で、鍵のロールオーバー用のレコードも作成できます。さらに、公開済みのレコードをサーバーが提示するチェーンと照合し、DNSSEC の状態も表示します。
ツールを開くsecurity.txt 生成ツール
security.txt を作成・チェック
脆弱性の報告方法を研究者に伝える security.txt ファイル(RFC 9116)を、連絡先、有効期限、暗号化鍵、ポリシーを指定して作成できます。公開しているファイルを検証することもでき、すべてのフィールド、有効期限、配置場所、OpenPGP 署名の構造をチェックします。
ツールを開くDNSSEC インスペクター
信頼の連鎖をたどる
IANA のルートトラストアンカーから任意の名前とレコードタイプまで、DNSSEC の信頼の連鎖をたどります。DS のダイジェスト、DNSKEY、RRSIG はすべて、このツール独自の RSA、ECDSA、EdDSA の実装によりブラウザー内で検証します。不在証明の内容も解説します。
ツールを開くブラウザーのポスト量子チェック
ブラウザーの ML-KEM 対応を確認
ワンクリックで、お使いのブラウザーが TCP 上の TLS と QUIC(HTTP/3)内のそれぞれで、Cloudflare とポスト量子ハイブリッド方式の X25519MLKEM768 をネゴシエートしているかを確認できます。それがそのバージョンで想定される動作かどうか、通信を傍受するプロキシや古いバージョンで何が変わるかもわかります。
ツールを開くTLS フィンガープリント(JA4)
ブラウザーの JA4 を確認
ecdsa.com のエッジが観測した、お使いのブラウザーの JA4 フィンガープリントを、プロトコル、TLS バージョン、暗号スイート、拡張、ALPN と部分ごとに解説します。貼り付けた任意のフィンガープリントや ClientHello から JA4 を計算するツールもあります。
ツールを開くドメイン一括チェッカー
ドメイン一覧の TLS と有効期限
ドメインの一覧を貼り付けると、ecdsa.com の API ですべてをまとめて確認できます。各ドメインの TLS の評価、証明書の有効期限と鍵アルゴリズム、TLS 1.3、レガシープロトコル、チェーンの欠落の有無を確認でき、サマリーと CSV または JSON でのエクスポートにも対応しています。
ツールを開く