本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

GC256D

GC256D は、256 ビットの GOST 曲線 CryptoPro-C(id-GostR3410-2001-CryptoPro-C-ParamSet)です。

GC256D は、256 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 256 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 128 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

GC256D は RFC 4357 §11.4 で GOST R 34.10-2001 向けに定義され、GOST R 34.10-2012 でも paramSetD として引き継がれています(RFC 9215)。256 ビットの素数上の曲線 y² = x³ − 3x + 32858 で、位数は素数です。

そのパラメーターは鍵交換用に CryptoPro-XchB としても登録されています。TLS ではグループ GC256D、署名方式 gostr34102012_256d として登録されています(RFC 9189、RFC 9367)。

規格での名称

規格名称
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

オブジェクト識別子

ドメインパラメーター

256 ビットの素体 · 約 128 ビットセキュリティ

有限体の素数 p
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
係数 a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
係数 b
0x805a
ベースポイントの x 座標
0x0
ベースポイントの y 座標
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
ベースポイントの位数 n
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
コファクター h
0x1

採用例

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

レジストリでの識別子

TLS のサポートされるグループ
GC256D 0x0025
TLS の署名方式
gostr34102012_256d 0x070C

規格と参考文献

すべての曲線