Saltar al contenido
ecdsa.com
AceptableWeierstrass corta

GC256D

GC256D es la curva GOST de 256 bits CryptoPro-C (id-GostR3410-2001-CryptoPro-C-ParamSet).

GC256D es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 256 bits, con un subgrupo de orden primo de 256 bits y cofactor 1; su nivel de seguridad estimado es de 128 bits. Estado: segura, pero regional o de nicho.

GC256D se definió para GOST R 34.10-2001 en el RFC 4357 §11.4, y GOST R 34.10-2012 la conserva como paramSetD (RFC 9215). Es y² = x³ − 3x + 32858 sobre un primo de 256 bits, con orden primo.

Sus parámetros también están registrados para el intercambio de claves como CryptoPro-XchB. TLS la incluye como grupo GC256D con el esquema de firma gostr34102012_256d (RFC 9189, RFC 9367).

Nombres en los estándares

EstándarNombre
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

Identificadores de objeto

Parámetros de dominio

campo primo de 256 bits · seguridad de unos 128 bits

Primo del campo p
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
Coeficiente a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
Coeficiente b
0x805a
Punto base x
0x0
Punto base y
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
Orden n del punto base
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
Cofactor h
0x1

Se usa en

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identificadores en registros

Grupos admitidos de TLS
GC256D 0x0025
Esquemas de firma de TLS
gostr34102012_256d 0x070C

Estándares y referencias

Todas las curvas