Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

GC256D

GC256D est la courbe GOST de 256 bits CryptoPro-C (id-GostR3410-2001-CryptoPro-C-ParamSet).

GC256D est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 256 bits, avec un sous-groupe d’ordre premier de 256 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 128 bits. Statut : sûre, mais régionale ou de niche.

GC256D a été définie pour GOST R 34.10-2001 dans la RFC 4357, §11.4, et GOST R 34.10-2012 la conserve sous le nom paramSetD (RFC 9215). C’est la courbe d’ordre premier y² = x³ − 3x + 32858 sur un corps premier de 256 bits.

Ses paramètres sont aussi enregistrés pour l’échange de clés sous le nom CryptoPro-XchB. TLS la répertorie comme groupe GC256D, avec le schéma de signature gostr34102012_256d (RFC 9189, RFC 9367).

Noms dans les normes

NormeNom
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

Identifiants d’objet

Paramètres de domaine

corps premier de 256 bits · sécurité d’environ 128 bits

Nombre premier p du corps
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
Coefficient a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
Coefficient b
0x805a
Coordonnée x du point de base
0x0
Coordonnée y du point de base
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
Ordre n du point de base
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
Cofacteur h
0x1

Utilisée dans

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identifiants dans les registres

Groupes pris en charge par TLS
GC256D 0x0025
Schémas de signature TLS
gostr34102012_256d 0x070C

Normes et références

Toutes les courbes