跳到主要内容
ecdsa.com
可接受短 Weierstrass 形式

GC256D

GC256D 即 256 位 GOST 曲线 CryptoPro-C(id-GostR3410-2001-CryptoPro-C-ParamSet)。

GC256D 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 256 位素域上,其素数阶子群为 256 位,余因子为 1;估计安全级别为 128 位。状态:安全,但仅限特定地区或小众场景。

GC256D 在 RFC 4357 §11.4 中为 GOST R 34.10-2001 而定义,GOST R 34.10-2012 将其保留为 paramSetD(RFC 9215)。它是某个 256 位素数上的曲线 y² = x³ − 3x + 32858,阶为素数。

它的参数还以 CryptoPro-XchB 之名注册用于密钥交换。TLS 将其列为组 GC256D,对应的签名方案为 gostr34102012_256d(RFC 9189、RFC 9367)。

各标准中的名称

标准名称
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

对象标识符

域参数

256 位素域 · 约 128 位安全强度

域素数 p
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
系数 a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
系数 b
0x805a
基点 x 坐标
0x0
基点 y 坐标
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
基点的阶 n
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
余因子 h
0x1

用于

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

注册表中的标识符

TLS 支持的组
GC256D 0x0025
TLS 签名方案
gostr34102012_256d 0x070C

标准与参考资料

全部曲线