全部工具
面向所有与签名打交道的人的免费工具。每个工具都在你的浏览器中运行——粘贴密钥、令牌或签名,任何数据都不会离开页面——除非某个工具另有说明,并解释它会发送什么。
91 个工具
签名
7 个工具验证签名、转换签名编码、找出验证不通过的原因、生成测试向量、查看底层的椭圆曲线运算,以及把秘密拆分为 Shamir 份额——每个工具都在你的浏览器中运行。
JOSE 与 JWT
9 个工具签名、解码和验证 JSON Web 令牌,解密 JWE,读取 PASETO 令牌,生成密钥并在 JWK、PEM 和 SSH 格式之间转换,以及构建或检查背后的密钥集——出了问题会用通俗的语言解释原因。
证书与密钥
17 个工具解码证书、证书签名请求、吊销列表、OCSP 响应和证书透明度时间戳;生成 CSR 及其密钥,检查密钥、证书和 CSR 是否相互匹配,比较两张证书,整理证书链顺序并获取缺失的中间证书,计算 SPKI 公钥固定值,检测密钥是否存在已知弱点;打开 PFX 文件,拆分 PEM 合集文件,浏览原始 ASN.1 结构,生成你需要的 openssl 命令。密钥始终留在你的浏览器中;少数需要我们服务器的检查会在发送之前说明要发送什么。
X.509 证书解码器
查看证书内容
打开工具SSH 公钥查看器
解码 authorized_keys 条目
打开工具OpenSSL 命令生成器
生成你需要的 openssl 命令
打开工具ASN.1 查看器
解码任意 DER 或 BER 结构
打开工具DER 文本编辑器
以可读文本编辑 DER
打开工具CSR 解码器
赶在 CA 之前检查 CSR
打开工具CRL 解码器
读取 CRL 并查找序列号
打开工具OCSP 解码器
读取 OCSP 响应,生成请求
打开工具SCT 解码器
证书被哪些 CT 日志记录过
打开工具PFX 查看器
查看 .pfx 或 .p12 文件的内容
打开工具PEM 证书包拆分工具
把 PEM 文件拆分成干净的部分
打开工具CSR 生成器
在本地创建 CSR 及其密钥
打开工具密钥与证书匹配检测
这个密钥和证书是否匹配?
打开工具证书对比
两张证书之间有哪些变化
打开工具SPKI 固定值生成器
移动应用的公钥固定值
打开工具弱密钥检测
找出已被攻破和已泄露的密钥
打开工具证书链构建工具
排序并修复证书链
打开工具TLS 与 DNS
9 个工具为你的服务器生成 TLS 配置,为 47 天证书做好准备,发布 CAA、TLSA 和 security.txt 记录,沿 DNSSEC 信任链逐级追踪,查看你的浏览器是否已在使用后量子 TLS,并一次检查多个域名。每个页面都会写明它是否通过网络发送数据,以及具体发送什么。
电子邮件
5 个工具找出 DKIM 签名验证失败的原因,查看 ARC 链中每个转发方记录了什么,为你自己的域名创建密钥和 DNS 记录,并检查品牌的 BIMI 记录和标志证书(Mark Certificate)。DKIM 和 ARC 工具在你的浏览器中分析邮件,只通过 DNS-over-HTTPS 查询公钥记录的公开名称;完整的 SPF、DKIM、DMARC、ARC、BIMI 和 MTA-STS 分析在我们的服务器上运行,只有在你同意之后,邮件才会发送到服务器。
Web3
13 个工具解码原始以太坊交易或 EIP-7702 委托,在签名之前看清类型化数据签名会交出什么,验证以太坊消息或登录请求的签名者,将 Safe 交易的哈希与硬件钱包上显示的哈希逐一比对,查找重复使用的 ECDSA nonce,查看 PSBT 和 xpub,以及验证比特币(BIP-137/322)、Solana 和 Nostr 签名。所有操作都在你的浏览器中运行;只有在你要求时,才会向公共 RPC 节点发起链上查询。工具从不接受助记词和私钥。
Nonce 重用检测
扫描比特币地址,查找重复的 r 值
打开工具EIP-712 查看器
类型化数据签名实际允许做什么
打开工具以太坊签名验证工具
这条以太坊消息是谁签名的?
打开工具SIWE 验证工具
检查以太坊登录(SIWE)消息
打开工具Safe 交易哈希
核对 Safe 签名者实际签署的内容
打开工具以太坊交易解码器
解码已签名的原始交易
打开工具EIP-7702 委托解码器
谁委托给了哪个合约
打开工具以太坊 nonce 重用检测
找出以太坊签名中重复的 r
打开工具比特币消息验证工具
验证 BIP-137 和 BIP-322 签名
打开工具PSBT 查看器
签名前解码并检查 PSBT
打开工具xpub 查看器
从 xpub 派生地址
打开工具Solana 消息验证工具
验证 Solana 签名消息
打开工具Nostr 事件验证工具
验证 Nostr 事件并解码 npub
打开工具后量子
6 个工具动手实践后量子密码:用 ML-DSA 和 SLH-DSA 签名,用 ML-KEM 以及浏览器已在使用的 X25519MLKEM768 混合方案做密钥封装,对 100 多种 liboqs 算法做基准测试,查看后量子证书、HPKE 和 age——全部在浏览器中完成,不上传任何数据。
身份与通行密钥
12 个工具用真实的通行密钥注册和登录,并通过 FIDO 元数据服务识别其背后的认证器;校验 OpenID Connect ID 令牌和 SAML 响应;查看欧盟数字身份钱包的凭证(SD-JWT VC 和 mdoc)、DPoP 证明、COSE 和 CWT,以及由机器人和 AI 智能体签名的 HTTP 请求。令牌和密钥在你的浏览器中检查;认证器查询只向我们的服务器请求公开元数据。
WebAuthn / 通行密钥查看器
解码通行密钥的注册和登录数据
打开工具通行密钥沙盒
试用通行密钥注册和登录
打开工具OIDC ID 令牌校验器
校验 OpenID Connect ID 令牌
打开工具SD-JWT 查看器
解码并验证 SD-JWT VC
打开工具mdoc / mDL 查看器
验证移动驾驶证
打开工具HTTP 消息签名
验证 RFC 9421 签名
打开工具Web Bot Auth 检测
验证已签名的机器人和智能体请求
打开工具COSE 与 CWT 解码器
解码并验证 COSE 和 CWT
打开工具DPoP 证明查看器
检查 RFC 9449 DPoP 证明
打开工具SAML 查看器
验证 SAML 签名和断言
打开工具XAdES 查看器
查看 XAdES 电子签名
打开工具AAGUID 查询
识别通行密钥或安全密钥
打开工具代码与文档签名
12 个工具运行发布版本之前,先确认它到底是什么。验证 Sigstore 签名包和 npm 来源证明,一直追溯到构建它们的仓库、工作流和提交;读取 SLSA 和 in-toto 证明;对照 allowed_signers 检查 SSH 签名的 Git 提交和文件;以及查看 Windows 可执行文件、Android APK 和 Java 归档文件的签名。文档和媒体也不例外:无需上传任何内容即可验证 PDF 签名(PAdES、LTV)和签名邮件(S/MIME),解码 RFC 3161 时间戳,读取图片和视频的内容凭证(C2PA),以及证明密钥是在 YubiKey 上生成的。文件和密钥都留在你的浏览器中;npm 检测工具会向公共注册表查询你指定的包,可选的 Sigstore 二次检查只向我们的服务器发送签名包和文件摘要。
Sigstore 签名包验证工具
cosign、npm 和 GitHub 证明的签名包
打开工具npm 来源证明检测
npm 包究竟是在哪里构建的
打开工具in-toto 证明查看器
SLSA 来源证明、DSSE 和 .intoto.jsonl
打开工具SSH 签名验证工具
ssh-keygen -Y 文件、已签名的提交和标签
打开工具Authenticode 查看器
Windows EXE、DLL 和 SYS 文件的签名
打开工具APK 签名查看器
Android APK 签名方案 v1~v4
打开工具JAR 签名查看器
逐个条目检查已签名的 JAR、WAR 和 EAR 文件
打开工具PDF 签名验证工具
无需上传即可检查 PDF 签名
打开工具S/MIME 签名验证工具
在本地检查签名邮件
打开工具时间戳令牌查看器
解码并验证 RFC 3161 令牌
打开工具C2PA 内容凭证查看器
读取并验证内容凭证
打开工具YubiKey 证明验证工具
证明密钥是在 YubiKey 上生成的
打开工具OpenPGP
1 个工具粘贴 ASCII 封装(armored)格式的密钥、签名或消息,或者打开 .gpg、.sig 或 .asc 文件,即可查看每个数据包:子密钥、用户 ID 和自签名、过期和吊销信息、算法(包括 RFC 9580 v6 密钥和新的后量子算法 ID)。用签名者的公钥验证分离签名、明文签名和内联签名——和 gpg --verify 一样,但无需安装 GnuPG。所有操作都在你的浏览器中运行,私钥会被直接拒绝,不会被读取。