Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

GC256D

A GC256D é a curva GOST de 256 bits CryptoPro-C (id-GostR3410-2001-CryptoPro-C-ParamSet).

GC256D é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 256 bits com um subgrupo de ordem prima de 256 bits e cofator 1; o nível de segurança estimado é de 128 bits. Status: segura, mas regional ou de nicho.

A GC256D foi definida para o GOST R 34.10-2001 na RFC 4357 §11.4, e o GOST R 34.10-2012 a mantém como paramSetD (RFC 9215). Ela é y² = x³ − 3x + 32858 sobre um primo de 256 bits, com ordem prima.

Os parâmetros dela também estão registrados para troca de chaves como CryptoPro-XchB. O TLS a lista como grupo GC256D, com o esquema de assinatura gostr34102012_256d (RFC 9189, RFC 9367).

Nomes nos padrões

PadrãoNome
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

Identificadores de objeto

Parâmetros de domínio

campo primo de 256 bits · cerca de 128 bits de segurança

Primo p do campo
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
Coeficiente a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
Coeficiente b
0x805a
Coordenada x do ponto base
0x0
Coordenada y do ponto base
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
Ordem n do ponto base
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
Cofator h
0x1

Usada em

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Identificadores em registros

Grupos suportados do TLS
GC256D 0x0025
Esquemas de assinatura do TLS
gostr34102012_256d 0x070C

Padrões e referências

Todas as curvas