Zum Inhalt springen
ecdsa.com
AkzeptabelKurze Weierstraß-Form

GC256D

GC256D ist die 256-Bit-GOST-Kurve CryptoPro-C (id-GostR3410-2001-CryptoPro-C-ParamSet).

GC256D ist eine Kurve in kurzer Weierstraß-Form y² = x³ + ax + b über einem 256-Bit-Primkörper mit einer 256-Bit-Untergruppe von Primordnung und dem Kofaktor 1; das geschätzte Sicherheitsniveau beträgt 128 Bit. Status: sicher, aber nur regional oder in Nischen verbreitet.

GC256D wurde für GOST R 34.10-2001 in RFC 4357 §11.4 definiert, und GOST R 34.10-2012 übernimmt sie als paramSetD (RFC 9215). Die Kurve ist y² = x³ − 3x + 32858 über einer 256-Bit-Primzahl und hat Primordnung.

Die Parameter der Kurve sind außerdem als CryptoPro-XchB für den Schlüsselaustausch registriert. TLS führt sie als Gruppe GC256D mit dem Signaturverfahren gostr34102012_256d (RFC 9189, RFC 9367).

Namen in Standards

StandardName
IANA TLS (RFC 9189)GC256D
TC 26id-tc26-gost-3410-2012-256-paramSetD
RFC 4357id-GostR3410-2001-CryptoPro-C-ParamSet
RFC 4357id-GostR3410-2001-CryptoPro-XchB-ParamSet

Object Identifier

Domainparameter

256-Bit-Primkörper · etwa 128-Bit-Sicherheit

Primzahl p des Körpers
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d759b
Koeffizient a
0x9b9f605f5a858107ab1ec85e6b41c8aacf846e86789051d37998f7b9022d7598
Koeffizient b
0x805a
x-Koordinate des Basispunkts
0x0
y-Koordinate des Basispunkts
0x41ece55743711a8c3cbf3783cd08c0ee4d4dc440d4641a8f366e550dfdb3bb67
Ordnung n des Basispunkts
0x9b9f605f5a858107ab1ec85e6b41c8aa582ca3511eddfb74f02f3a6598980bb9
Kofaktor h
0x1

Verwendet in

  • GOST R 34.10-2012 signatures
  • TLS 1.2 and 1.3 GOST cipher suites (RFC 9189, RFC 9367)
  • Russian government PKI

Kennungen in Registern

TLS-Supported-Groups
GC256D 0x0025
TLS-Signaturverfahren
gostr34102012_256d 0x070C

Standards und Quellen

Alle Kurven