0x0001 | sect163k1 | sect163k1 (0x0001) es Diffie–Hellman de curva elíptica sobre sect163k1.sect163k1 | D | RFC 8422RFC 9847 |
0x0002 | sect163r1 | sect163r1 (0x0002) es Diffie–Hellman de curva elíptica sobre sect163r1. | D | RFC 8422RFC 9847 |
0x0003 | sect163r2 | sect163r2 (0x0003) es Diffie–Hellman de curva elíptica sobre sect163r2.sect163r2 | D | RFC 8422RFC 9847 |
0x0004 | sect193r1 | sect193r1 (0x0004) es Diffie–Hellman de curva elíptica sobre sect193r1. | D | RFC 8422RFC 9847 |
0x0005 | sect193r2 | sect193r2 (0x0005) es Diffie–Hellman de curva elíptica sobre sect193r2. | D | RFC 8422RFC 9847 |
0x0006 | sect233k1 | sect233k1 (0x0006) es Diffie–Hellman de curva elíptica sobre sect233k1.sect233k1 | D | RFC 8422RFC 9847 |
0x0007 | sect233r1 | sect233r1 (0x0007) es Diffie–Hellman de curva elíptica sobre sect233r1.sect233r1 | D | RFC 8422RFC 9847 |
0x0008 | sect239k1 | sect239k1 (0x0008) es Diffie–Hellman de curva elíptica sobre sect239k1. | D | RFC 8422RFC 9847 |
0x0009 | sect283k1 | sect283k1 (0x0009) es Diffie–Hellman de curva elíptica sobre sect283k1.sect283k1 | N | RFC 8422 |
0x000A | sect283r1 | sect283r1 (0x000A) es Diffie–Hellman de curva elíptica sobre sect283r1.sect283r1 | N | RFC 8422 |
0x000B | sect409k1 | sect409k1 (0x000B) es Diffie–Hellman de curva elíptica sobre sect409k1.sect409k1 | N | RFC 8422 |
0x000C | sect409r1 | sect409r1 (0x000C) es Diffie–Hellman de curva elíptica sobre sect409r1.sect409r1 | N | RFC 8422 |
0x000D | sect571k1 | sect571k1 (0x000D) es Diffie–Hellman de curva elíptica sobre sect571k1.sect571k1 | N | RFC 8422 |
0x000E | sect571r1 | sect571r1 (0x000E) es Diffie–Hellman de curva elíptica sobre sect571r1.sect571r1 | N | RFC 8422 |
0x000F | secp160k1 | secp160k1 (0x000F) es Diffie–Hellman de curva elíptica sobre secp160k1. | D | RFC 8422RFC 9847 |
0x0010 | secp160r1 | secp160r1 (0x0010) es Diffie–Hellman de curva elíptica sobre secp160r1. | D | RFC 8422RFC 9847 |
0x0011 | secp160r2 | secp160r2 (0x0011) es Diffie–Hellman de curva elíptica sobre secp160r2. | D | RFC 8422RFC 9847 |
0x0012 | secp192k1 | secp192k1 (0x0012) es Diffie–Hellman de curva elíptica sobre secp192k1.secp192k1 | D | RFC 8422RFC 9847 |
0x0013 | secp192r1 | secp192r1 (0x0013) es Diffie–Hellman de curva elíptica sobre P-192.P-192 | D | RFC 8422RFC 9847 |
0x0014 | secp224k1 | secp224k1 (0x0014) es Diffie–Hellman de curva elíptica sobre secp224k1.secp224k1 | D | RFC 8422RFC 9847 |
0x0015 | secp224r1 | secp224r1 (0x0015) es Diffie–Hellman de curva elíptica sobre P-224.P-224 | D | RFC 8422RFC 9847 |
0x0016 | secp256k1 | secp256k1 (0x0016) es Diffie–Hellman de curva elíptica sobre secp256k1.secp256k1 | N | RFC 8422 |
0x0017Nota | secp256r1 | secp256r1 (0x0017) es Diffie–Hellman de curva elíptica sobre P-256.P-256 | Y | RFC 8422 |
0x0018Nota | secp384r1 | secp384r1 (0x0018) es Diffie–Hellman de curva elíptica sobre P-384.P-384 | Y | RFC 8422 |
0x0019 | secp521r1 | secp521r1 (0x0019) es Diffie–Hellman de curva elíptica sobre P-521.P-521 | N | RFC 8422 |
0x001A | brainpoolP256r1 | brainpoolP256r1 (0x001A) es Diffie–Hellman de curva elíptica sobre brainpoolP256r1.brainpoolP256r1 | N | RFC 7027 |
0x001B | brainpoolP384r1 | brainpoolP384r1 (0x001B) es Diffie–Hellman de curva elíptica sobre brainpoolP384r1.brainpoolP384r1 | N | RFC 7027 |
0x001C | brainpoolP512r1 | brainpoolP512r1 (0x001C) es Diffie–Hellman de curva elíptica sobre brainpoolP512r1.brainpoolP512r1 | N | RFC 7027 |
0x001DNota | x25519 | x25519 (0x001D) es Diffie–Hellman de curva elíptica sobre curve25519.curve25519 | Y | RFC 9846RFC 8422 |
0x001E | x448 | x448 (0x001E) es Diffie–Hellman de curva elíptica sobre curve448.curve448 | Y | RFC 9846RFC 8422 |
0x001F | brainpoolP256r1tls13 | brainpoolP256r1tls13 (0x001F) es Diffie–Hellman de curva elíptica sobre brainpoolP256r1.brainpoolP256r1 | N | RFC 8734 |
0x0020 | brainpoolP384r1tls13 | brainpoolP384r1tls13 (0x0020) es Diffie–Hellman de curva elíptica sobre brainpoolP384r1.brainpoolP384r1 | N | RFC 8734 |
0x0021 | brainpoolP512r1tls13 | brainpoolP512r1tls13 (0x0021) es Diffie–Hellman de curva elíptica sobre brainpoolP512r1.brainpoolP512r1 | N | RFC 8734 |
0x0022 | GC256A | GC256A (0x0022) es Diffie–Hellman de curva elíptica sobre GC256A.GC256A | N | RFC 9189 |
0x0023 | GC256B | GC256B (0x0023) es Diffie–Hellman de curva elíptica sobre GC256B.GC256B | N | RFC 9189 |
0x0024 | GC256C | GC256C (0x0024) es Diffie–Hellman de curva elíptica sobre GC256C.GC256C | N | RFC 9189 |
0x0025 | GC256D | GC256D (0x0025) es Diffie–Hellman de curva elíptica sobre GC256D.GC256D | N | RFC 9189 |
0x0026 | GC512A | GC512A (0x0026) es Diffie–Hellman de curva elíptica sobre GC512A.GC512A | N | RFC 9189 |
0x0027 | GC512B | GC512B (0x0027) es Diffie–Hellman de curva elíptica sobre GC512B.GC512B | N | RFC 9189 |
0x0028 | GC512C | GC512C (0x0028) es Diffie–Hellman de curva elíptica sobre GC512C.GC512C | N | RFC 9189 |
0x0029 | curveSM2 | curveSM2 (0x0029) es Diffie–Hellman de curva elíptica sobre SM2.SM2 | N | RFC 8998 |
0x0100Nota | ffdhe2048 | ffdhe2048 (0x0100) es un grupo Diffie–Hellman de campo finito de 2048 bits, definido en el RFC 7919. | N | RFC 7919 |
0x0101 | ffdhe3072 | ffdhe3072 (0x0101) es un grupo Diffie–Hellman de campo finito de 3072 bits, definido en el RFC 7919. | N | RFC 7919 |
0x0102 | ffdhe4096 | ffdhe4096 (0x0102) es un grupo Diffie–Hellman de campo finito de 4096 bits, definido en el RFC 7919. | N | RFC 7919 |
0x0103 | ffdhe6144 | ffdhe6144 (0x0103) es un grupo Diffie–Hellman de campo finito de 6144 bits, definido en el RFC 7919. | N | RFC 7919 |
0x0104 | ffdhe8192 | ffdhe8192 (0x0104) es un grupo Diffie–Hellman de campo finito de 8192 bits, definido en el RFC 7919. | N | RFC 7919 |
0x0200 | MLKEM512 | MLKEM512 (0x0200) es un acuerdo de claves poscuántico solo con ML-KEM-512 (FIPS 203), sin componente clásico. | N | RFC-ietf-tls-mlkem-10 |
0x0201Nota | MLKEM768 | MLKEM768 (0x0201) es un acuerdo de claves poscuántico solo con ML-KEM-768 (FIPS 203), sin componente clásico. | N | RFC-ietf-tls-mlkem-10 |
0x0202 | MLKEM1024 | MLKEM1024 (0x0202) es un acuerdo de claves poscuántico solo con ML-KEM-1024 (FIPS 203), sin componente clásico. | N | RFC-ietf-tls-mlkem-10 |
0x0A0A | Reserved | 0x0A0A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x11E9 | SecP256r1MLKEM512 | SecP256r1MLKEM512 (0x11E9) es un intercambio de claves híbrido: el secreto compartido combina secp256r1 con ML-KEM-512, así que sigue siendo secreto mientras resista cualquiera de los dos.P-256 | N | draft-rosomakho-tls-ecdhe-mlkem512-00 |
0x11EA | MLKEM512X25519 | MLKEM512X25519 (0x11EA) es un intercambio de claves híbrido: el secreto compartido combina X25519 con ML-KEM-512, así que sigue siendo secreto mientras resista cualquiera de los dos.curve25519 | N | draft-rosomakho-tls-ecdhe-mlkem512-00 |
0x11EBNota | SecP256r1MLKEM768 | SecP256r1MLKEM768 (0x11EB) es un intercambio de claves híbrido: el secreto compartido combina secp256r1 con ML-KEM-768, así que sigue siendo secreto mientras resista cualquiera de los dos.P-256 | N | RFC 10024 |
0x11ECNota | X25519MLKEM768 | X25519MLKEM768 (0x11EC) es un intercambio de claves híbrido: el secreto compartido combina X25519 con ML-KEM-768, así que sigue siendo secreto mientras resista cualquiera de los dos.curve25519 | Y | RFC 10024 |
0x11ED | SecP384r1MLKEM1024 | SecP384r1MLKEM1024 (0x11ED) es un intercambio de claves híbrido: el secreto compartido combina secp384r1 con ML-KEM-1024, así que sigue siendo secreto mientras resista cualquiera de los dos.P-384 | N | RFC 10024 |
0x11EE | curveSM2MLKEM768 | curveSM2MLKEM768 (0x11EE) es un intercambio de claves híbrido: el secreto compartido combina curveSM2 con ML-KEM-768, así que sigue siendo secreto mientras resista cualquiera de los dos.SM2 | N | draft-yang-tls-hybrid-sm2-mlkem-03 |
0x1A1A | Reserved | 0x1A1A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x2A2A | Reserved | 0x2A2A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x3A3A | Reserved | 0x3A3A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x4A4A | Reserved | 0x4A4A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x5A5A | Reserved | 0x5A5A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x6399 | X25519Kyber768Draft00 | X25519Kyber768Draft00 (0x6399) es un intercambio de claves híbrido: el secreto compartido combina X25519 con Kyber768 (draft 00), así que sigue siendo secreto mientras resista cualquiera de los dos. Es un punto de código anterior al estándar y ya está obsoleto.curve25519 | D | draft-tls-westerbaan-xyber768d00-02RFC 10024 |
0x639A | SecP256r1Kyber768Draft00 | SecP256r1Kyber768Draft00 (0x639A) es un intercambio de claves híbrido: el secreto compartido combina secp256r1 con Kyber768 (draft 00), así que sigue siendo secreto mientras resista cualquiera de los dos. Es un punto de código anterior al estándar y ya está obsoleto.P-256 | D | draft-kwiatkowski-tls-ecdhe-kyber-01RFC 10024 |
0x6A6A | Reserved | 0x6A6A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x7A7A | Reserved | 0x7A7A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x8A8A | Reserved | 0x8A8A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0x9A9A | Reserved | 0x9A9A es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xAAAA | Reserved | 0xAAAA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xBABA | Reserved | 0xBABA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xCACA | Reserved | 0xCACA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xDADA | Reserved | 0xDADA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xEAEA | Reserved | 0xEAEA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xFAFA | Reserved | 0xFAFA es un valor GREASE (RFC 8701) del registro de grupos admitidos de TLS: los clientes envían estos valores al azar para que los servidores aprendan a ignorar las entradas desconocidas. Nunca identifica un algoritmo real. | N | RFC 8701 |
0xFF01 | arbitrary_explicit_prime_curves | arbitrary_explicit_prime_curves (0xFF01) indica al otro extremo que los parámetros de la curva se envían de forma explícita en lugar de nombrar un grupo. El RFC 8422 declara en desuso las curvas explícitas. | N | RFC 8422 |
0xFF02 | arbitrary_explicit_char2_curves | arbitrary_explicit_char2_curves (0xFF02) indica al otro extremo que los parámetros de la curva se envían de forma explícita en lugar de nombrar un grupo. El RFC 8422 declara en desuso las curvas explícitas. | N | RFC 8422 |