curve448 es una curva de Montgomery By² = x³ + Ax² + x sobre un campo primo de 448 bits, con un subgrupo de orden primo de 446 bits y cofactor 4; su nivel de seguridad estimado es de 224 bits. Estado: recomendada para sistemas nuevos.
Curve448 es y² = x³ + 156326x² + x sobre el primo «Goldilocks» 2^448 − 2^224 − 1, presentada por Mike Hamburg en 2015 y adoptada en el RFC 7748. Su grupo tiene orden 4·n, con n primo de 446 bits, lo que da unos 224 bits de seguridad.
Las claves y los secretos compartidos de X448 ocupan 56 bytes. TLS 1.3 (x448, marcado como Recommended por la IANA), SSH (curve448-sha512, RFC 8731) y HPKE (DHKEM(X448, HKDF-SHA512)) lo definen, pero se usa mucho menos que X25519. Su equivalente de Edwards es edwards448, que se usa para Ed448.
Nombres en los estándares
| Estándar | Nombre |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
Identificadores de objeto
Parámetros de dominio
campo primo de 448 bits · seguridad de unos 224 bits
- Primo del campo p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coeficiente a
- 0x262a6
- Coeficiente b
- 0x1
- Punto base x
- 0x5
- Punto base y
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- Orden n del punto base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofactor h
- 0x4
Se usa en
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
Identificadores en registros
← Todas las curvas