curve448 ist eine Montgomery-Kurve By² = x³ + Ax² + x über einem 448-Bit-Primkörper mit einer 446-Bit-Untergruppe von Primordnung und dem Kofaktor 4; das geschätzte Sicherheitsniveau beträgt 224 Bit. Status: empfohlen für Neuentwicklungen.
Curve448 ist y² = x³ + 156326x² + x über der „Goldilocks“-Primzahl 2^448 − 2^224 − 1, 2015 von Mike Hamburg vorgestellt und in RFC 7748 übernommen. Die Gruppe hat die Ordnung 4·n mit einer 446-Bit-Primzahl n, was ein Sicherheitsniveau von etwa 224 Bit ergibt.
Schlüssel und gemeinsame Geheimnisse von X448 sind 56 Byte lang. TLS 1.3 (x448, von IANA als „Recommended“ markiert), SSH (curve448-sha512, RFC 8731) und HPKE (DHKEM(X448, HKDF-SHA512)) definieren X448, doch es wird weit seltener verwendet als X25519. Das Gegenstück in Edwards-Form ist edwards448, die Kurve von Ed448.
Namen in Standards
| Standard | Name |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
Domainparameter
448-Bit-Primkörper · etwa 224-Bit-Sicherheit
- Primzahl p des Körpers
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Koeffizient a
- 0x262a6
- Koeffizient b
- 0x1
- x-Koordinate des Basispunkts
- 0x5
- y-Koordinate des Basispunkts
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- Ordnung n des Basispunkts
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Kofaktor h
- 0x4
Verwendet in
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
Kennungen in Registern
- Elliptische Kurven für COSE
- X448 5
← Alle Kurven