curve448 は、448 ビットの素体上のモンゴメリ形式の曲線 By² = x³ + Ax² + x で、位数が 446 ビットの素数である部分群とコファクター 4 を持ちます。推定セキュリティレベルは 224 ビットです。ステータス:新しいシステムに推奨。
Curve448 は「Goldilocks」素数 2^448 − 2^224 − 1 上の曲線 y² = x³ + 156326x² + x で、2015年に Mike Hamburg が提案し、RFC 7748 に採用されました。群の位数は 4·n(n は 446 ビットの素数)で、約 224 ビットのセキュリティを提供します。
X448 の鍵と共有秘密は 56 バイトです。TLS 1.3(x448、IANA が「推奨」に指定)、SSH(curve448-sha512、RFC 8731)、HPKE(DHKEM(X448, HKDF-SHA512))で定義されていますが、X25519 に比べると利用ははるかに限られています。エドワーズ形式の対となる曲線は edwards448 で、Ed448 に使われます。
規格での名称
| 規格 | 名称 |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
ドメインパラメーター
448 ビットの素体 · 約 224 ビットセキュリティ
- 有限体の素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- 係数 a
- 0x262a6
- 係数 b
- 0x1
- ベースポイントの x 座標
- 0x5
- ベースポイントの y 座標
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- ベースポイントの位数 n
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- コファクター h
- 0x4
採用例
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
← すべての曲線