本文へスキップ
ecdsa.com
JOSE、JWK、COSE

COSE のアルゴリズム、鍵の種類、曲線

CWT、WebAuthn、mdoc などの CBOR 形式で使われる COSE のアルゴリズム識別子、鍵の種類、楕円曲線を、IANA レジストリの推奨状況とともに掲載しています。

105 件中 105 件を表示

COSE アルゴリズム · 86 件

CWT、WebAuthn、mDL などの CBOR ベースの形式で使われる COSE アルゴリズム識別子です。

値名称説明参考文献
-65535RS1RS1(COSE アルゴリズム -65535):RSASSA-PKCS1-v1_5 using SHA-1。ファミリー:RSASSA-PKCS1-v1_5。推奨:非推奨。RFC 8812RFC 9053
-65534A128CTRA128CTR(COSE アルゴリズム -65534):AES-CTR w/ 128-bit key。ファミリー:認証なしの AES-CTR。推奨:非推奨。RFC 9459
-65533A192CTRA192CTR(COSE アルゴリズム -65533):AES-CTR w/ 192-bit key。ファミリー:認証なしの AES-CTR。推奨:非推奨。RFC 9459
-65532A256CTRA256CTR(COSE アルゴリズム -65532):AES-CTR w/ 256-bit key。ファミリー:認証なしの AES-CTR。推奨:非推奨。RFC 9459
-65531A128CBCA128CBC(COSE アルゴリズム -65531):AES-CBC w/ 128-bit key。ファミリー:認証なしの AES-CBC。推奨:非推奨。RFC 9459
-65530A192CBCA192CBC(COSE アルゴリズム -65530):AES-CBC w/ 192-bit key。ファミリー:認証なしの AES-CBC。推奨:非推奨。RFC 9459
-65529A256CBCA256CBC(COSE アルゴリズム -65529):AES-CBC w/ 256-bit key。ファミリー:認証なしの AES-CBC。推奨:非推奨。RFC 9459
-268ESB512ESB512(COSE アルゴリズム -268):ECDSA using BrainpoolP512r1 curve and SHA-512。ファミリー:ECDSA。推奨:いいえ。brainpoolP512r1RFC 9864, Section 2.1
-267ESB384ESB384(COSE アルゴリズム -267):ECDSA using BrainpoolP384r1 curve and SHA-384。ファミリー:ECDSA。推奨:いいえ。brainpoolP384r1RFC 9864, Section 2.1
-266ESB320ESB320(COSE アルゴリズム -266):ECDSA using BrainpoolP320r1 curve and SHA-384。ファミリー:ECDSA。推奨:いいえ。brainpoolP320r1RFC 9864, Section 2.1
-265ESB256ESB256(COSE アルゴリズム -265):ECDSA using BrainpoolP256r1 curve and SHA-256。ファミリー:ECDSA。推奨:いいえ。brainpoolP256r1RFC 9864, Section 2.1
-264KT256KT256(COSE アルゴリズム -264):KT256 XOF。ファミリー:拡張可能出力関数。推奨:いいえ。RFC 9861
-263KT128KT128(COSE アルゴリズム -263):KT128 XOF。ファミリー:拡張可能出力関数。推奨:いいえ。RFC 9861
-262TurboSHAKE256TurboSHAKE256(COSE アルゴリズム -262):TurboSHAKE256 XOF。ファミリー:拡張可能出力関数。推奨:いいえ。RFC 9861
-261TurboSHAKE128TurboSHAKE128(COSE アルゴリズム -261):TurboSHAKE128 XOF。ファミリー:拡張可能出力関数。推奨:いいえ。RFC 9861
-260WalnutDSAWalnutDSA(COSE アルゴリズム -260):WalnutDSA signature。ファミリー:WalnutDSA。推奨:いいえ。RFC 9021RFC 9053
-259RS512RS512(COSE アルゴリズム -259):RSASSA-PKCS1-v1_5 using SHA-512。ファミリー:RSASSA-PKCS1-v1_5。推奨:いいえ。RFC 8812RFC 9053
-258RS384RS384(COSE アルゴリズム -258):RSASSA-PKCS1-v1_5 using SHA-384。ファミリー:RSASSA-PKCS1-v1_5。推奨:いいえ。RFC 8812RFC 9053
-257注記RS256RS256(COSE アルゴリズム -257):RSASSA-PKCS1-v1_5 using SHA-256。ファミリー:RSASSA-PKCS1-v1_5。推奨:いいえ。RFC 8812RFC 9053
-53Ed448Ed448(COSE アルゴリズム -53):EdDSA using the Ed448 parameter set in [Section 5.2 of RFC 8032]。ファミリー:EdDSA。推奨:はい。edwards448RFC 9864, Section 2.2
-52ESP512ESP512(COSE アルゴリズム -52):ECDSA using P-521 curve and SHA-512。ファミリー:ECDSA。推奨:はい。P-521RFC 9864, Section 2.1
-51ESP384ESP384(COSE アルゴリズム -51):ECDSA using P-384 curve and SHA-384。ファミリー:ECDSA。推奨:はい。P-384RFC 9864, Section 2.1
-50ML-DSA-87ML-DSA-87(COSE アルゴリズム -50):CBOR Object Signing Algorithm for ML-DSA-87。ファミリー:ML-DSA。推奨:はい。RFC 9964
-49ML-DSA-65ML-DSA-65(COSE アルゴリズム -49):CBOR Object Signing Algorithm for ML-DSA-65。ファミリー:ML-DSA。推奨:はい。RFC 9964
-48ML-DSA-44ML-DSA-44(COSE アルゴリズム -48):CBOR Object Signing Algorithm for ML-DSA-44。ファミリー:ML-DSA。推奨:はい。RFC 9964
-47ES256KES256K(COSE アルゴリズム -47):ECDSA using secp256k1 curve and SHA-256。ファミリー:ECDSA。推奨:いいえ。secp256k1RFC 8812RFC 9053
-46HSS-LMSHSS-LMS(COSE アルゴリズム -46):HSS/LMS hash-based digital signature。ファミリー:HSS/LMS ハッシュベース署名。推奨:はい。RFC 8778RFC 9053
-45SHAKE256SHAKE256(COSE アルゴリズム -45):SHAKE-256 512-bit Hash Value。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-44SHA-512SHA-512(COSE アルゴリズム -44):SHA-2 512-bit Hash。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-43SHA-384SHA-384(COSE アルゴリズム -43):SHA-2 384-bit Hash。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-42RSAES-OAEP w/ SHA-512RSAES-OAEP w/ SHA-512(COSE アルゴリズム -42):RSAES-OAEP w/ SHA-512。ファミリー:RSAES-OAEP 暗号化。推奨:はい。RFC 8230RFC 9053
-41RSAES-OAEP w/ SHA-256RSAES-OAEP w/ SHA-256(COSE アルゴリズム -41):RSAES-OAEP w/ SHA-256。ファミリー:RSAES-OAEP 暗号化。推奨:はい。RFC 8230RFC 9053
-40RSAES-OAEP w/ RFC 8017 default parametersRSAES-OAEP w/ RFC 8017 default parameters(COSE アルゴリズム -40):RSAES-OAEP w/ SHA-1。ファミリー:RSAES-OAEP 暗号化。推奨:はい。RFC 8230RFC 9053
-39PS512PS512(COSE アルゴリズム -39):RSASSA-PSS w/ SHA-512。ファミリー:RSASSA-PSS。推奨:はい。RFC 8230RFC 9053
-38PS384PS384(COSE アルゴリズム -38):RSASSA-PSS w/ SHA-384。ファミリー:RSASSA-PSS。推奨:はい。RFC 8230RFC 9053
-37PS256PS256(COSE アルゴリズム -37):RSASSA-PSS w/ SHA-256。ファミリー:RSASSA-PSS。推奨:はい。RFC 8230RFC 9053
-36ES512ES512(COSE アルゴリズム -36):ECDSA w/ SHA-512。ファミリー:ECDSA。推奨:非推奨。RFC 9053RFC 9864
-35ES384ES384(COSE アルゴリズム -35):ECDSA w/ SHA-384。ファミリー:ECDSA。推奨:非推奨。RFC 9053RFC 9864
-34ECDH-SS + A256KWECDH-SS + A256KW(COSE アルゴリズム -34):ECDH SS w/ Concat KDF and AES Key Wrap w/ 256-bit key。ファミリー:静的鍵同士の ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-33ECDH-SS + A192KWECDH-SS + A192KW(COSE アルゴリズム -33):ECDH SS w/ Concat KDF and AES Key Wrap w/ 192-bit key。ファミリー:静的鍵同士の ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-32ECDH-SS + A128KWECDH-SS + A128KW(COSE アルゴリズム -32):ECDH SS w/ Concat KDF and AES Key Wrap w/ 128-bit key。ファミリー:静的鍵同士の ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-31ECDH-ES + A256KWECDH-ES + A256KW(COSE アルゴリズム -31):ECDH ES w/ Concat KDF and AES Key Wrap w/ 256-bit key。ファミリー:一時鍵と静的鍵による ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-30ECDH-ES + A192KWECDH-ES + A192KW(COSE アルゴリズム -30):ECDH ES w/ Concat KDF and AES Key Wrap w/ 192-bit key。ファミリー:一時鍵と静的鍵による ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-29ECDH-ES + A128KWECDH-ES + A128KW(COSE アルゴリズム -29):ECDH ES w/ Concat KDF and AES Key Wrap w/ 128-bit key。ファミリー:一時鍵と静的鍵による ECDH と、それに続く AES 鍵ラップ。推奨:はい。RFC 9053
-28ECDH-SS + HKDF-512ECDH-SS + HKDF-512(COSE アルゴリズム -28):ECDH SS w/ HKDF - generate key directly。ファミリー:静的鍵同士の ECDH(static-static)。推奨:はい。RFC 9053
-27ECDH-SS + HKDF-256ECDH-SS + HKDF-256(COSE アルゴリズム -27):ECDH SS w/ HKDF - generate key directly。ファミリー:静的鍵同士の ECDH(static-static)。推奨:はい。RFC 9053
-26ECDH-ES + HKDF-512ECDH-ES + HKDF-512(COSE アルゴリズム -26):ECDH ES w/ HKDF - generate key directly。ファミリー:一時鍵と静的鍵による ECDH(ephemeral-static)。推奨:はい。RFC 9053
-25ECDH-ES + HKDF-256ECDH-ES + HKDF-256(COSE アルゴリズム -25):ECDH ES w/ HKDF - generate key directly。ファミリー:一時鍵と静的鍵による ECDH(ephemeral-static)。推奨:はい。RFC 9053
-19Ed25519Ed25519(COSE アルゴリズム -19):EdDSA using the Ed25519 parameter set in [Section 5.1 of RFC 8032]。ファミリー:EdDSA。推奨:はい。edwards25519RFC 9864, Section 2.2
-18SHAKE128SHAKE128(COSE アルゴリズム -18):SHAKE-128 256-bit Hash Value。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-17SHA-512/256SHA-512/256(COSE アルゴリズム -17):SHA-2 512-bit Hash truncated to 256-bits。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-16SHA-256SHA-256(COSE アルゴリズム -16):SHA-2 256-bit Hash。ファミリー:ハッシュ関数。推奨:はい。RFC 9054RFC 9053
-15SHA-256/64SHA-256/64(COSE アルゴリズム -15):SHA-2 256-bit Hash truncated to 64-bits。ファミリー:ハッシュ関数。推奨:フィルタリング専用(セキュリティ用途には使わない)。RFC 9054RFC 9053
-14SHA-1SHA-1(COSE アルゴリズム -14):SHA-1 Hash。ファミリー:ハッシュ関数。推奨:フィルタリング専用(セキュリティ用途には使わない)。RFC 9054RFC 9053
-13direct+HKDF-AES-256direct+HKDF-AES-256(COSE アルゴリズム -13):Shared secret w/ AES-MAC 256-bit key。ファミリー:HKDF で拡張した共有鍵。推奨:はい。RFC 9053
-12direct+HKDF-AES-128direct+HKDF-AES-128(COSE アルゴリズム -12):Shared secret w/ AES-MAC 128-bit key。ファミリー:HKDF で拡張した共有鍵。推奨:はい。RFC 9053
-11direct+HKDF-SHA-512direct+HKDF-SHA-512(COSE アルゴリズム -11):Shared secret w/ HKDF and SHA-512。ファミリー:HKDF で拡張した共有鍵。推奨:はい。RFC 9053
-10direct+HKDF-SHA-256direct+HKDF-SHA-256(COSE アルゴリズム -10):Shared secret w/ HKDF and SHA-256。ファミリー:HKDF で拡張した共有鍵。推奨:はい。RFC 9053
-9ESP256ESP256(COSE アルゴリズム -9):ECDSA using P-256 curve and SHA-256。ファミリー:ECDSA。推奨:はい。P-256RFC 9864, Section 2.1
-8注記EdDSAEdDSA(COSE アルゴリズム -8):EdDSA。ファミリー:EdDSA。推奨:非推奨。RFC 9053RFC 9864
-7注記ES256ES256(COSE アルゴリズム -7):ECDSA w/ SHA-256。ファミリー:ECDSA。推奨:非推奨。RFC 9053RFC 9864
-6directdirect(COSE アルゴリズム -6):Direct use of CEK。ファミリー:共有された共通鍵の直接使用。推奨:はい。RFC 9053
-5A256KWA256KW(COSE アルゴリズム -5):AES Key Wrap w/ 256-bit key。ファミリー:AES 鍵ラップ。推奨:はい。RFC 9053
-4A192KWA192KW(COSE アルゴリズム -4):AES Key Wrap w/ 192-bit key。ファミリー:AES 鍵ラップ。推奨:はい。RFC 9053
-3A128KWA128KW(COSE アルゴリズム -3):AES Key Wrap w/ 128-bit key。ファミリー:AES 鍵ラップ。推奨:はい。RFC 9053
1A128GCMA128GCM(COSE アルゴリズム 1):AES-GCM mode w/ 128-bit key, 128-bit tag。ファミリー:AES-GCM。推奨:はい。RFC 9053
2A192GCMA192GCM(COSE アルゴリズム 2):AES-GCM mode w/ 192-bit key, 128-bit tag。ファミリー:AES-GCM。推奨:はい。RFC 9053
3A256GCMA256GCM(COSE アルゴリズム 3):AES-GCM mode w/ 256-bit key, 128-bit tag。ファミリー:AES-GCM。推奨:はい。RFC 9053
4HMAC 256/64HMAC 256/64(COSE アルゴリズム 4):HMAC w/ SHA-256 truncated to 64 bits。ファミリー:HMAC。推奨:はい。RFC 9053
5HMAC 256/256HMAC 256/256(COSE アルゴリズム 5):HMAC w/ SHA-256。ファミリー:HMAC。推奨:はい。RFC 9053
6HMAC 384/384HMAC 384/384(COSE アルゴリズム 6):HMAC w/ SHA-384。ファミリー:HMAC。推奨:はい。RFC 9053
7HMAC 512/512HMAC 512/512(COSE アルゴリズム 7):HMAC w/ SHA-512。ファミリー:HMAC。推奨:はい。RFC 9053
10AES-CCM-16-64-128AES-CCM-16-64-128(COSE アルゴリズム 10):AES-CCM mode 128-bit key, 64-bit tag, 13-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
11AES-CCM-16-64-256AES-CCM-16-64-256(COSE アルゴリズム 11):AES-CCM mode 256-bit key, 64-bit tag, 13-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
12AES-CCM-64-64-128AES-CCM-64-64-128(COSE アルゴリズム 12):AES-CCM mode 128-bit key, 64-bit tag, 7-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
13AES-CCM-64-64-256AES-CCM-64-64-256(COSE アルゴリズム 13):AES-CCM mode 256-bit key, 64-bit tag, 7-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
14AES-MAC 128/64AES-MAC 128/64(COSE アルゴリズム 14):AES-MAC 128-bit key, 64-bit tag。ファミリー:AES-CBC-MAC。推奨:はい。RFC 9053
15AES-MAC 256/64AES-MAC 256/64(COSE アルゴリズム 15):AES-MAC 256-bit key, 64-bit tag。ファミリー:AES-CBC-MAC。推奨:はい。RFC 9053
24ChaCha20/Poly1305ChaCha20/Poly1305(COSE アルゴリズム 24):ChaCha20/Poly1305 w/ 256-bit key, 128-bit tag。ファミリー:ChaCha20-Poly1305。推奨:はい。RFC 9053
25AES-MAC 128/128AES-MAC 128/128(COSE アルゴリズム 25):AES-MAC 128-bit key, 128-bit tag。ファミリー:AES-CBC-MAC。推奨:はい。RFC 9053
26AES-MAC 256/128AES-MAC 256/128(COSE アルゴリズム 26):AES-MAC 256-bit key, 128-bit tag。ファミリー:AES-CBC-MAC。推奨:はい。RFC 9053
30AES-CCM-16-128-128AES-CCM-16-128-128(COSE アルゴリズム 30):AES-CCM mode 128-bit key, 128-bit tag, 13-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
31AES-CCM-16-128-256AES-CCM-16-128-256(COSE アルゴリズム 31):AES-CCM mode 256-bit key, 128-bit tag, 13-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
32AES-CCM-64-128-128AES-CCM-64-128-128(COSE アルゴリズム 32):AES-CCM mode 128-bit key, 128-bit tag, 7-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
33AES-CCM-64-128-256AES-CCM-64-128-256(COSE アルゴリズム 33):AES-CCM mode 256-bit key, 128-bit tag, 7-byte nonce。ファミリー:AES-CCM。推奨:はい。RFC 9053
34IV-GENERATIONIV-GENERATION(COSE アルゴリズム 34):For doing IV generation for symmetric algorithms.。ファミリー:共通鍵アルゴリズム用の IV 生成。推奨:いいえ。RFC 9053
未割り当ての範囲と予約済みの範囲 · 10 件
範囲ステータス説明
-9007199254740991–-65537privateReserved for Private Use
-65536unassignedUnassigned
-65528–-269unassignedUnassigned
-256–-54unassignedUnassigned
-24–-20unassignedUnassigned
-2–-1unassignedUnassigned
0reservedReserved
8–9unassignedUnassigned
16–23unassignedUnassigned
27–29unassignedUnassigned

出典:CBOR Object Signing and Encryption (COSE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 COSE Algorithms

注目すべき項目の注記

RS256

COSE アルゴリズム −257 で、SHA-256 を使う RSASSA-PKCS1-v1_5 です。Windows Hello のパスキーで使われています。

−257 は RFC 8812 で WebAuthn 向けに登録されています。Windows Hello や TPM ベースの認証器は RSA 鍵を作成することが多いため、リライングパーティは −7 とあわせて −257 も受け付けるべきです。

EdDSA

COSE アルゴリズム −8 で、鍵が指定する曲線の EdDSA を表します。RFC 9864 で非推奨になりました。

WebAuthn は −8 を Ed25519 のみを意味するものとして再定義しています。RFC 9864 §1 はこの回避策を引き合いに出したうえで、完全指定の Ed25519(−19)と Ed448(−53)を導入し、−8 を非推奨としています。

ES256

COSE アルゴリズム −7 で、任意の曲線上で SHA-256 を使う ECDSA です。ほとんどのパスキーがこのアルゴリズムを使っています。

WebAuthn の認証器は鍵のアルゴリズムを COSE の識別子で報告し、P-256 鍵での −7(ES256)が圧倒的に多く使われています。JOSE と異なり COSE の ES256 は曲線を固定しないため、RFC 9864 はこれを非推奨とし、代わりに ESP256(−9)を推奨しています。既存の WebAuthn の導入環境では引き続き −7 が使われます。

COSE の鍵の種類 · 7 件

登録済みの COSE の鍵の種類(kty)です。

値名称説明参考文献
1OKPOctet Key PairRFC 9053
2EC2Elliptic Curve Keys w/ x- and y-coordinate pairRFC 9053
3RSARSA KeyRFC 8230RFC 9053
4SymmetricSymmetric KeysRFC 9053
5HSS-LMSPublic key for HSS/LMS hash-based digital signatureRFC 8778RFC 9053
6WalnutDSAWalnutDSA public keyRFC 9021RFC 9053
7AKPCOSE Key Type for Algorithm Key PairsRFC 9964

出典:CBOR Object Signing and Encryption (COSE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 COSE Key Types

COSE の楕円曲線 · 12 件

登録済みの COSE の曲線識別子(crv)です。

値名称鍵の種類説明推奨参考文献
1P-256EC2NIST P-256 also known as secp256r1P-256YesRFC 9053
2P-384EC2NIST P-384 also known as secp384r1P-384YesRFC 9053
3P-521EC2NIST P-521 also known as secp521r1P-521YesRFC 9053
4X25519OKPX25519 for use w/ ECDH onlycurve25519YesRFC 9053
5X448OKPX448 for use w/ ECDH onlycurve448YesRFC 9053
6Ed25519OKPEd25519 for use w/ EdDSA onlyedwards25519YesRFC 9053
7Ed448OKPEd448 for use w/ EdDSA onlyedwards448YesRFC 9053
8secp256k1EC2SECG secp256k1 curvesecp256k1NoRFC 8812
256brainpoolP256r1EC2BrainpoolP256r1brainpoolP256r1NoISO/IEC 18013-5:2021, 9.1.5.2
257brainpoolP320r1EC2BrainpoolP320r1brainpoolP320r1NoISO/IEC 18013-5:2021, 9.1.5.2
258brainpoolP384r1EC2BrainpoolP384r1brainpoolP384r1NoISO/IEC 18013-5:2021, 9.1.5.2
259brainpoolP512r1EC2BrainpoolP512r1brainpoolP512r1NoISO/IEC 18013-5:2021, 9.1.5.2
未割り当ての範囲と予約済みの範囲 · 4 件
範囲ステータス説明
-9007199254740991–-65537privateReserved for Private Use
-65536–-1unassignedUnassigned
0reservedReserved
9–255unassignedUnassigned

出典:CBOR Object Signing and Encryption (COSE)(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 COSE Elliptic Curves

すべてのレジストリ