跳到主要内容
ecdsa.com
JOSE、JWK 与 COSE

COSE 算法、密钥类型与曲线

本页收录 CWT、WebAuthn、mdoc 及其他 CBOR 格式所使用的 COSE 算法标识符、密钥类型(kty)和椭圆曲线(crv),并附 IANA 注册表对每一项给出的推荐状态。

显示 105 项中的 105 项

COSE 算法 · 86 个条目

CWT、WebAuthn、mDL 及其他 CBOR 格式中使用的 COSE 算法标识符。

值名称说明参考文献
-65535RS1RS1(COSE 算法 -65535):RSASSA-PKCS1-v1_5 using SHA-1。系列:RSASSA-PKCS1-v1_5。推荐:已弃用。RFC 8812RFC 9053
-65534A128CTRA128CTR(COSE 算法 -65534):AES-CTR w/ 128-bit key。系列:不带认证的 AES-CTR。推荐:已弃用。RFC 9459
-65533A192CTRA192CTR(COSE 算法 -65533):AES-CTR w/ 192-bit key。系列:不带认证的 AES-CTR。推荐:已弃用。RFC 9459
-65532A256CTRA256CTR(COSE 算法 -65532):AES-CTR w/ 256-bit key。系列:不带认证的 AES-CTR。推荐:已弃用。RFC 9459
-65531A128CBCA128CBC(COSE 算法 -65531):AES-CBC w/ 128-bit key。系列:不带认证的 AES-CBC。推荐:已弃用。RFC 9459
-65530A192CBCA192CBC(COSE 算法 -65530):AES-CBC w/ 192-bit key。系列:不带认证的 AES-CBC。推荐:已弃用。RFC 9459
-65529A256CBCA256CBC(COSE 算法 -65529):AES-CBC w/ 256-bit key。系列:不带认证的 AES-CBC。推荐:已弃用。RFC 9459
-268ESB512ESB512(COSE 算法 -268):ECDSA using BrainpoolP512r1 curve and SHA-512。系列:ECDSA。推荐:否。brainpoolP512r1RFC 9864, Section 2.1
-267ESB384ESB384(COSE 算法 -267):ECDSA using BrainpoolP384r1 curve and SHA-384。系列:ECDSA。推荐:否。brainpoolP384r1RFC 9864, Section 2.1
-266ESB320ESB320(COSE 算法 -266):ECDSA using BrainpoolP320r1 curve and SHA-384。系列:ECDSA。推荐:否。brainpoolP320r1RFC 9864, Section 2.1
-265ESB256ESB256(COSE 算法 -265):ECDSA using BrainpoolP256r1 curve and SHA-256。系列:ECDSA。推荐:否。brainpoolP256r1RFC 9864, Section 2.1
-264KT256KT256(COSE 算法 -264):KT256 XOF。系列:可扩展输出函数。推荐:否。RFC 9861
-263KT128KT128(COSE 算法 -263):KT128 XOF。系列:可扩展输出函数。推荐:否。RFC 9861
-262TurboSHAKE256TurboSHAKE256(COSE 算法 -262):TurboSHAKE256 XOF。系列:可扩展输出函数。推荐:否。RFC 9861
-261TurboSHAKE128TurboSHAKE128(COSE 算法 -261):TurboSHAKE128 XOF。系列:可扩展输出函数。推荐:否。RFC 9861
-260WalnutDSAWalnutDSA(COSE 算法 -260):WalnutDSA signature。系列:WalnutDSA。推荐:否。RFC 9021RFC 9053
-259RS512RS512(COSE 算法 -259):RSASSA-PKCS1-v1_5 using SHA-512。系列:RSASSA-PKCS1-v1_5。推荐:否。RFC 8812RFC 9053
-258RS384RS384(COSE 算法 -258):RSASSA-PKCS1-v1_5 using SHA-384。系列:RSASSA-PKCS1-v1_5。推荐:否。RFC 8812RFC 9053
-257说明RS256RS256(COSE 算法 -257):RSASSA-PKCS1-v1_5 using SHA-256。系列:RSASSA-PKCS1-v1_5。推荐:否。RFC 8812RFC 9053
-53Ed448Ed448(COSE 算法 -53):EdDSA using the Ed448 parameter set in [Section 5.2 of RFC 8032]。系列:EdDSA。推荐:是。edwards448RFC 9864, Section 2.2
-52ESP512ESP512(COSE 算法 -52):ECDSA using P-521 curve and SHA-512。系列:ECDSA。推荐:是。P-521RFC 9864, Section 2.1
-51ESP384ESP384(COSE 算法 -51):ECDSA using P-384 curve and SHA-384。系列:ECDSA。推荐:是。P-384RFC 9864, Section 2.1
-50ML-DSA-87ML-DSA-87(COSE 算法 -50):CBOR Object Signing Algorithm for ML-DSA-87。系列:ML-DSA。推荐:是。RFC 9964
-49ML-DSA-65ML-DSA-65(COSE 算法 -49):CBOR Object Signing Algorithm for ML-DSA-65。系列:ML-DSA。推荐:是。RFC 9964
-48ML-DSA-44ML-DSA-44(COSE 算法 -48):CBOR Object Signing Algorithm for ML-DSA-44。系列:ML-DSA。推荐:是。RFC 9964
-47ES256KES256K(COSE 算法 -47):ECDSA using secp256k1 curve and SHA-256。系列:ECDSA。推荐:否。secp256k1RFC 8812RFC 9053
-46HSS-LMSHSS-LMS(COSE 算法 -46):HSS/LMS hash-based digital signature。系列:HSS/LMS 基于哈希的签名。推荐:是。RFC 8778RFC 9053
-45SHAKE256SHAKE256(COSE 算法 -45):SHAKE-256 512-bit Hash Value。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-44SHA-512SHA-512(COSE 算法 -44):SHA-2 512-bit Hash。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-43SHA-384SHA-384(COSE 算法 -43):SHA-2 384-bit Hash。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-42RSAES-OAEP w/ SHA-512RSAES-OAEP w/ SHA-512(COSE 算法 -42):RSAES-OAEP w/ SHA-512。系列:RSAES-OAEP 加密。推荐:是。RFC 8230RFC 9053
-41RSAES-OAEP w/ SHA-256RSAES-OAEP w/ SHA-256(COSE 算法 -41):RSAES-OAEP w/ SHA-256。系列:RSAES-OAEP 加密。推荐:是。RFC 8230RFC 9053
-40RSAES-OAEP w/ RFC 8017 default parametersRSAES-OAEP w/ RFC 8017 default parameters(COSE 算法 -40):RSAES-OAEP w/ SHA-1。系列:RSAES-OAEP 加密。推荐:是。RFC 8230RFC 9053
-39PS512PS512(COSE 算法 -39):RSASSA-PSS w/ SHA-512。系列:RSASSA-PSS。推荐:是。RFC 8230RFC 9053
-38PS384PS384(COSE 算法 -38):RSASSA-PSS w/ SHA-384。系列:RSASSA-PSS。推荐:是。RFC 8230RFC 9053
-37PS256PS256(COSE 算法 -37):RSASSA-PSS w/ SHA-256。系列:RSASSA-PSS。推荐:是。RFC 8230RFC 9053
-36ES512ES512(COSE 算法 -36):ECDSA w/ SHA-512。系列:ECDSA。推荐:已弃用。RFC 9053RFC 9864
-35ES384ES384(COSE 算法 -35):ECDSA w/ SHA-384。系列:ECDSA。推荐:已弃用。RFC 9053RFC 9864
-34ECDH-SS + A256KWECDH-SS + A256KW(COSE 算法 -34):ECDH SS w/ Concat KDF and AES Key Wrap w/ 256-bit key。系列:静态-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-33ECDH-SS + A192KWECDH-SS + A192KW(COSE 算法 -33):ECDH SS w/ Concat KDF and AES Key Wrap w/ 192-bit key。系列:静态-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-32ECDH-SS + A128KWECDH-SS + A128KW(COSE 算法 -32):ECDH SS w/ Concat KDF and AES Key Wrap w/ 128-bit key。系列:静态-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-31ECDH-ES + A256KWECDH-ES + A256KW(COSE 算法 -31):ECDH ES w/ Concat KDF and AES Key Wrap w/ 256-bit key。系列:临时-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-30ECDH-ES + A192KWECDH-ES + A192KW(COSE 算法 -30):ECDH ES w/ Concat KDF and AES Key Wrap w/ 192-bit key。系列:临时-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-29ECDH-ES + A128KWECDH-ES + A128KW(COSE 算法 -29):ECDH ES w/ Concat KDF and AES Key Wrap w/ 128-bit key。系列:临时-静态 ECDH 后接 AES 密钥包装。推荐:是。RFC 9053
-28ECDH-SS + HKDF-512ECDH-SS + HKDF-512(COSE 算法 -28):ECDH SS w/ HKDF - generate key directly。系列:静态-静态 ECDH。推荐:是。RFC 9053
-27ECDH-SS + HKDF-256ECDH-SS + HKDF-256(COSE 算法 -27):ECDH SS w/ HKDF - generate key directly。系列:静态-静态 ECDH。推荐:是。RFC 9053
-26ECDH-ES + HKDF-512ECDH-ES + HKDF-512(COSE 算法 -26):ECDH ES w/ HKDF - generate key directly。系列:临时-静态 ECDH。推荐:是。RFC 9053
-25ECDH-ES + HKDF-256ECDH-ES + HKDF-256(COSE 算法 -25):ECDH ES w/ HKDF - generate key directly。系列:临时-静态 ECDH。推荐:是。RFC 9053
-19Ed25519Ed25519(COSE 算法 -19):EdDSA using the Ed25519 parameter set in [Section 5.1 of RFC 8032]。系列:EdDSA。推荐:是。edwards25519RFC 9864, Section 2.2
-18SHAKE128SHAKE128(COSE 算法 -18):SHAKE-128 256-bit Hash Value。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-17SHA-512/256SHA-512/256(COSE 算法 -17):SHA-2 512-bit Hash truncated to 256-bits。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-16SHA-256SHA-256(COSE 算法 -16):SHA-2 256-bit Hash。系列:哈希函数。推荐:是。RFC 9054RFC 9053
-15SHA-256/64SHA-256/64(COSE 算法 -15):SHA-2 256-bit Hash truncated to 64-bits。系列:哈希函数。推荐:仅用于过滤,绝不用于安全目的。RFC 9054RFC 9053
-14SHA-1SHA-1(COSE 算法 -14):SHA-1 Hash。系列:哈希函数。推荐:仅用于过滤,绝不用于安全目的。RFC 9054RFC 9053
-13direct+HKDF-AES-256direct+HKDF-AES-256(COSE 算法 -13):Shared secret w/ AES-MAC 256-bit key。系列:经 HKDF 扩展的共享密钥。推荐:是。RFC 9053
-12direct+HKDF-AES-128direct+HKDF-AES-128(COSE 算法 -12):Shared secret w/ AES-MAC 128-bit key。系列:经 HKDF 扩展的共享密钥。推荐:是。RFC 9053
-11direct+HKDF-SHA-512direct+HKDF-SHA-512(COSE 算法 -11):Shared secret w/ HKDF and SHA-512。系列:经 HKDF 扩展的共享密钥。推荐:是。RFC 9053
-10direct+HKDF-SHA-256direct+HKDF-SHA-256(COSE 算法 -10):Shared secret w/ HKDF and SHA-256。系列:经 HKDF 扩展的共享密钥。推荐:是。RFC 9053
-9ESP256ESP256(COSE 算法 -9):ECDSA using P-256 curve and SHA-256。系列:ECDSA。推荐:是。P-256RFC 9864, Section 2.1
-8说明EdDSAEdDSA(COSE 算法 -8):EdDSA。系列:EdDSA。推荐:已弃用。RFC 9053RFC 9864
-7说明ES256ES256(COSE 算法 -7):ECDSA w/ SHA-256。系列:ECDSA。推荐:已弃用。RFC 9053RFC 9864
-6directdirect(COSE 算法 -6):Direct use of CEK。系列:直接使用共享对称密钥。推荐:是。RFC 9053
-5A256KWA256KW(COSE 算法 -5):AES Key Wrap w/ 256-bit key。系列:AES 密钥包装。推荐:是。RFC 9053
-4A192KWA192KW(COSE 算法 -4):AES Key Wrap w/ 192-bit key。系列:AES 密钥包装。推荐:是。RFC 9053
-3A128KWA128KW(COSE 算法 -3):AES Key Wrap w/ 128-bit key。系列:AES 密钥包装。推荐:是。RFC 9053
1A128GCMA128GCM(COSE 算法 1):AES-GCM mode w/ 128-bit key, 128-bit tag。系列:AES-GCM。推荐:是。RFC 9053
2A192GCMA192GCM(COSE 算法 2):AES-GCM mode w/ 192-bit key, 128-bit tag。系列:AES-GCM。推荐:是。RFC 9053
3A256GCMA256GCM(COSE 算法 3):AES-GCM mode w/ 256-bit key, 128-bit tag。系列:AES-GCM。推荐:是。RFC 9053
4HMAC 256/64HMAC 256/64(COSE 算法 4):HMAC w/ SHA-256 truncated to 64 bits。系列:HMAC。推荐:是。RFC 9053
5HMAC 256/256HMAC 256/256(COSE 算法 5):HMAC w/ SHA-256。系列:HMAC。推荐:是。RFC 9053
6HMAC 384/384HMAC 384/384(COSE 算法 6):HMAC w/ SHA-384。系列:HMAC。推荐:是。RFC 9053
7HMAC 512/512HMAC 512/512(COSE 算法 7):HMAC w/ SHA-512。系列:HMAC。推荐:是。RFC 9053
10AES-CCM-16-64-128AES-CCM-16-64-128(COSE 算法 10):AES-CCM mode 128-bit key, 64-bit tag, 13-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
11AES-CCM-16-64-256AES-CCM-16-64-256(COSE 算法 11):AES-CCM mode 256-bit key, 64-bit tag, 13-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
12AES-CCM-64-64-128AES-CCM-64-64-128(COSE 算法 12):AES-CCM mode 128-bit key, 64-bit tag, 7-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
13AES-CCM-64-64-256AES-CCM-64-64-256(COSE 算法 13):AES-CCM mode 256-bit key, 64-bit tag, 7-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
14AES-MAC 128/64AES-MAC 128/64(COSE 算法 14):AES-MAC 128-bit key, 64-bit tag。系列:AES-CBC-MAC。推荐:是。RFC 9053
15AES-MAC 256/64AES-MAC 256/64(COSE 算法 15):AES-MAC 256-bit key, 64-bit tag。系列:AES-CBC-MAC。推荐:是。RFC 9053
24ChaCha20/Poly1305ChaCha20/Poly1305(COSE 算法 24):ChaCha20/Poly1305 w/ 256-bit key, 128-bit tag。系列:ChaCha20-Poly1305。推荐:是。RFC 9053
25AES-MAC 128/128AES-MAC 128/128(COSE 算法 25):AES-MAC 128-bit key, 128-bit tag。系列:AES-CBC-MAC。推荐:是。RFC 9053
26AES-MAC 256/128AES-MAC 256/128(COSE 算法 26):AES-MAC 256-bit key, 128-bit tag。系列:AES-CBC-MAC。推荐:是。RFC 9053
30AES-CCM-16-128-128AES-CCM-16-128-128(COSE 算法 30):AES-CCM mode 128-bit key, 128-bit tag, 13-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
31AES-CCM-16-128-256AES-CCM-16-128-256(COSE 算法 31):AES-CCM mode 256-bit key, 128-bit tag, 13-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
32AES-CCM-64-128-128AES-CCM-64-128-128(COSE 算法 32):AES-CCM mode 128-bit key, 128-bit tag, 7-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
33AES-CCM-64-128-256AES-CCM-64-128-256(COSE 算法 33):AES-CCM mode 256-bit key, 128-bit tag, 7-byte nonce。系列:AES-CCM。推荐:是。RFC 9053
34IV-GENERATIONIV-GENERATION(COSE 算法 34):For doing IV generation for symmetric algorithms.。系列:对称算法的 IV 生成。推荐:否。RFC 9053
未分配和保留的范围 · 10 个条目
范围状态说明
-9007199254740991–-65537privateReserved for Private Use
-65536unassignedUnassigned
-65528–-269unassignedUnassigned
-256–-54unassignedUnassigned
-24–-20unassignedUnassigned
-2–-1unassignedUnassigned
0reservedReserved
8–9unassignedUnassigned
16–23unassignedUnassigned
27–29unassignedUnassigned

来源:CBOR Object Signing and Encryption (COSE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 COSE Algorithms

重要条目说明

RS256

COSE 算法 −257,即使用 SHA-256 的 RSASSA-PKCS1-v1_5,Windows Hello 通行密钥使用的就是它。

−257 由 RFC 8812 为 WebAuthn 注册:Windows Hello 和基于 TPM 的认证器经常创建 RSA 密钥,因此依赖方应当在接受 −7 的同时也接受它。

EdDSA

COSE 算法 −8,即在密钥所指定的任意曲线上运行的 EdDSA;已被 RFC 9864 弃用。

WebAuthn 把 −8 重新定义为仅指 Ed25519;RFC 9864 §1 在引入完全指定的 Ed25519(−19)和 Ed448(−53)并弃用 −8 时,引用了这一变通做法。

ES256

COSE 算法 −7,即在任意曲线上使用 SHA-256 的 ECDSA——大多数通行密钥使用的算法。

WebAuthn 认证器以 COSE 标识符报告其密钥的算法,其中使用 P-256 密钥的 −7(ES256)远比其他算法常见。与 JOSE 不同,COSE 的 ES256 并不固定曲线,因此 RFC 9864 弃用了它,改用 ESP256(−9);现有的 WebAuthn 部署仍继续使用 −7。

COSE 密钥类型 · 7 个条目

已注册的 COSE 密钥类型(kty)。

值名称说明参考文献
1OKPOctet Key PairRFC 9053
2EC2Elliptic Curve Keys w/ x- and y-coordinate pairRFC 9053
3RSARSA KeyRFC 8230RFC 9053
4SymmetricSymmetric KeysRFC 9053
5HSS-LMSPublic key for HSS/LMS hash-based digital signatureRFC 8778RFC 9053
6WalnutDSAWalnutDSA public keyRFC 9021RFC 9053
7AKPCOSE Key Type for Algorithm Key PairsRFC 9964

来源:CBOR Object Signing and Encryption (COSE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 COSE Key Types

COSE 椭圆曲线 · 12 个条目

已注册的 COSE 曲线标识符(crv)。

值名称密钥类型说明推荐参考文献
1P-256EC2NIST P-256 also known as secp256r1P-256YesRFC 9053
2P-384EC2NIST P-384 also known as secp384r1P-384YesRFC 9053
3P-521EC2NIST P-521 also known as secp521r1P-521YesRFC 9053
4X25519OKPX25519 for use w/ ECDH onlycurve25519YesRFC 9053
5X448OKPX448 for use w/ ECDH onlycurve448YesRFC 9053
6Ed25519OKPEd25519 for use w/ EdDSA onlyedwards25519YesRFC 9053
7Ed448OKPEd448 for use w/ EdDSA onlyedwards448YesRFC 9053
8secp256k1EC2SECG secp256k1 curvesecp256k1NoRFC 8812
256brainpoolP256r1EC2BrainpoolP256r1brainpoolP256r1NoISO/IEC 18013-5:2021, 9.1.5.2
257brainpoolP320r1EC2BrainpoolP320r1brainpoolP320r1NoISO/IEC 18013-5:2021, 9.1.5.2
258brainpoolP384r1EC2BrainpoolP384r1brainpoolP384r1NoISO/IEC 18013-5:2021, 9.1.5.2
259brainpoolP512r1EC2BrainpoolP512r1brainpoolP512r1NoISO/IEC 18013-5:2021, 9.1.5.2
未分配和保留的范围 · 4 个条目
范围状态说明
-9007199254740991–-65537privateReserved for Private Use
-65536–-1unassignedUnassigned
0reservedReserved
9–255unassignedUnassigned

来源:CBOR Object Signing and Encryption (COSE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 COSE Elliptic Curves

全部注册表