brainpoolP512r1 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 512 位素域上,其素数阶子群为 512 位,余因子为 1;估计安全级别为 256 位。状态:安全,但仅限特定地区或小众场景。
Brainpool 曲线(RFC 5639)以可验证的伪随机方式生成:素数取自 π 的各位数字,曲线系数取自 e 的各位数字,因此任何人都可以重新计算它们(RFC 5639 附录 A)。brainpoolP512r1 是其中的 512 位随机曲线,阶为素数(余因子为 1),安全强度约为 256 位。
TLS 通过 RFC 7027(TLS 1.2)和 RFC 8734(TLS 1.3,组 brainpoolP512r1tls13,签名方案 ecdsa_brainpoolP512r1tls13_sha512)支持它;COSE 注册了 ESB512。德国政府 PKI 和电子身份证件使用 Brainpool 曲线,NIST SP 800-186 也允许出于互操作性考虑使用它们。
各标准中的名称
| 标准 | 名称 |
|---|
| RFC 5639 | brainpoolP512r1 |
| IANA TLS 1.3 | brainpoolP512r1tls13 |
域参数
512 位素域 · 约 256 位安全强度
- 域素数 p
- 0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca703308717d4d9b009bc66842aecda12ae6a380e62881ff2f2d82c68528aa6056583a48f3
- 系数 a
- 0x7830a3318b603b89e2327145ac234cc594cbdd8d3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94ca
- 系数 b
- 0x3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94cadc083e67984050b75ebae5dd2809bd638016f723
- 基点 x 坐标
- 0x81aee4bdd82ed9645a21322e9c4c6a9385ed9f70b5d916c1b43b62eef4d0098eff3b1f78e2d0d48d50d1687b93b97d5f7c6d5047406a5e688b352209bcb9f822
- 基点 y 坐标
- 0x7dde385d566332ecc0eabfa9cf7822fdf209f70024a57b1aa000c55b881f8111b2dcde494a5f485e5bca4bd88a2763aed1ca2b2fa8f0540678cd1e0f3ad80892
- 基点的阶 n
- 0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca70330870553e5c414ca92619418661197fac10471db1d381085ddaddb58796829ca90069
- 余因子 h
- 0x1
用于
- TLS 1.2 (RFC 7027)
- TLS 1.3 (RFC 8734)
- German eID and ePassports
- X.509 (BSI TR-03116)
← 全部曲线