Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

brainpoolP512r1

A brainpoolP512r1 é a curva Brainpool de 512 bits da RFC 5639, com parâmetros derivados de forma verificável dos dígitos de π e do número e.

brainpoolP512r1 é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 512 bits com um subgrupo de ordem prima de 512 bits e cofator 1; o nível de segurança estimado é de 256 bits. Status: segura, mas regional ou de nicho.

As curvas Brainpool (RFC 5639) foram geradas de forma pseudoaleatória verificável: os primos vêm dos dígitos de π e os coeficientes da curva, dos dígitos de e, de modo que qualquer pessoa pode recalculá-los (RFC 5639, apêndice A). A brainpoolP512r1 é a curva aleatória de 512 bits; ela tem ordem prima (cofator 1) e cerca de 256 bits de segurança.

O TLS oferece suporte a ela por meio da RFC 7027 (TLS 1.2) e da RFC 8734 (TLS 1.3, grupo brainpoolP512r1tls13 e esquema de assinatura ecdsa_brainpoolP512r1tls13_sha512); o COSE registra o ESB512. A PKI do governo alemão e os documentos de identidade eletrônicos usam as curvas Brainpool, e o NIST SP 800-186 as permite para fins de interoperabilidade.

Nomes nos padrões

PadrãoNome
RFC 5639brainpoolP512r1
IANA TLS 1.3brainpoolP512r1tls13

Identificadores de objeto

Parâmetros de domínio

campo primo de 512 bits · cerca de 256 bits de segurança

Primo p do campo
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca703308717d4d9b009bc66842aecda12ae6a380e62881ff2f2d82c68528aa6056583a48f3
Coeficiente a
0x7830a3318b603b89e2327145ac234cc594cbdd8d3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94ca
Coeficiente b
0x3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94cadc083e67984050b75ebae5dd2809bd638016f723
Coordenada x do ponto base
0x81aee4bdd82ed9645a21322e9c4c6a9385ed9f70b5d916c1b43b62eef4d0098eff3b1f78e2d0d48d50d1687b93b97d5f7c6d5047406a5e688b352209bcb9f822
Coordenada y do ponto base
0x7dde385d566332ecc0eabfa9cf7822fdf209f70024a57b1aa000c55b881f8111b2dcde494a5f485e5bca4bd88a2763aed1ca2b2fa8f0540678cd1e0f3ad80892
Ordem n do ponto base
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca70330870553e5c414ca92619418661197fac10471db1d381085ddaddb58796829ca90069
Cofator h
0x1

Usada em

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identificadores em registros

Grupos suportados do TLS
brainpoolP512r1 0x001CbrainpoolP512r1tls13 0x0021
Esquemas de assinatura do TLS
ecdsa_brainpoolP512r1tls13_sha512 0x081C
Algoritmos COSE
ESB512 -268
Curvas elípticas COSE
brainpoolP512r1 259

Padrões e referências

Todas as curvas