本文へスキップ
ecdsa.com
許容短縮ワイエルシュトラス形式

brainpoolP512r1

brainpoolP512r1 は RFC 5639 の 512 ビットの Brainpool 曲線で、パラメーターは π と e の数字列から検証可能な方法で導出されています。

brainpoolP512r1 は、512 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 512 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 256 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。

Brainpool 曲線(RFC 5639)は、検証可能な擬似乱数的手法で生成されました。素数は π の数字列から、曲線の係数は e の数字列から得られているため、誰でも再計算できます(RFC 5639 付録 A)。brainpoolP512r1 は 512 ビットのランダム曲線で、位数は素数(コファクター 1)、セキュリティは約 256 ビットです。

TLS では RFC 7027(TLS 1.2)と RFC 8734(TLS 1.3、グループ brainpoolP512r1tls13 と署名方式 ecdsa_brainpoolP512r1tls13_sha512)によってサポートされており、COSE には ESB512 が登録されています。ドイツ政府の PKI と電子的な本人確認書類は Brainpool 曲線を使っており、NIST SP 800-186 も相互運用性のためにこれらの曲線の使用を認めています。

規格での名称

規格名称
RFC 5639brainpoolP512r1
IANA TLS 1.3brainpoolP512r1tls13

オブジェクト識別子

ドメインパラメーター

512 ビットの素体 · 約 256 ビットセキュリティ

有限体の素数 p
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca703308717d4d9b009bc66842aecda12ae6a380e62881ff2f2d82c68528aa6056583a48f3
係数 a
0x7830a3318b603b89e2327145ac234cc594cbdd8d3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94ca
係数 b
0x3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94cadc083e67984050b75ebae5dd2809bd638016f723
ベースポイントの x 座標
0x81aee4bdd82ed9645a21322e9c4c6a9385ed9f70b5d916c1b43b62eef4d0098eff3b1f78e2d0d48d50d1687b93b97d5f7c6d5047406a5e688b352209bcb9f822
ベースポイントの y 座標
0x7dde385d566332ecc0eabfa9cf7822fdf209f70024a57b1aa000c55b881f8111b2dcde494a5f485e5bca4bd88a2763aed1ca2b2fa8f0540678cd1e0f3ad80892
ベースポイントの位数 n
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca70330870553e5c414ca92619418661197fac10471db1d381085ddaddb58796829ca90069
コファクター h
0x1

採用例

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

レジストリでの識別子

TLS のサポートされるグループ
brainpoolP512r1 0x001CbrainpoolP512r1tls13 0x0021
TLS の署名方式
ecdsa_brainpoolP512r1tls13_sha512 0x081C
COSE アルゴリズム
ESB512 -268
COSE の楕円曲線
brainpoolP512r1 259

規格と参考文献

すべての曲線