Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

brainpoolP512r1

brainpoolP512r1 est la courbe Brainpool de 512 bits de la RFC 5639, dont les paramètres sont dérivés de façon vérifiable des décimales de π et de e.

brainpoolP512r1 est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 512 bits, avec un sous-groupe d’ordre premier de 512 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 256 bits. Statut : sûre, mais régionale ou de niche.

Les courbes Brainpool (RFC 5639) ont été générées de manière pseudo-aléatoire vérifiable : les nombres premiers proviennent des décimales de π et les coefficients des courbes de celles de e, si bien que chacun peut les recalculer (RFC 5639, annexe A). brainpoolP512r1 est la courbe aléatoire de 512 bits ; elle est d’ordre premier (cofacteur 1) et offre environ 256 bits de sécurité.

TLS la prend en charge via la RFC 7027 (TLS 1.2) et la RFC 8734 (TLS 1.3, groupe brainpoolP512r1tls13 et schéma de signature ecdsa_brainpoolP512r1tls13_sha512) ; COSE enregistre ESB512. La PKI de l’administration allemande et les documents d’identité électroniques utilisent les courbes Brainpool, et la NIST SP 800-186 les autorise pour l’interopérabilité.

Noms dans les normes

NormeNom
RFC 5639brainpoolP512r1
IANA TLS 1.3brainpoolP512r1tls13

Identifiants d’objet

Paramètres de domaine

corps premier de 512 bits · sécurité d’environ 256 bits

Nombre premier p du corps
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca703308717d4d9b009bc66842aecda12ae6a380e62881ff2f2d82c68528aa6056583a48f3
Coefficient a
0x7830a3318b603b89e2327145ac234cc594cbdd8d3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94ca
Coefficient b
0x3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94cadc083e67984050b75ebae5dd2809bd638016f723
Coordonnée x du point de base
0x81aee4bdd82ed9645a21322e9c4c6a9385ed9f70b5d916c1b43b62eef4d0098eff3b1f78e2d0d48d50d1687b93b97d5f7c6d5047406a5e688b352209bcb9f822
Coordonnée y du point de base
0x7dde385d566332ecc0eabfa9cf7822fdf209f70024a57b1aa000c55b881f8111b2dcde494a5f485e5bca4bd88a2763aed1ca2b2fa8f0540678cd1e0f3ad80892
Ordre n du point de base
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca70330870553e5c414ca92619418661197fac10471db1d381085ddaddb58796829ca90069
Cofacteur h
0x1

Utilisée dans

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identifiants dans les registres

Groupes pris en charge par TLS
brainpoolP512r1 0x001CbrainpoolP512r1tls13 0x0021
Schémas de signature TLS
ecdsa_brainpoolP512r1tls13_sha512 0x081C
Algorithmes COSE
ESB512 -268
Courbes elliptiques COSE
brainpoolP512r1 259

Normes et références

Toutes les courbes