Saltar al contenido
ecdsa.com
AceptableWeierstrass corta

brainpoolP512r1

brainpoolP512r1 es la curva Brainpool de 512 bits del RFC 5639, con parámetros derivados de forma verificable de los dígitos de π y e.

brainpoolP512r1 es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 512 bits, con un subgrupo de orden primo de 512 bits y cofactor 1; su nivel de seguridad estimado es de 256 bits. Estado: segura, pero regional o de nicho.

Las curvas Brainpool (RFC 5639) se generaron de forma pseudoaleatoria verificable: los primos salen de los dígitos de π y los coeficientes de la curva, de los dígitos de e, así que cualquiera puede volver a calcularlos (RFC 5639, apéndice A). brainpoolP512r1 es la curva aleatoria de 512 bits; tiene orden primo (cofactor 1) y unos 256 bits de seguridad.

TLS la admite mediante el RFC 7027 (TLS 1.2) y el RFC 8734 (TLS 1.3, grupo brainpoolP512r1tls13 y esquema de firma ecdsa_brainpoolP512r1tls13_sha512); COSE registra ESB512. La PKI del Gobierno alemán y los documentos de identidad electrónicos usan las curvas Brainpool, y NIST SP 800-186 las permite por interoperabilidad.

Nombres en los estándares

EstándarNombre
RFC 5639brainpoolP512r1
IANA TLS 1.3brainpoolP512r1tls13

Identificadores de objeto

Parámetros de dominio

campo primo de 512 bits · seguridad de unos 256 bits

Primo del campo p
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca703308717d4d9b009bc66842aecda12ae6a380e62881ff2f2d82c68528aa6056583a48f3
Coeficiente a
0x7830a3318b603b89e2327145ac234cc594cbdd8d3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94ca
Coeficiente b
0x3df91610a83441caea9863bc2ded5d5aa8253aa10a2ef1c98b9ac8b57f1117a72bf2c7b9e7c1ac4d77fc94cadc083e67984050b75ebae5dd2809bd638016f723
Punto base x
0x81aee4bdd82ed9645a21322e9c4c6a9385ed9f70b5d916c1b43b62eef4d0098eff3b1f78e2d0d48d50d1687b93b97d5f7c6d5047406a5e688b352209bcb9f822
Punto base y
0x7dde385d566332ecc0eabfa9cf7822fdf209f70024a57b1aa000c55b881f8111b2dcde494a5f485e5bca4bd88a2763aed1ca2b2fa8f0540678cd1e0f3ad80892
Orden n del punto base
0xaadd9db8dbe9c48b3fd4e6ae33c9fc07cb308db3b3c9d20ed6639cca70330870553e5c414ca92619418661197fac10471db1d381085ddaddb58796829ca90069
Cofactor h
0x1

Se usa en

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identificadores en registros

Grupos admitidos de TLS
brainpoolP512r1 0x001CbrainpoolP512r1tls13 0x0021
Esquemas de firma de TLS
ecdsa_brainpoolP512r1tls13_sha512 0x081C
Algoritmos COSE
ESB512 -268
Curvas elípticas COSE
brainpoolP512r1 259

Estándares y referencias

Todas las curvas