brainpoolP384r1 是形如 y² = x³ + ax + b 的短 Weierstrass 曲线,定义在 384 位素域上,其素数阶子群为 384 位,余因子为 1;估计安全级别为 192 位。状态:安全,但仅限特定地区或小众场景。
Brainpool 曲线(RFC 5639)以可验证的伪随机方式生成:素数取自 π 的各位数字,曲线系数取自 e 的各位数字,因此任何人都可以重新计算它们(RFC 5639 附录 A)。brainpoolP384r1 是其中的 384 位随机曲线,阶为素数(余因子为 1),安全强度约为 192 位。
TLS 通过 RFC 7027(TLS 1.2)和 RFC 8734(TLS 1.3,组 brainpoolP384r1tls13,签名方案 ecdsa_brainpoolP384r1tls13_sha384)支持它;COSE 注册了 ESB384。德国政府 PKI 和电子身份证件使用 Brainpool 曲线,NIST SP 800-186 也允许出于互操作性考虑使用它们。
各标准中的名称
| 标准 | 名称 |
|---|
| RFC 5639 | brainpoolP384r1 |
| IANA TLS 1.3 | brainpoolP384r1tls13 |
域参数
384 位素域 · 约 192 位安全强度
- 域素数 p
- 0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
- 系数 a
- 0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
- 系数 b
- 0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
- 基点 x 坐标
- 0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
- 基点 y 坐标
- 0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
- 基点的阶 n
- 0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
- 余因子 h
- 0x1
用于
- TLS 1.2 (RFC 7027)
- TLS 1.3 (RFC 8734)
- German eID and ePassports
- X.509 (BSI TR-03116)
← 全部曲线