Saltar al contenido
ecdsa.com
AceptableWeierstrass corta

brainpoolP384r1

brainpoolP384r1 es la curva Brainpool de 384 bits del RFC 5639, con parámetros derivados de forma verificable de los dígitos de π y e.

brainpoolP384r1 es una curva de Weierstrass corta y² = x³ + ax + b sobre un campo primo de 384 bits, con un subgrupo de orden primo de 384 bits y cofactor 1; su nivel de seguridad estimado es de 192 bits. Estado: segura, pero regional o de nicho.

Las curvas Brainpool (RFC 5639) se generaron de forma pseudoaleatoria verificable: los primos salen de los dígitos de π y los coeficientes de la curva, de los dígitos de e, así que cualquiera puede volver a calcularlos (RFC 5639, apéndice A). brainpoolP384r1 es la curva aleatoria de 384 bits; tiene orden primo (cofactor 1) y unos 192 bits de seguridad.

TLS la admite mediante el RFC 7027 (TLS 1.2) y el RFC 8734 (TLS 1.3, grupo brainpoolP384r1tls13 y esquema de firma ecdsa_brainpoolP384r1tls13_sha384); COSE registra ESB384. La PKI del Gobierno alemán y los documentos de identidad electrónicos usan las curvas Brainpool, y NIST SP 800-186 las permite por interoperabilidad.

Nombres en los estándares

EstándarNombre
RFC 5639brainpoolP384r1
IANA TLS 1.3brainpoolP384r1tls13

Identificadores de objeto

Parámetros de dominio

campo primo de 384 bits · seguridad de unos 192 bits

Primo del campo p
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
Coeficiente a
0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
Coeficiente b
0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
Punto base x
0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
Punto base y
0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
Orden n del punto base
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
Cofactor h
0x1

Se usa en

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identificadores en registros

Grupos admitidos de TLS
brainpoolP384r1 0x001BbrainpoolP384r1tls13 0x0020
Esquemas de firma de TLS
ecdsa_brainpoolP384r1tls13_sha384 0x081B
Algoritmos COSE
ESB384 -267
Curvas elípticas COSE
brainpoolP384r1 258

Estándares y referencias

Todas las curvas