Aller au contenu
ecdsa.com
AcceptableWeierstrass réduite

brainpoolP384r1

brainpoolP384r1 est la courbe Brainpool de 384 bits de la RFC 5639, dont les paramètres sont dérivés de façon vérifiable des décimales de π et de e.

brainpoolP384r1 est une courbe de Weierstrass réduite y² = x³ + ax + b sur un corps premier de 384 bits, avec un sous-groupe d’ordre premier de 384 bits et un cofacteur de 1 ; son niveau de sécurité estimé est de 192 bits. Statut : sûre, mais régionale ou de niche.

Les courbes Brainpool (RFC 5639) ont été générées de manière pseudo-aléatoire vérifiable : les nombres premiers proviennent des décimales de π et les coefficients des courbes de celles de e, si bien que chacun peut les recalculer (RFC 5639, annexe A). brainpoolP384r1 est la courbe aléatoire de 384 bits ; elle est d’ordre premier (cofacteur 1) et offre environ 192 bits de sécurité.

TLS la prend en charge via la RFC 7027 (TLS 1.2) et la RFC 8734 (TLS 1.3, groupe brainpoolP384r1tls13 et schéma de signature ecdsa_brainpoolP384r1tls13_sha384) ; COSE enregistre ESB384. La PKI de l’administration allemande et les documents d’identité électroniques utilisent les courbes Brainpool, et la NIST SP 800-186 les autorise pour l’interopérabilité.

Noms dans les normes

NormeNom
RFC 5639brainpoolP384r1
IANA TLS 1.3brainpoolP384r1tls13

Identifiants d’objet

Paramètres de domaine

corps premier de 384 bits · sécurité d’environ 192 bits

Nombre premier p du corps
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
Coefficient a
0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
Coefficient b
0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
Coordonnée x du point de base
0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
Coordonnée y du point de base
0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
Ordre n du point de base
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
Cofacteur h
0x1

Utilisée dans

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identifiants dans les registres

Groupes pris en charge par TLS
brainpoolP384r1 0x001BbrainpoolP384r1tls13 0x0020
Schémas de signature TLS
ecdsa_brainpoolP384r1tls13_sha384 0x081B
Algorithmes COSE
ESB384 -267
Courbes elliptiques COSE
brainpoolP384r1 258

Normes et références

Toutes les courbes