Pular para o conteúdo
ecdsa.com
AceitávelWeierstrass curta

brainpoolP384r1

A brainpoolP384r1 é a curva Brainpool de 384 bits da RFC 5639, com parâmetros derivados de forma verificável dos dígitos de π e do número e.

brainpoolP384r1 é uma curva na forma curta de Weierstrass y² = x³ + ax + b sobre um campo primo de 384 bits com um subgrupo de ordem prima de 384 bits e cofator 1; o nível de segurança estimado é de 192 bits. Status: segura, mas regional ou de nicho.

As curvas Brainpool (RFC 5639) foram geradas de forma pseudoaleatória verificável: os primos vêm dos dígitos de π e os coeficientes da curva, dos dígitos de e, de modo que qualquer pessoa pode recalculá-los (RFC 5639, apêndice A). A brainpoolP384r1 é a curva aleatória de 384 bits; ela tem ordem prima (cofator 1) e cerca de 192 bits de segurança.

O TLS oferece suporte a ela por meio da RFC 7027 (TLS 1.2) e da RFC 8734 (TLS 1.3, grupo brainpoolP384r1tls13 e esquema de assinatura ecdsa_brainpoolP384r1tls13_sha384); o COSE registra o ESB384. A PKI do governo alemão e os documentos de identidade eletrônicos usam as curvas Brainpool, e o NIST SP 800-186 as permite para fins de interoperabilidade.

Nomes nos padrões

PadrãoNome
RFC 5639brainpoolP384r1
IANA TLS 1.3brainpoolP384r1tls13

Identificadores de objeto

Parâmetros de domínio

campo primo de 384 bits · cerca de 192 bits de segurança

Primo p do campo
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
Coeficiente a
0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
Coeficiente b
0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
Coordenada x do ponto base
0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
Coordenada y do ponto base
0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
Ordem n do ponto base
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
Cofator h
0x1

Usada em

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Identificadores em registros

Grupos suportados do TLS
brainpoolP384r1 0x001BbrainpoolP384r1tls13 0x0020
Esquemas de assinatura do TLS
ecdsa_brainpoolP384r1tls13_sha384 0x081B
Algoritmos COSE
ESB384 -267
Curvas elípticas COSE
brainpoolP384r1 258

Padrões e referências

Todas as curvas