brainpoolP384r1 は、384 ビットの素体上の短縮ワイエルシュトラス形式の曲線 y² = x³ + ax + b で、位数が 384 ビットの素数である部分群とコファクター 1 を持ちます。推定セキュリティレベルは 192 ビットです。ステータス:安全(ただし地域限定またはニッチな用途向け)。
Brainpool 曲線(RFC 5639)は、検証可能な擬似乱数的手法で生成されました。素数は π の数字列から、曲線の係数は e の数字列から得られているため、誰でも再計算できます(RFC 5639 付録 A)。brainpoolP384r1 は 384 ビットのランダム曲線で、位数は素数(コファクター 1)、セキュリティは約 192 ビットです。
TLS では RFC 7027(TLS 1.2)と RFC 8734(TLS 1.3、グループ brainpoolP384r1tls13 と署名方式 ecdsa_brainpoolP384r1tls13_sha384)によってサポートされており、COSE には ESB384 が登録されています。ドイツ政府の PKI と電子的な本人確認書類は Brainpool 曲線を使っており、NIST SP 800-186 も相互運用性のためにこれらの曲線の使用を認めています。
規格での名称
| 規格 | 名称 |
|---|
| RFC 5639 | brainpoolP384r1 |
| IANA TLS 1.3 | brainpoolP384r1tls13 |
ドメインパラメーター
384 ビットの素体 · 約 192 ビットセキュリティ
- 有限体の素数 p
- 0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
- 係数 a
- 0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
- 係数 b
- 0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
- ベースポイントの x 座標
- 0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
- ベースポイントの y 座標
- 0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
- ベースポイントの位数 n
- 0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
- コファクター h
- 0x1
採用例
- TLS 1.2 (RFC 7027)
- TLS 1.3 (RFC 8734)
- German eID and ePassports
- X.509 (BSI TR-03116)
← すべての曲線