Zum Inhalt springen
ecdsa.com
AkzeptabelKurze Weierstraß-Form

brainpoolP384r1

brainpoolP384r1 ist die 384-Bit-Brainpool-Kurve aus RFC 5639, deren Parameter nachprüfbar aus den Ziffern von π und e abgeleitet sind.

brainpoolP384r1 ist eine Kurve in kurzer Weierstraß-Form y² = x³ + ax + b über einem 384-Bit-Primkörper mit einer 384-Bit-Untergruppe von Primordnung und dem Kofaktor 1; das geschätzte Sicherheitsniveau beträgt 192 Bit. Status: sicher, aber nur regional oder in Nischen verbreitet.

Die Brainpool-Kurven (RFC 5639) wurden nachprüfbar pseudozufällig erzeugt: Die Primzahlen stammen aus den Ziffern von π, die Kurvenkoeffizienten aus den Ziffern von e, sodass jeder sie nachrechnen kann (RFC 5639, Anhang A). brainpoolP384r1 ist die zufällig erzeugte 384-Bit-Kurve; sie hat Primordnung (Kofaktor 1) und ein Sicherheitsniveau von etwa 192 Bit.

TLS unterstützt die Kurve über RFC 7027 (TLS 1.2) und RFC 8734 (TLS 1.3, Gruppe brainpoolP384r1tls13 und Signaturverfahren ecdsa_brainpoolP384r1tls13_sha384); COSE registriert ESB384. Die PKI der deutschen Verwaltung und elektronische Identitätsdokumente nutzen die Brainpool-Kurven, und NIST SP 800-186 lässt sie für die Interoperabilität zu.

Namen in Standards

StandardName
RFC 5639brainpoolP384r1
IANA TLS 1.3brainpoolP384r1tls13

Object Identifier

Domainparameter

384-Bit-Primkörper · etwa 192-Bit-Sicherheit

Primzahl p des Körpers
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b412b1da197fb71123acd3a729901d1a71874700133107ec53
Koeffizient a
0x7bc382c63d8c150c3c72080ace05afa0c2bea28e4fb22787139165efba91f90f8aa5814a503ad4eb04a8c7dd22ce2826
Koeffizient b
0x4a8c7dd22ce28268b39b55416f0447c2fb77de107dcd2a62e880ea53eeb62d57cb4390295dbc9943ab78696fa504c11
x-Koordinate des Basispunkts
0x1d1c64f068cf45ffa2a63a81b7c13f6b8847a3e77ef14fe3db7fcafe0cbd10e8e826e03436d646aaef87b2e247d4af1e
y-Koordinate des Basispunkts
0x8abe1d7520f9c2a45cb1eb8e95cfd55262b70b29feec5864e19c054ff99129280e4646217791811142820341263c5315
Ordnung n des Basispunkts
0x8cb91e82a3386d280f5d6f7e50e641df152f7109ed5456b31f166e6cac0425a7cf3ab6af6b7fc3103b883202e9046565
Kofaktor h
0x1

Verwendet in

  • TLS 1.2 (RFC 7027)
  • TLS 1.3 (RFC 8734)
  • German eID and ePassports
  • X.509 (BSI TR-03116)

Kennungen in Registern

TLS-Supported-Groups
brainpoolP384r1 0x001BbrainpoolP384r1tls13 0x0020
TLS-Signaturverfahren
ecdsa_brainpoolP384r1tls13_sha384 0x081B
COSE-Algorithmen
ESB384 -267
Elliptische Kurven für COSE
brainpoolP384r1 258

Standards und Quellen

Alle Kurven