edwards448 是形如 x² + y² = 1 + dx²y² 的 Edwards 曲线,定义在 448 位素域上,其素数阶子群为 446 位,余因子为 4;估计安全级别为 224 位。状态:推荐用于新系统。
Edwards448 是 p = 2^448 − 2^224 − 1 上的非扭曲 Edwards 曲线 x² + y² = 1 − 39081x²y²(RFC 7748 §4.2),与 Curve448 4-同源。它的群阶为 4·n,其中 n 是 446 位素数。
Ed448(RFC 8032 §5.2)使用 SHAKE256 计算哈希,密钥为 57 字节,签名为 114 字节,并支持上下文字符串。TLS 1.3(ed448)、DNSSEC(算法 16)、JOSE 和 COSE(Ed448)以及 X.509(OID 1.3.101.113)都为它做了定义,FIPS 186-5 也批准了它。
各标准中的名称
| 标准 | 名称 |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
域参数
448 位素域 · 约 224 位安全强度
- 域素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- 系数 d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- 基点 x 坐标
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- 基点 y 坐标
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- 基点的阶 n
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- 余因子 h
- 0x4
用于
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
← 全部曲线