edwards448 est une courbe d’Edwards x² + y² = 1 + dx²y² sur un corps premier de 448 bits, avec un sous-groupe d’ordre premier de 446 bits et un cofacteur de 4 ; son niveau de sécurité estimé est de 224 bits. Statut : recommandée pour les nouveaux systèmes.
Edwards448 est la courbe d’Edwards non tordue x² + y² = 1 − 39081x²y² définie modulo p = 2^448 − 2^224 − 1 (RFC 7748, §4.2), 4-isogène à Curve448. L’ordre du groupe est 4·n, où n est un nombre premier de 446 bits.
Ed448 (RFC 8032, §5.2) utilise SHAKE256 comme fonction de hachage, des clés de 57 octets et des signatures de 114 octets, et prend en charge une chaîne de contexte. Il est défini pour TLS 1.3 (ed448), DNSSEC (algorithme 16), JOSE et COSE (Ed448) et X.509 (OID 1.3.101.113), et la norme FIPS 186-5 l’approuve.
Noms dans les normes
| Norme | Nom |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
Paramètres de domaine
corps premier de 448 bits · sécurité d’environ 224 bits
- Nombre premier p du corps
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coefficient d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- Coordonnée x du point de base
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- Coordonnée y du point de base
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- Ordre n du point de base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofacteur h
- 0x4
Utilisée dans
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
Identifiants dans les registres
← Toutes les courbes