A128CBC | A128CBC est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CBC sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A128CBC-HS256 | A128CBC-HS256 est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-CBC avec HMAC avec SHA-256. Exigence d’implémentation : obligatoire. | enc | RFC 7518, Section 5.2.3 |
A128CTR | A128CTR est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CTR sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A128GCM | A128GCM est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-GCM. Exigence d’implémentation : recommandé. | enc | RFC 7518, Section 5.3 |
A128GCMKW | A128GCMKW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES-GCM. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.7 |
A128KW | A128KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 4.4 |
A192CBC | A192CBC est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CBC sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A192CBC-HS384 | A192CBC-HS384 est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-CBC avec HMAC avec SHA-384. Exigence d’implémentation : facultatif. | enc | RFC 7518, Section 5.2.4 |
A192CTR | A192CTR est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CTR sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A192GCM | A192GCM est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-GCM. Exigence d’implémentation : facultatif. | enc | RFC 7518, Section 5.3 |
A192GCMKW | A192GCMKW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES-GCM. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.7 |
A192KW | A192KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.4 |
A256CBC | A256CBC est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CBC sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A256CBC-HS512 | A256CBC-HS512 est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-CBC avec HMAC avec SHA-512. Exigence d’implémentation : obligatoire. | enc | RFC 7518, Section 5.2.5 |
A256CTR | A256CTR est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : AES-CTR sans authentification. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
A256GCM | A256GCM est un algorithme JOSE de chiffrement du contenu (enc dans un JWE) : AES-GCM. Exigence d’implémentation : recommandé. | enc | RFC 7518, Section 5.3 |
A256GCMKW | A256GCMKW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES-GCM. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.7 |
A256KW | A256KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : enveloppement de clé AES. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 4.4 |
dir | dir est un algorithme JOSE de gestion des clés (alg dans un JWE) : utilisation directe d’une clé symétrique partagée. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 4.5 |
ECDH-ES | ECDH-ES est un algorithme JOSE de gestion des clés (alg dans un JWE) : ECDH éphémère-statique. Exigence d’implémentation : recommandé, probablement obligatoire à l’avenir. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A128KW | ECDH-ES+A128KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : ECDH éphémère-statique suivi d’un enveloppement de clé AES. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A192KW | ECDH-ES+A192KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : ECDH éphémère-statique suivi d’un enveloppement de clé AES. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A256KW | ECDH-ES+A256KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : ECDH éphémère-statique suivi d’un enveloppement de clé AES. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 4.6 |
Ed25519 | Ed25519 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : EdDSA sur edwards25519. Exigence d’implémentation : facultatif.edwards25519 | alg | RFC 9864, Section 2.2 |
Ed448 | Ed448 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : EdDSA sur edwards448. Exigence d’implémentation : facultatif.edwards448 | alg | RFC 9864, Section 2.2 |
EdDSANote | EdDSA est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : EdDSA. Exigence d’implémentation : déconseillé. | alg | RFC 9864, Section 2.2 |
ES256Note | ES256 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ECDSA sur P-256 avec SHA-256. Exigence d’implémentation : recommandé, probablement obligatoire à l’avenir.P-256 | alg | RFC 7518, Section 3.4 |
ES256K | ES256K est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ECDSA sur secp256k1 avec SHA-256. Exigence d’implémentation : facultatif.secp256k1 | alg | RFC 8812, Section 3.2 |
ES384 | ES384 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ECDSA sur P-384 avec SHA-384. Exigence d’implémentation : facultatif.P-384 | alg | RFC 7518, Section 3.4 |
ES512 | ES512 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ECDSA sur P-521 avec SHA-512. Exigence d’implémentation : facultatif.P-521 | alg | RFC 7518, Section 3.4 |
HPKE-0 | HPKE-0 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-256. Exigence d’implémentation : facultatif.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-0-KE | HPKE-0-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-256. Exigence d’implémentation : facultatif.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-1 | HPKE-1 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-384. Exigence d’implémentation : facultatif.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-1-KE | HPKE-1-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-384. Exigence d’implémentation : facultatif.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-2 | HPKE-2 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-521. Exigence d’implémentation : facultatif.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-2-KE | HPKE-2-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-521. Exigence d’implémentation : facultatif.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-3 | HPKE-3 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve25519. Exigence d’implémentation : facultatif.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-3-KE | HPKE-3-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve25519. Exigence d’implémentation : facultatif.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-4 | HPKE-4 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve25519. Exigence d’implémentation : facultatif.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5 | HPKE-5 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve448. Exigence d’implémentation : facultatif.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5-KE | HPKE-5-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve448. Exigence d’implémentation : facultatif.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-6 | HPKE-6 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur curve448. Exigence d’implémentation : facultatif.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7 | HPKE-7 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-256. Exigence d’implémentation : facultatif.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7-KE | HPKE-7-KE est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement hybride à clé publique (HPKE) sur P-256. Exigence d’implémentation : facultatif.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HS1 | HS1 est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : HMAC avec SHA-1. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
HS256Note | HS256 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : HMAC avec SHA-256. Exigence d’implémentation : obligatoire. | alg | RFC 7518, Section 3.2 |
HS384 | HS384 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : HMAC avec SHA-384. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.2 |
HS512 | HS512 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : HMAC avec SHA-512. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.2 |
ML-DSA-44 | ML-DSA-44 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ML-DSA. Exigence d’implémentation : facultatif. | alg | RFC 9964 |
ML-DSA-65Note | ML-DSA-65 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ML-DSA. Exigence d’implémentation : facultatif. | alg | RFC 9964 |
ML-DSA-87 | ML-DSA-87 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : ML-DSA. Exigence d’implémentation : facultatif. | alg | RFC 9964 |
noneNote | none est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : aucune signature ni aucun MAC. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.6 |
PBES2-HS256+A128KW | PBES2-HS256+A128KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement fondé sur un mot de passe (PBES2) avec SHA-256. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.8 |
PBES2-HS384+A192KW | PBES2-HS384+A192KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement fondé sur un mot de passe (PBES2) avec SHA-384. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.8 |
PBES2-HS512+A256KW | PBES2-HS512+A256KW est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement fondé sur un mot de passe (PBES2) avec SHA-512. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.8 |
PS256 | PS256 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PSS avec SHA-256. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.5 |
PS384 | PS384 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PSS avec SHA-384. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.5 |
PS512 | PS512 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PSS avec SHA-512. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.5 |
RS1 | RS1 est un identifiant JOSE WebCrypto qui ne peut apparaître que dans une JWK : RSASSA-PKCS1-v1_5 avec SHA-1. Exigence d’implémentation : interdit. | JWK | W3C Web Cryptography API |
RS256Note | RS256 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PKCS1-v1_5 avec SHA-256. Exigence d’implémentation : recommandé. | alg | RFC 7518, Section 3.3 |
RS384 | RS384 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PKCS1-v1_5 avec SHA-384. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.3 |
RS512 | RS512 est un algorithme JOSE de signature ou de MAC (alg dans un JWS) : RSASSA-PKCS1-v1_5 avec SHA-512. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 3.3 |
RSA-OAEP | RSA-OAEP est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement RSAES-OAEP avec SHA-1. Exigence d’implémentation : recommandé, probablement obligatoire à l’avenir. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-256 | RSA-OAEP-256 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement RSAES-OAEP avec SHA-256. Exigence d’implémentation : facultatif. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-384 | RSA-OAEP-384 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement RSAES-OAEP avec SHA-384. Exigence d’implémentation : facultatif. | alg | W3C Web Cryptography API |
RSA-OAEP-512 | RSA-OAEP-512 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement RSAES-OAEP avec SHA-512. Exigence d’implémentation : facultatif. | alg | W3C Web Cryptography API |
RSA1_5Note | RSA1_5 est un algorithme JOSE de gestion des clés (alg dans un JWE) : chiffrement RSAES-PKCS1-v1_5. Exigence d’implémentation : recommandé, probablement facultatif à l’avenir. | alg | RFC 7518, Section 4.2 |