curve448 est une courbe de Montgomery By² = x³ + Ax² + x sur un corps premier de 448 bits, avec un sous-groupe d’ordre premier de 446 bits et un cofacteur de 4 ; son niveau de sécurité estimé est de 224 bits. Statut : recommandée pour les nouveaux systèmes.
Curve448 est la courbe y² = x³ + 156326x² + x définie modulo le nombre premier « Goldilocks » 2^448 − 2^224 − 1, proposée par Mike Hamburg en 2015 et adoptée dans la RFC 7748. Son groupe est d’ordre 4·n, où n est un nombre premier de 446 bits, soit environ 224 bits de sécurité.
Les clés et les secrets partagés X448 font 56 octets. TLS 1.3 (x448, marqué comme recommandé par l’IANA), SSH (curve448-sha512, RFC 8731) et HPKE (DHKEM(X448, HKDF-SHA512)) le définissent, mais il est bien moins utilisé que X25519. Son homologue en forme d’Edwards est edwards448, utilisée pour Ed448.
Noms dans les normes
| Norme | Nom |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
Paramètres de domaine
corps premier de 448 bits · sécurité d’environ 224 bits
- Nombre premier p du corps
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coefficient a
- 0x262a6
- Coefficient b
- 0x1
- Coordonnée x du point de base
- 0x5
- Coordonnée y du point de base
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- Ordre n du point de base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofacteur h
- 0x4
Utilisée dans
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
Identifiants dans les registres
- Courbes elliptiques COSE
- X448 5
← Toutes les courbes