curve448 é uma curva de Montgomery By² = x³ + Ax² + x sobre um campo primo de 448 bits com um subgrupo de ordem prima de 446 bits e cofator 4; o nível de segurança estimado é de 224 bits. Status: recomendada para sistemas novos.
A Curve448 é y² = x³ + 156326x² + x sobre o primo “Goldilocks” 2^448 − 2^224 − 1, apresentada por Mike Hamburg em 2015 e adotada na RFC 7748. O grupo dela tem ordem 4·n, com n primo de 446 bits, o que dá cerca de 224 bits de segurança.
As chaves e os segredos compartilhados do X448 têm 56 bytes. O TLS 1.3 (x448, marcado como recomendado pela IANA), o SSH (curve448-sha512, RFC 8731) e o HPKE (DHKEM(X448, HKDF-SHA512)) o definem, mas ele é muito menos usado que o X25519. A contraparte de Edwards da curva é a edwards448, usada no Ed448.
Nomes nos padrões
| Padrão | Nome |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
Identificadores de objeto
Parâmetros de domínio
campo primo de 448 bits · cerca de 224 bits de segurança
- Primo p do campo
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coeficiente a
- 0x262a6
- Coeficiente b
- 0x1
- Coordenada x do ponto base
- 0x5
- Coordenada y do ponto base
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- Ordem n do ponto base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofator h
- 0x4
Usada em
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
Identificadores em registros
← Todas as curvas