edwards448 é uma curva de Edwards x² + y² = 1 + dx²y² sobre um campo primo de 448 bits com um subgrupo de ordem prima de 446 bits e cofator 4; o nível de segurança estimado é de 224 bits. Status: recomendada para sistemas novos.
A Edwards448 é a curva de Edwards não torcida x² + y² = 1 − 39081x²y² sobre p = 2^448 − 2^224 − 1 (RFC 7748 §4.2), 4-isógena à Curve448. A ordem do grupo dela é 4·n, com n primo de 446 bits.
O Ed448 (RFC 8032 §5.2) calcula o hash com SHAKE256, usa chaves de 57 bytes e assinaturas de 114 bytes e oferece suporte a uma string de contexto. Ele é definido para o TLS 1.3 (ed448), o DNSSEC (algoritmo 16), o JOSE e o COSE (Ed448) e o X.509 (OID 1.3.101.113), e o FIPS 186-5 o aprova.
Nomes nos padrões
| Padrão | Nome |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
Identificadores de objeto
Parâmetros de domínio
campo primo de 448 bits · cerca de 224 bits de segurança
- Primo p do campo
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coeficiente d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- Coordenada x do ponto base
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- Coordenada y do ponto base
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- Ordem n do ponto base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofator h
- 0x4
Usada em
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
Identificadores em registros
← Todas as curvas