edwards448 は、448 ビットの素体上のエドワーズ形式の曲線 x² + y² = 1 + dx²y² で、位数が 446 ビットの素数である部分群とコファクター 4 を持ちます。推定セキュリティレベルは 224 ビットです。ステータス:新しいシステムに推奨。
Edwards448 は、p = 2^448 − 2^224 − 1 上のツイストされていないエドワーズ曲線 x² + y² = 1 − 39081x²y²(RFC 7748 §4.2)で、Curve448 とは次数 4 の同種写像で対応しています。群の位数は 4·n(n は 446 ビットの素数)です。
Ed448(RFC 8032 §5.2)は SHAKE256 でハッシュを計算し、57 バイトの鍵と 114 バイトの署名を使い、コンテキスト文字列をサポートします。TLS 1.3(ed448)、DNSSEC(アルゴリズム 16)、JOSE と COSE(Ed448)、X.509(OID 1.3.101.113)向けに定義されており、FIPS 186-5 でも承認されています。
規格での名称
| 規格 | 名称 |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
ドメインパラメーター
448 ビットの素体 · 約 224 ビットセキュリティ
- 有限体の素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- 係数 d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- ベースポイントの x 座標
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- ベースポイントの y 座標
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- ベースポイントの位数 n
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- コファクター h
- 0x4
採用例
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
← すべての曲線