本文へスキップ
ecdsa.com
SSH

SSH のアルゴリズム名|鍵交換、暗号、MAC、鍵

IANA レジストリにある SSH トランスポートプロトコルの鍵交換、暗号化、MAC、公開鍵のアルゴリズム名を、RFC 9142 の実装ガイダンス付きで掲載しています。

112 件中 112 件を表示

SSH の鍵交換方式 · 41 件

SSH トランスポートプロトコルの鍵交換方式の名前と、RFC 9142 による実装のガイダンスです。

名称説明参考文献
curve25519-sha256注記curve25519-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8731
curve448-sha512curve448-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8731
diffie-hellman-group-exchange-sha1diffie-hellman-group-exchange-sha1 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):非推奨(SHOULD NOT)。RFC 4419RFC 8270
diffie-hellman-group-exchange-sha256diffie-hellman-group-exchange-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 4419RFC 8270
diffie-hellman-group1-sha1注記diffie-hellman-group1-sha1 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):非推奨(SHOULD NOT)。RFC 4253
diffie-hellman-group14-sha1diffie-hellman-group14-sha1 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 4253
diffie-hellman-group14-sha256diffie-hellman-group14-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):必須(MUST)。RFC 8268
diffie-hellman-group15-sha512diffie-hellman-group15-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8268
diffie-hellman-group16-sha512diffie-hellman-group16-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8268
diffie-hellman-group17-sha512diffie-hellman-group17-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8268
diffie-hellman-group18-sha512diffie-hellman-group18-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8268
ecdh-sha2-*ecdh-sha2-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 5656
ecdh-sha2-nistp256ecdh-sha2-nistp256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 5656
ecdh-sha2-nistp384ecdh-sha2-nistp384 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 5656
ecdh-sha2-nistp521ecdh-sha2-nistp521 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 5656
ecmqv-sha2ecmqv-sha2 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 5656
ext-info-cext-info-c は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8308
ext-info-sext-info-s は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8308
gss-gss- は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):予約済み。RFC 4462
gss-curve25519-sha256-*gss-curve25519-sha256-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8732
gss-curve448-sha512-*gss-curve448-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8732
gss-gex-sha1-*gss-gex-sha1-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):非推奨(SHOULD NOT)。RFC 4462RFC 8732
gss-group1-sha1-*gss-group1-sha1-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):非推奨(SHOULD NOT)。RFC 4462RFC 8732
gss-group14-sha1-*gss-group14-sha1-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):非推奨(SHOULD NOT)。RFC 4462RFC 8732
gss-group14-sha256-*gss-group14-sha256-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8732
gss-group15-sha512-*gss-group15-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8732
gss-group16-sha512-*gss-group16-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8732
gss-group17-sha512-*gss-group17-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8732
gss-group18-sha512-*gss-group18-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):任意(MAY)。RFC 8732
gss-nistp256-sha256-*gss-nistp256-sha256-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8732
gss-nistp384-sha384-*gss-nistp384-sha384-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8732
gss-nistp521-sha512-*gss-nistp521-sha512-* は SSH の鍵交換方式のファミリーです。名前の残りの部分は参照先の文書で定義されます。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 8732
mlkem1024-sha384mlkem1024-sha384 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。draft-harrison-mlkem-ssh-01
mlkem1024nistp384-sha384mlkem1024nistp384-sha384 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 10042
mlkem512-sha256mlkem512-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。draft-harrison-mlkem-ssh-01
mlkem768-sha256mlkem768-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。draft-harrison-mlkem-ssh-01
mlkem768nistp256-sha256mlkem768nistp256-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 10042
mlkem768x25519-sha256注記mlkem768x25519-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 10042
rsa1024-sha1rsa1024-sha1 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):禁止(MUST NOT)。RFC 4432
rsa2048-sha256rsa2048-sha256 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):任意(MAY)。RFC 4432
sntrup761x25519-sha512sntrup761x25519-sha512 は SSH の鍵交換方式です。実装のガイダンス(RFC 9142):推奨(SHOULD)。RFC 9941

出典:Secure Shell (SSH) Protocol Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 Key Exchange Method Names

注目すべき項目の注記

curve25519-sha256

SSH の X25519 鍵交換(RFC 8731)で、ほとんどの SSH 実装では従来型の鍵交換のデフォルトです。

OpenSSH は 2014年に curve25519-sha256@libssh.org という名前でこれを導入し、RFC 8731 がサフィックスを除いた名前で標準化しました。RFC 9142 は、実装がこれをサポートすべき(SHOULD)としています。相手がポスト量子ハイブリッドに対応していない場合の、通常のフォールバックとして今も使われています。

diffie-hellman-group1-sha1

1024 ビットの Oakley グループ 2 と SHA-1 を使う、SSH で最初に定められた鍵交換です。現在は「使用すべきではない(SHOULD NOT)」とされています(RFC 9142)。

1024 ビットのグループは国家レベルの事前計算で破れる範囲にあり(Logjam、2015年)、SHA-1 も脆弱です。OpenSSH はバージョン 7.0(2015年)でこの方式をデフォルトで無効にしました。この方式しか提供しない古いネットワーク機器を使うには、方式を明示的に再び有効にする必要がありますが、本当の解決策は機器の更新です。

mlkem768x25519-sha256

OpenSSH がバージョン 10.0 からデフォルトで使う、ML-KEM-768 + X25519 のハイブリッド鍵交換です。

mlkem768x25519-sha256(RFC 10042)は ML-KEM-768 と X25519 を組み合わせ、その結果を SHA-256 でハッシュします。OpenSSH 9.9 で追加され、OpenSSH 10.0(2025年4月)で sntrup761x25519-sha512 に代わってデフォルトになりました。記録されたセッションを将来の量子コンピューターから守ります。

SSH の暗号化アルゴリズム · 35 件

SSH トランスポートプロトコルの暗号の名前です。

名称説明参考文献
3des-cbc3des-cbc は SSH の暗号化アルゴリズムです。RFC 4253
3des-ctr3des-ctr は SSH の暗号化アルゴリズムです。RFC 4344
AEAD_AES_128_GCMAEAD_AES_128_GCM は SSH の暗号化アルゴリズムです。RFC 5647
AEAD_AES_256_GCMAEAD_AES_256_GCM は SSH の暗号化アルゴリズムです。RFC 5647
aes128-cbcaes128-cbc は SSH の暗号化アルゴリズムです。RFC 4253
aes128-ctraes128-ctr は SSH の暗号化アルゴリズムです。RFC 4344
aes192-cbcaes192-cbc は SSH の暗号化アルゴリズムです。RFC 4253
aes192-ctraes192-ctr は SSH の暗号化アルゴリズムです。RFC 4344
aes256-cbcaes256-cbc は SSH の暗号化アルゴリズムです。RFC 4253
aes256-ctraes256-ctr は SSH の暗号化アルゴリズムです。RFC 4344
arcfourarcfour は SSH の暗号化アルゴリズムです。歴史的なものとしてマークされています。RFC 8758
arcfour128arcfour128 は SSH の暗号化アルゴリズムです。歴史的なものとしてマークされています。RFC 8758
arcfour256arcfour256 は SSH の暗号化アルゴリズムです。歴史的なものとしてマークされています。RFC 8758
blowfish-cbcblowfish-cbc は SSH の暗号化アルゴリズムです。RFC 4253
blowfish-ctrblowfish-ctr は SSH の暗号化アルゴリズムです。RFC 4344
cast128-cbccast128-cbc は SSH の暗号化アルゴリズムです。RFC 4253
cast128-ctrcast128-ctr は SSH の暗号化アルゴリズムです。RFC 4344
chacha20-poly1305chacha20-poly1305 は SSH の暗号化アルゴリズムです。draft-josefsson-ssh-chacha20-poly1305-openssh-01
des-cbcdes-cbc は SSH の暗号化アルゴリズムです。歴史的なものとしてマークされています。FIPS 46-3
idea-cbcidea-cbc は SSH の暗号化アルゴリズムです。RFC 4253
idea-ctridea-ctr は SSH の暗号化アルゴリズムです。RFC 4344
nonenone は SSH の暗号化アルゴリズムです。RFC 4253
serpent128-cbcserpent128-cbc は SSH の暗号化アルゴリズムです。RFC 4253
serpent128-ctrserpent128-ctr は SSH の暗号化アルゴリズムです。RFC 4344
serpent192-cbcserpent192-cbc は SSH の暗号化アルゴリズムです。RFC 4253
serpent192-ctrserpent192-ctr は SSH の暗号化アルゴリズムです。RFC 4344
serpent256-cbcserpent256-cbc は SSH の暗号化アルゴリズムです。RFC 4253
serpent256-ctrserpent256-ctr は SSH の暗号化アルゴリズムです。RFC 4344
twofish-cbctwofish-cbc は SSH の暗号化アルゴリズムです。RFC 4253
twofish128-cbctwofish128-cbc は SSH の暗号化アルゴリズムです。RFC 4253
twofish128-ctrtwofish128-ctr は SSH の暗号化アルゴリズムです。RFC 4344
twofish192-cbctwofish192-cbc は SSH の暗号化アルゴリズムです。RFC 4253
twofish192-ctrtwofish192-ctr は SSH の暗号化アルゴリズムです。RFC 4344
twofish256-cbctwofish256-cbc は SSH の暗号化アルゴリズムです。RFC 4253
twofish256-ctrtwofish256-ctr は SSH の暗号化アルゴリズムです。RFC 4344

出典:Secure Shell (SSH) Protocol Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 Encryption Algorithm Names

SSH の MAC アルゴリズム · 9 件

SSH トランスポートプロトコルの MAC アルゴリズムの名前です。

名称説明参考文献
AEAD_AES_128_GCMAEAD_AES_128_GCM は SSH の MAC アルゴリズムです。RFC 5647
AEAD_AES_256_GCMAEAD_AES_256_GCM は SSH の MAC アルゴリズムです。RFC 5647
hmac-md5hmac-md5 は SSH の MAC アルゴリズムです。RFC 4253
hmac-md5-96hmac-md5-96 は SSH の MAC アルゴリズムです。RFC 4253
hmac-sha1hmac-sha1 は SSH の MAC アルゴリズムです。RFC 4253
hmac-sha1-96hmac-sha1-96 は SSH の MAC アルゴリズムです。RFC 4253
hmac-sha2-256hmac-sha2-256 は SSH の MAC アルゴリズムです。RFC 6668
hmac-sha2-512hmac-sha2-512 は SSH の MAC アルゴリズムです。RFC 6668
nonenone は SSH の MAC アルゴリズムです。RFC 4253

出典:Secure Shell (SSH) Protocol Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 MAC Algorithm Names

SSH の公開鍵アルゴリズム · 27 件

SSH のホスト鍵とユーザー鍵で使われる公開鍵アルゴリズムと署名アルゴリズムの名前です。

名称説明参考文献
ecdsa-sha2-*ecdsa-sha2-* は SSH の公開鍵アルゴリズムのファミリーです。名前の残りの部分は参照先の文書で定義されます。RFC 5656
ecdsa-sha2-nistp256ecdsa-sha2-nistp256 は SSH の公開鍵アルゴリズムです。ecdsa-sha2-* ファミリーに属します。RFC 5656, Section 10.1
ecdsa-sha2-nistp384ecdsa-sha2-nistp384 は SSH の公開鍵アルゴリズムです。ecdsa-sha2-* ファミリーに属します。RFC 5656, Section 10.1
ecdsa-sha2-nistp521ecdsa-sha2-nistp521 は SSH の公開鍵アルゴリズムです。ecdsa-sha2-* ファミリーに属します。RFC 5656, Section 10.1
nullnull は SSH の公開鍵アルゴリズムです。RFC 4462
pgp-sign-dsspgp-sign-dss は SSH の公開鍵アルゴリズムです。RFC 4253
pgp-sign-rsapgp-sign-rsa は SSH の公開鍵アルゴリズムです。RFC 4253
rsa-sha2-256rsa-sha2-256 は SSH の公開鍵アルゴリズムです。RFC 8332
rsa-sha2-512rsa-sha2-512 は SSH の公開鍵アルゴリズムです。RFC 8332
spki-sign-dssspki-sign-dss は SSH の公開鍵アルゴリズムです。RFC 4253
spki-sign-rsaspki-sign-rsa は SSH の公開鍵アルゴリズムです。RFC 4253
ssh-dss注記ssh-dss は SSH の公開鍵アルゴリズムです。RFC 4253
ssh-ed25519注記ssh-ed25519 は SSH の公開鍵アルゴリズムです。RFC 8709
ssh-ed448ssh-ed448 は SSH の公開鍵アルゴリズムです。RFC 8709
ssh-mldsa-44ssh-mldsa-44 は SSH の公開鍵アルゴリズムです。draft-sfluhrer-ssh-mldsa-08
ssh-mldsa-65ssh-mldsa-65 は SSH の公開鍵アルゴリズムです。draft-sfluhrer-ssh-mldsa-08
ssh-mldsa-87ssh-mldsa-87 は SSH の公開鍵アルゴリズムです。draft-sfluhrer-ssh-mldsa-08
ssh-mldsa44-ed25519ssh-mldsa44-ed25519 は SSH の公開鍵アルゴリズムです。draft-ietf-sshm-composite-sigs-00
ssh-mldsa87-p384ssh-mldsa87-p384 は SSH の公開鍵アルゴリズムです。draft-ietf-sshm-composite-sigs-00
ssh-rsa注記ssh-rsa は SSH の公開鍵アルゴリズムです。RFC 4253
x509v3-ecdsa-sha2-*x509v3-ecdsa-sha2-* は SSH の公開鍵アルゴリズムのファミリーです。名前の残りの部分は参照先の文書で定義されます。RFC 6187
x509v3-ecdsa-sha2-nistp256x509v3-ecdsa-sha2-nistp256 は SSH の公開鍵アルゴリズムです。x509v3-ecdsa-sha2-* ファミリーに属します。RFC 6187, Section 3.3
x509v3-ecdsa-sha2-nistp384x509v3-ecdsa-sha2-nistp384 は SSH の公開鍵アルゴリズムです。x509v3-ecdsa-sha2-* ファミリーに属します。RFC 6187, Section 3.3
x509v3-ecdsa-sha2-nistp521x509v3-ecdsa-sha2-nistp521 は SSH の公開鍵アルゴリズムです。x509v3-ecdsa-sha2-* ファミリーに属します。RFC 6187, Section 3.3
x509v3-rsa2048-sha256x509v3-rsa2048-sha256 は SSH の公開鍵アルゴリズムです。RFC 6187
x509v3-ssh-dssx509v3-ssh-dss は SSH の公開鍵アルゴリズムです。RFC 6187
x509v3-ssh-rsax509v3-ssh-rsa は SSH の公開鍵アルゴリズムです。RFC 6187

出典:Secure Shell (SSH) Protocol Parameters(IANA)、2026-10-20 に取得。データのライセンス:CC0-1.0。 Public Key Algorithm Names

注目すべき項目の注記

ssh-dss

SSH の DSA 鍵で、1024 ビットと SHA-1 に限定されています。OpenSSH 10.0 でサポートが完全に削除されました。

SSH の DSA プロファイルは、鍵長を 1024 ビット、ハッシュを SHA-1 に固定しています。OpenSSH は 7.0(2015年)で DSA をデフォルトで無効にし、10.0(2025年)で削除しました。ssh-dss 鍵は Ed25519 鍵か ECDSA 鍵に置き換えてください。

ssh-ed25519

SSH の Ed25519 鍵(RFC 8709)で、OpenSSH 9.5 から ssh-keygen がデフォルトで作成する種類です。

ssh-ed25519 の公開鍵は 32 バイトで、authorized_keys の行も短く収まります。OpenSSH 9.5(2023年10月)で、Ed25519 が ssh-keygen のデフォルトの鍵の種類になりました。edwards25519 も参照してください。

ssh-rsa

SSH の RSA 鍵の形式です。また、OpenSSH 8.8 で無効になった、SHA-1 を使う古い RSA 署名の名前でもあります。

この名前には 2 つの意味があります。鍵の種類としての ssh-rsa は今もすべての RSA 鍵を表しますが、署名アルゴリズムとしては SHA-1 を使う PKCS#1 v1.5 を意味します。OpenSSH 8.8(2021年)は ssh-rsa 署名をデフォルトで無効にしました。RSA 鍵は、サーバーが server-sig-algs 拡張で通知する署名アルゴリズム rsa-sha2-256 と rsa-sha2-512(RFC 8332)で引き続き使えます。

すべてのレジストリ