curve25519-sha256Note | curve25519-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 8731 |
curve448-sha512 | curve448-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 8731 |
diffie-hellman-group-exchange-sha1 | diffie-hellman-group-exchange-sha1 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD NOT. | RFC 4419RFC 8270 |
diffie-hellman-group-exchange-sha256 | diffie-hellman-group-exchange-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 4419RFC 8270 |
diffie-hellman-group1-sha1Note | diffie-hellman-group1-sha1 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD NOT. | RFC 4253 |
diffie-hellman-group14-sha1 | diffie-hellman-group14-sha1 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 4253 |
diffie-hellman-group14-sha256 | diffie-hellman-group14-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): MUST. | RFC 8268 |
diffie-hellman-group15-sha512 | diffie-hellman-group15-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 8268 |
diffie-hellman-group16-sha512 | diffie-hellman-group16-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 8268 |
diffie-hellman-group17-sha512 | diffie-hellman-group17-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 8268 |
diffie-hellman-group18-sha512 | diffie-hellman-group18-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 8268 |
ecdh-sha2-* | ecdh-sha2-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 5656 |
ecdh-sha2-nistp256 | ecdh-sha2-nistp256 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 5656 |
ecdh-sha2-nistp384 | ecdh-sha2-nistp384 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 5656 |
ecdh-sha2-nistp521 | ecdh-sha2-nistp521 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 5656 |
ecmqv-sha2 | ecmqv-sha2 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 5656 |
ext-info-c | ext-info-c is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 8308 |
ext-info-s | ext-info-s is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 8308 |
gss- | gss- is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): reserved. | RFC 4462 |
gss-curve25519-sha256-* | gss-curve25519-sha256-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD. | RFC 8732 |
gss-curve448-sha512-* | gss-curve448-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 8732 |
gss-gex-sha1-* | gss-gex-sha1-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD NOT. | RFC 4462RFC 8732 |
gss-group1-sha1-* | gss-group1-sha1-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD NOT. | RFC 4462RFC 8732 |
gss-group14-sha1-* | gss-group14-sha1-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD NOT. | RFC 4462RFC 8732 |
gss-group14-sha256-* | gss-group14-sha256-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD. | RFC 8732 |
gss-group15-sha512-* | gss-group15-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 8732 |
gss-group16-sha512-* | gss-group16-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 8732 |
gss-group17-sha512-* | gss-group17-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 8732 |
gss-group18-sha512-* | gss-group18-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): MAY. | RFC 8732 |
gss-nistp256-sha256-* | gss-nistp256-sha256-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD. | RFC 8732 |
gss-nistp384-sha384-* | gss-nistp384-sha384-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD. | RFC 8732 |
gss-nistp521-sha512-* | gss-nistp521-sha512-* is an SSH key exchange method family; the rest of the name is defined by the referenced document. Implementation guidance (RFC 9142): SHOULD. | RFC 8732 |
mlkem1024-sha384 | mlkem1024-sha384 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | draft-harrison-mlkem-ssh-01 |
mlkem1024nistp384-sha384 | mlkem1024nistp384-sha384 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 10042 |
mlkem512-sha256 | mlkem512-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | draft-harrison-mlkem-ssh-01 |
mlkem768-sha256 | mlkem768-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | draft-harrison-mlkem-ssh-01 |
mlkem768nistp256-sha256 | mlkem768nistp256-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 10042 |
mlkem768x25519-sha256Note | mlkem768x25519-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 10042 |
rsa1024-sha1 | rsa1024-sha1 is an SSH key exchange method. Implementation guidance (RFC 9142): MUST NOT. | RFC 4432 |
rsa2048-sha256 | rsa2048-sha256 is an SSH key exchange method. Implementation guidance (RFC 9142): MAY. | RFC 4432 |
sntrup761x25519-sha512 | sntrup761x25519-sha512 is an SSH key exchange method. Implementation guidance (RFC 9142): SHOULD. | RFC 9941 |