edwards448 ist eine Edwards-Kurve x² + y² = 1 + dx²y² über einem 448-Bit-Primkörper mit einer 446-Bit-Untergruppe von Primordnung und dem Kofaktor 4; das geschätzte Sicherheitsniveau beträgt 224 Bit. Status: empfohlen für Neuentwicklungen.
Edwards448 ist die nicht getwistete Edwards-Kurve x² + y² = 1 − 39081x²y² über p = 2^448 − 2^224 − 1 (RFC 7748 §4.2), 4-isogen zu Curve448. Die Gruppenordnung ist 4·n mit einer 446-Bit-Primzahl n.
Ed448 (RFC 8032 §5.2) hasht mit SHAKE256, verwendet 57-Byte-Schlüssel und 114-Byte-Signaturen und unterstützt einen Kontext-String. Es ist für TLS 1.3 (ed448), DNSSEC (Algorithmus 16), JOSE und COSE (Ed448) sowie X.509 (OID 1.3.101.113) definiert, und FIPS 186-5 lässt es zu.
Namen in Standards
| Standard | Name |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
Domainparameter
448-Bit-Primkörper · etwa 224-Bit-Sicherheit
- Primzahl p des Körpers
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Koeffizient d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- x-Koordinate des Basispunkts
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- y-Koordinate des Basispunkts
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- Ordnung n des Basispunkts
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Kofaktor h
- 0x4
Verwendet in
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
Kennungen in Registern
- SSH-Algorithmen für öffentliche Schlüssel
- ssh-ed448
← Alle Kurven