0 | DELETE | DELETE (DNSSEC-Algorithmus 0): Delete DS. Signieren von Zonen: keine Vorgabe; Validierung: keine Vorgabe. | RFC 4034RFC 4398RFC 8078 |
1 | RSAMD5 | RSAMD5 (DNSSEC-Algorithmus 1): RSA/MD5 (DEPRECATED, see 5). Signieren von Zonen: verboten (MUST NOT); Validierung: verboten (MUST NOT). | RFC 3110RFC 4034 |
2 | DH | DH (DNSSEC-Algorithmus 2): Diffie-Hellman. Signieren von Zonen: keine Vorgabe; Validierung: keine Vorgabe. | RFC 2539 |
3 | DSA | DSA (DNSSEC-Algorithmus 3): DSA/SHA1. Signieren von Zonen: verboten (MUST NOT); Validierung: verboten (MUST NOT). | RFC 3755RFC 2536Federal Information Processing Standards Publication (FIPS PUB) 186, Digital Signature Standard, 18 May 1994Federal Information Processing Standards Publication (FIPS PUB) 180-1, Secure Hash Standard, 17 April 1995. (Supersedes FIPS PUB 180 dated 11 May 1993.) |
5Anmerkung | RSASHA1 | RSASHA1 (DNSSEC-Algorithmus 5): RSA/SHA-1. Signieren von Zonen: verboten (MUST NOT); Validierung: empfohlen (RECOMMENDED). | RFC 3110RFC 4034RFC 9905 |
6 | DSA-NSEC3-SHA1 | DSA-NSEC3-SHA1 (DNSSEC-Algorithmus 6): DSA-NSEC3-SHA1. Signieren von Zonen: verboten (MUST NOT); Validierung: verboten (MUST NOT). | RFC 5155 |
7 | RSASHA1-NSEC3-SHA1 | RSASHA1-NSEC3-SHA1 (DNSSEC-Algorithmus 7): RSASHA1-NSEC3-SHA1. Signieren von Zonen: verboten (MUST NOT); Validierung: empfohlen (RECOMMENDED). | RFC 5155RFC 9905 |
8Anmerkung | RSASHA256 | RSASHA256 (DNSSEC-Algorithmus 8): RSA/SHA-256. Signieren von Zonen: empfohlen (RECOMMENDED); Validierung: empfohlen (RECOMMENDED). | RFC 5702 |
10 | RSASHA512 | RSASHA512 (DNSSEC-Algorithmus 10): RSA/SHA-512. Signieren von Zonen: nicht empfohlen (NOT RECOMMENDED); Validierung: empfohlen (RECOMMENDED). | RFC 5702 |
12 | ECC-GOST | ECC-GOST (DNSSEC-Algorithmus 12): GOST R 34.10-2001 (DEPRECATED). Signieren von Zonen: verboten (MUST NOT); Validierung: verboten (MUST NOT). | RFC 5933Change the status of GOST Signature Algorithms in DNSSEC in the IETF stream to HistoricRFC 9906 |
13Anmerkung | ECDSAP256SHA256 | ECDSAP256SHA256 (DNSSEC-Algorithmus 13): ECDSA Curve P-256 with SHA-256. Signieren von Zonen: empfohlen (RECOMMENDED); Validierung: empfohlen (RECOMMENDED). | RFC 6605 |
14 | ECDSAP384SHA384 | ECDSAP384SHA384 (DNSSEC-Algorithmus 14): ECDSA Curve P-384 with SHA-384. Signieren von Zonen: optional (MAY); Validierung: empfohlen (RECOMMENDED). | RFC 6605 |
15Anmerkung | ED25519 | ED25519 (DNSSEC-Algorithmus 15): Ed25519. Signieren von Zonen: empfohlen (RECOMMENDED); Validierung: empfohlen (RECOMMENDED). | RFC 8080 |
16 | ED448 | ED448 (DNSSEC-Algorithmus 16): Ed448. Signieren von Zonen: optional (MAY); Validierung: empfohlen (RECOMMENDED). | RFC 8080 |
17 | SM2SM3 | SM2SM3 (DNSSEC-Algorithmus 17): SM2 signing algorithm with SM3 hashing algorithm. Signieren von Zonen: optional (MAY); Validierung: optional (MAY). | RFC 9563 |
18 | MLDSA44 | MLDSA44 (DNSSEC-Algorithmus 18): ML-DSA-44. Signieren von Zonen: optional (MAY); Validierung: optional (MAY). | draft-westerbaan-dnssec-mldsa-03 |
23 | ECC-GOST12 | ECC-GOST12 (DNSSEC-Algorithmus 23): GOST R 34.10-2012. Signieren von Zonen: optional (MAY); Validierung: optional (MAY). | RFC 9558 |
252 | INDIRECT | INDIRECT (DNSSEC-Algorithmus 252): Reserved for Indirect Keys. Signieren von Zonen: keine Vorgabe; Validierung: keine Vorgabe. | RFC 4034 |
253 | PRIVATEDNS | PRIVATEDNS (DNSSEC-Algorithmus 253): private algorithm. Signieren von Zonen: optional (MAY); Validierung: optional (MAY). | RFC 4034 |
254 | PRIVATEOID | PRIVATEOID (DNSSEC-Algorithmus 254): private algorithm OID. Signieren von Zonen: optional (MAY); Validierung: optional (MAY). | RFC 4034 |