0 | DELETE | DELETE (DNSSEC algorithm 0): Delete DS. Signing zones: no guidance; validating: no guidance. | RFC 4034RFC 4398RFC 8078 |
1 | RSAMD5 | RSAMD5 (DNSSEC algorithm 1): RSA/MD5 (DEPRECATED, see 5). Signing zones: MUST NOT; validating: MUST NOT. | RFC 3110RFC 4034 |
2 | DH | DH (DNSSEC algorithm 2): Diffie-Hellman. Signing zones: no guidance; validating: no guidance. | RFC 2539 |
3 | DSA | DSA (DNSSEC algorithm 3): DSA/SHA1. Signing zones: MUST NOT; validating: MUST NOT. | RFC 3755RFC 2536Federal Information Processing Standards Publication (FIPS PUB) 186, Digital Signature Standard, 18 May 1994Federal Information Processing Standards Publication (FIPS PUB) 180-1, Secure Hash Standard, 17 April 1995. (Supersedes FIPS PUB 180 dated 11 May 1993.) |
5Note | RSASHA1 | RSASHA1 (DNSSEC algorithm 5): RSA/SHA-1. Signing zones: MUST NOT; validating: RECOMMENDED. | RFC 3110RFC 4034RFC 9905 |
6 | DSA-NSEC3-SHA1 | DSA-NSEC3-SHA1 (DNSSEC algorithm 6): DSA-NSEC3-SHA1. Signing zones: MUST NOT; validating: MUST NOT. | RFC 5155 |
7 | RSASHA1-NSEC3-SHA1 | RSASHA1-NSEC3-SHA1 (DNSSEC algorithm 7): RSASHA1-NSEC3-SHA1. Signing zones: MUST NOT; validating: RECOMMENDED. | RFC 5155RFC 9905 |
8Note | RSASHA256 | RSASHA256 (DNSSEC algorithm 8): RSA/SHA-256. Signing zones: RECOMMENDED; validating: RECOMMENDED. | RFC 5702 |
10 | RSASHA512 | RSASHA512 (DNSSEC algorithm 10): RSA/SHA-512. Signing zones: NOT RECOMMENDED; validating: RECOMMENDED. | RFC 5702 |
12 | ECC-GOST | ECC-GOST (DNSSEC algorithm 12): GOST R 34.10-2001 (DEPRECATED). Signing zones: MUST NOT; validating: MUST NOT. | RFC 5933Change the status of GOST Signature Algorithms in DNSSEC in the IETF stream to HistoricRFC 9906 |
13Note | ECDSAP256SHA256 | ECDSAP256SHA256 (DNSSEC algorithm 13): ECDSA Curve P-256 with SHA-256. Signing zones: RECOMMENDED; validating: RECOMMENDED. | RFC 6605 |
14 | ECDSAP384SHA384 | ECDSAP384SHA384 (DNSSEC algorithm 14): ECDSA Curve P-384 with SHA-384. Signing zones: MAY; validating: RECOMMENDED. | RFC 6605 |
15Note | ED25519 | ED25519 (DNSSEC algorithm 15): Ed25519. Signing zones: RECOMMENDED; validating: RECOMMENDED. | RFC 8080 |
16 | ED448 | ED448 (DNSSEC algorithm 16): Ed448. Signing zones: MAY; validating: RECOMMENDED. | RFC 8080 |
17 | SM2SM3 | SM2SM3 (DNSSEC algorithm 17): SM2 signing algorithm with SM3 hashing algorithm. Signing zones: MAY; validating: MAY. | RFC 9563 |
18 | MLDSA44 | MLDSA44 (DNSSEC algorithm 18): ML-DSA-44. Signing zones: MAY; validating: MAY. | draft-westerbaan-dnssec-mldsa-03 |
23 | ECC-GOST12 | ECC-GOST12 (DNSSEC algorithm 23): GOST R 34.10-2012. Signing zones: MAY; validating: MAY. | RFC 9558 |
252 | INDIRECT | INDIRECT (DNSSEC algorithm 252): Reserved for Indirect Keys. Signing zones: no guidance; validating: no guidance. | RFC 4034 |
253 | PRIVATEDNS | PRIVATEDNS (DNSSEC algorithm 253): private algorithm. Signing zones: MAY; validating: MAY. | RFC 4034 |
254 | PRIVATEOID | PRIVATEOID (DNSSEC algorithm 254): private algorithm OID. Signing zones: MAY; validating: MAY. | RFC 4034 |