alg | alg: Algorithm. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.4 |
crv | crv: Curve. Verwendet bei den Schlüsseltypen: EC, OKP. | Nein | RFC 7518, Section 6.2.1.1RFC 8037, Section 2 |
dAnmerkung | d: ECC Private Key. Verwendet bei den Schlüsseltypen: EC, RSA, OKP. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.2.2.1RFC 7518, Section 6.3.2.1RFC 8037, Section 2 |
dp | dp: First Factor CRT Exponent. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.4 |
dq | dq: Second Factor CRT Exponent. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.5 |
e | e: Exponent. Verwendet bei den Schlüsseltypen: RSA. | Nein | RFC 7518, Section 6.3.1.2 |
exp | exp: Expiration Time, as defined in [RFC 7519]. Verwendet bei den Schlüsseltypen: *. | Nein | OpenID Federation 1.0, Section 8.7.2 |
ext | ext: Extractable. Verwendet bei den Schlüsseltypen: *. | Nein | W3C Web Cryptography API |
iat | iat: Issued At, as defined in [RFC 7519]. Verwendet bei den Schlüsseltypen: *. | Nein | OpenID Federation 1.0, Section 8.7.2 |
k | k: Key Value. Verwendet bei den Schlüsseltypen: oct. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.4.1 |
key_ops | key_ops: Key Operations. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.3 |
kidAnmerkung | kid: Key ID. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.5 |
kty | kty: Key Type. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.1 |
n | n: Modulus. Verwendet bei den Schlüsseltypen: RSA. | Nein | RFC 7518, Section 6.3.1.1 |
nbf | nbf: Not Before, as defined in [RFC 7519]. Verwendet bei den Schlüsseltypen: *. | Nein | OpenID Federation 1.0, Section 8.7.2 |
oth | oth: Other Primes Info. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.7 |
p | p: First Prime Factor. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.2 |
priv | priv: Private key. Verwendet bei den Schlüsseltypen: AKP. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 9964 |
pub | pub: Public key. Verwendet bei den Schlüsseltypen: AKP. | Nein | RFC 9964 |
q | q: Second Prime Factor. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.3 |
qi | qi: First CRT Coefficient. Verwendet bei den Schlüsseltypen: RSA. Das Feld enthält privates Schlüsselmaterial und darf nie in einem veröffentlichten JWK Set stehen. | Ja | RFC 7518, Section 6.3.2.6 |
revoked | revoked: Revoked Key Properties. Verwendet bei den Schlüsseltypen: *. | Nein | OpenID Federation 1.0, Section 8.7.2 |
use | use: Public Key Use. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.2 |
x | x: X Coordinate. Verwendet bei den Schlüsseltypen: EC, OKP. | Nein | RFC 7518, Section 6.2.1.2RFC 8037, Section 2 |
x5c | x5c: X.509 Certificate Chain. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.7 |
x5t | x5t: X.509 Certificate SHA-1 Thumbprint. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.8 |
x5t#S256 | x5t#S256: X.509 Certificate SHA-256 Thumbprint. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.9 |
x5u | x5u: X.509 URL. Verwendet bei den Schlüsseltypen: *. | Nein | RFC 7517, Section 4.6 |
y | y: Y Coordinate. Verwendet bei den Schlüsseltypen: EC. | Nein | RFC 7518, Section 6.2.1.3 |