alg | alg: Algorithm. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.4 |
crv | crv: Curve. Используется с типами ключей: EC, OKP. | Нет | RFC 7518, Section 6.2.1.1RFC 8037, Section 2 |
dПримечание | d: ECC Private Key. Используется с типами ключей: EC, RSA, OKP. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.2.2.1RFC 7518, Section 6.3.2.1RFC 8037, Section 2 |
dp | dp: First Factor CRT Exponent. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.4 |
dq | dq: Second Factor CRT Exponent. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.5 |
e | e: Exponent. Используется с типами ключей: RSA. | Нет | RFC 7518, Section 6.3.1.2 |
exp | exp: Expiration Time, as defined in [RFC 7519]. Используется с типами ключей: *. | Нет | OpenID Federation 1.0, Section 8.7.2 |
ext | ext: Extractable. Используется с типами ключей: *. | Нет | W3C Web Cryptography API |
iat | iat: Issued At, as defined in [RFC 7519]. Используется с типами ключей: *. | Нет | OpenID Federation 1.0, Section 8.7.2 |
k | k: Key Value. Используется с типами ключей: oct. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.4.1 |
key_ops | key_ops: Key Operations. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.3 |
kidПримечание | kid: Key ID. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.5 |
kty | kty: Key Type. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.1 |
n | n: Modulus. Используется с типами ключей: RSA. | Нет | RFC 7518, Section 6.3.1.1 |
nbf | nbf: Not Before, as defined in [RFC 7519]. Используется с типами ключей: *. | Нет | OpenID Federation 1.0, Section 8.7.2 |
oth | oth: Other Primes Info. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.7 |
p | p: First Prime Factor. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.2 |
priv | priv: Private key. Используется с типами ключей: AKP. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 9964 |
pub | pub: Public key. Используется с типами ключей: AKP. | Нет | RFC 9964 |
q | q: Second Prime Factor. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.3 |
qi | qi: First CRT Coefficient. Используется с типами ключей: RSA. Этот параметр содержит данные закрытого ключа и никогда не должен появляться в опубликованном JWK Set. | Да | RFC 7518, Section 6.3.2.6 |
revoked | revoked: Revoked Key Properties. Используется с типами ключей: *. | Нет | OpenID Federation 1.0, Section 8.7.2 |
use | use: Public Key Use. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.2 |
x | x: X Coordinate. Используется с типами ключей: EC, OKP. | Нет | RFC 7518, Section 6.2.1.2RFC 8037, Section 2 |
x5c | x5c: X.509 Certificate Chain. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.7 |
x5t | x5t: X.509 Certificate SHA-1 Thumbprint. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.8 |
x5t#S256 | x5t#S256: X.509 Certificate SHA-256 Thumbprint. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.9 |
x5u | x5u: X.509 URL. Используется с типами ключей: *. | Нет | RFC 7517, Section 4.6 |
y | y: Y Coordinate. Используется с типами ключей: EC. | Нет | RFC 7518, Section 6.2.1.3 |