alg | alg : Algorithm. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.4 |
crv | crv : Curve. Utilisé avec les types de clés : EC, OKP. | Non | RFC 7518, Section 6.2.1.1RFC 8037, Section 2 |
dNote | d : ECC Private Key. Utilisé avec les types de clés : EC, RSA, OKP. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.2.2.1RFC 7518, Section 6.3.2.1RFC 8037, Section 2 |
dp | dp : First Factor CRT Exponent. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.4 |
dq | dq : Second Factor CRT Exponent. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.5 |
e | e : Exponent. Utilisé avec les types de clés : RSA. | Non | RFC 7518, Section 6.3.1.2 |
exp | exp : Expiration Time, as defined in [RFC 7519]. Utilisé avec les types de clés : *. | Non | OpenID Federation 1.0, Section 8.7.2 |
ext | ext : Extractable. Utilisé avec les types de clés : *. | Non | W3C Web Cryptography API |
iat | iat : Issued At, as defined in [RFC 7519]. Utilisé avec les types de clés : *. | Non | OpenID Federation 1.0, Section 8.7.2 |
k | k : Key Value. Utilisé avec les types de clés : oct. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.4.1 |
key_ops | key_ops : Key Operations. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.3 |
kidNote | kid : Key ID. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.5 |
kty | kty : Key Type. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.1 |
n | n : Modulus. Utilisé avec les types de clés : RSA. | Non | RFC 7518, Section 6.3.1.1 |
nbf | nbf : Not Before, as defined in [RFC 7519]. Utilisé avec les types de clés : *. | Non | OpenID Federation 1.0, Section 8.7.2 |
oth | oth : Other Primes Info. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.7 |
p | p : First Prime Factor. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.2 |
priv | priv : Private key. Utilisé avec les types de clés : AKP. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 9964 |
pub | pub : Public key. Utilisé avec les types de clés : AKP. | Non | RFC 9964 |
q | q : Second Prime Factor. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.3 |
qi | qi : First CRT Coefficient. Utilisé avec les types de clés : RSA. Il contient des données de clé privée et ne doit jamais apparaître dans un JWK Set publié. | Oui | RFC 7518, Section 6.3.2.6 |
revoked | revoked : Revoked Key Properties. Utilisé avec les types de clés : *. | Non | OpenID Federation 1.0, Section 8.7.2 |
use | use : Public Key Use. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.2 |
x | x : X Coordinate. Utilisé avec les types de clés : EC, OKP. | Non | RFC 7518, Section 6.2.1.2RFC 8037, Section 2 |
x5c | x5c : X.509 Certificate Chain. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.7 |
x5t | x5t : X.509 Certificate SHA-1 Thumbprint. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.8 |
x5t#S256 | x5t#S256 : X.509 Certificate SHA-256 Thumbprint. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.9 |
x5u | x5u : X.509 URL. Utilisé avec les types de clés : *. | Non | RFC 7517, Section 4.6 |
y | y : Y Coordinate. Utilisé avec les types de clés : EC. | Non | RFC 7518, Section 6.2.1.3 |