edwards448 es una curva de Edwards x² + y² = 1 + dx²y² sobre un campo primo de 448 bits, con un subgrupo de orden primo de 446 bits y cofactor 4; su nivel de seguridad estimado es de 224 bits. Estado: recomendada para sistemas nuevos.
Edwards448 es la curva de Edwards no torcida x² + y² = 1 − 39081x²y² sobre p = 2^448 − 2^224 − 1 (RFC 7748 §4.2), 4-isógena a Curve448. El orden del grupo es 4·n, con n primo de 446 bits.
Ed448 (RFC 8032 §5.2) calcula el hash con SHAKE256, usa claves de 57 bytes y firmas de 114 bytes, y admite una cadena de contexto. Está definido para TLS 1.3 (ed448), DNSSEC (algoritmo 16), JOSE y COSE (Ed448) y X.509 (OID 1.3.101.113), y FIPS 186-5 lo aprueba.
Nombres en los estándares
| Estándar | Nombre |
|---|
| RFC 8032 | edwards448 |
| RFC 8032 / RFC 8410 | Ed448 |
| Hamburg | Goldilocks |
Identificadores de objeto
Parámetros de dominio
campo primo de 448 bits · seguridad de unos 224 bits
- Primo del campo p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- Coeficiente d
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffff6756
- Punto base x
- 0x4f1970c66bed0ded221d15a622bf36da9e146570470f1767ea6de324a3d3a46412ae1af72ab66511433b80e18b00938e2626a82bc70cc05e
- Punto base y
- 0x693f46716eb6bc248876203756c9c7624bea73736ca3984087789c1e05a0c2d73ad3ff1ce67c39c4fdbd132c4ed7c8ad9808795bf230fa14
- Orden n del punto base
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- Cofactor h
- 0x4
Se usa en
- TLS 1.3 (ed448)
- DNSSEC (algorithm 16)
- JOSE (Ed448)
- COSE (Ed448)
Identificadores en registros
← Todas las curvas