A128CBC | A128CBC es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CBC sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A128CBC-HS256 | A128CBC-HS256 es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-CBC con HMAC con SHA-256. Requisito de implementación: obligatorio. | enc | RFC 7518, Section 5.2.3 |
A128CTR | A128CTR es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CTR sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A128GCM | A128GCM es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-GCM. Requisito de implementación: recomendado. | enc | RFC 7518, Section 5.3 |
A128GCMKW | A128GCMKW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES-GCM. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.7 |
A128KW | A128KW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES (key wrap). Requisito de implementación: recomendado. | alg | RFC 7518, Section 4.4 |
A192CBC | A192CBC es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CBC sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A192CBC-HS384 | A192CBC-HS384 es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-CBC con HMAC con SHA-384. Requisito de implementación: opcional. | enc | RFC 7518, Section 5.2.4 |
A192CTR | A192CTR es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CTR sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A192GCM | A192GCM es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-GCM. Requisito de implementación: opcional. | enc | RFC 7518, Section 5.3 |
A192GCMKW | A192GCMKW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES-GCM. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.7 |
A192KW | A192KW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES (key wrap). Requisito de implementación: opcional. | alg | RFC 7518, Section 4.4 |
A256CBC | A256CBC es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CBC sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A256CBC-HS512 | A256CBC-HS512 es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-CBC con HMAC con SHA-512. Requisito de implementación: obligatorio. | enc | RFC 7518, Section 5.2.5 |
A256CTR | A256CTR es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: AES-CTR sin autenticación. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
A256GCM | A256GCM es un algoritmo JOSE de cifrado de contenido (enc en un JWE): AES-GCM. Requisito de implementación: recomendado. | enc | RFC 7518, Section 5.3 |
A256GCMKW | A256GCMKW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES-GCM. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.7 |
A256KW | A256KW es un algoritmo JOSE de gestión de claves (alg en un JWE): envoltura de claves AES (key wrap). Requisito de implementación: recomendado. | alg | RFC 7518, Section 4.4 |
dir | dir es un algoritmo JOSE de gestión de claves (alg en un JWE): uso directo de una clave simétrica compartida. Requisito de implementación: recomendado. | alg | RFC 7518, Section 4.5 |
ECDH-ES | ECDH-ES es un algoritmo JOSE de gestión de claves (alg en un JWE): ECDH efímero-estático. Requisito de implementación: recomendado, probablemente pasará a ser obligatorio. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A128KW | ECDH-ES+A128KW es un algoritmo JOSE de gestión de claves (alg en un JWE): ECDH efímero-estático seguido de envoltura de claves AES. Requisito de implementación: recomendado. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A192KW | ECDH-ES+A192KW es un algoritmo JOSE de gestión de claves (alg en un JWE): ECDH efímero-estático seguido de envoltura de claves AES. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A256KW | ECDH-ES+A256KW es un algoritmo JOSE de gestión de claves (alg en un JWE): ECDH efímero-estático seguido de envoltura de claves AES. Requisito de implementación: recomendado. | alg | RFC 7518, Section 4.6 |
Ed25519 | Ed25519 es un algoritmo JOSE de firma o MAC (alg en un JWS): EdDSA sobre edwards25519. Requisito de implementación: opcional.edwards25519 | alg | RFC 9864, Section 2.2 |
Ed448 | Ed448 es un algoritmo JOSE de firma o MAC (alg en un JWS): EdDSA sobre edwards448. Requisito de implementación: opcional.edwards448 | alg | RFC 9864, Section 2.2 |
EdDSANota | EdDSA es un algoritmo JOSE de firma o MAC (alg en un JWS): EdDSA. Requisito de implementación: en desuso. | alg | RFC 9864, Section 2.2 |
ES256Nota | ES256 es un algoritmo JOSE de firma o MAC (alg en un JWS): ECDSA sobre P-256 con SHA-256. Requisito de implementación: recomendado, probablemente pasará a ser obligatorio.P-256 | alg | RFC 7518, Section 3.4 |
ES256K | ES256K es un algoritmo JOSE de firma o MAC (alg en un JWS): ECDSA sobre secp256k1 con SHA-256. Requisito de implementación: opcional.secp256k1 | alg | RFC 8812, Section 3.2 |
ES384 | ES384 es un algoritmo JOSE de firma o MAC (alg en un JWS): ECDSA sobre P-384 con SHA-384. Requisito de implementación: opcional.P-384 | alg | RFC 7518, Section 3.4 |
ES512 | ES512 es un algoritmo JOSE de firma o MAC (alg en un JWS): ECDSA sobre P-521 con SHA-512. Requisito de implementación: opcional.P-521 | alg | RFC 7518, Section 3.4 |
HPKE-0 | HPKE-0 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-256. Requisito de implementación: opcional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-0-KE | HPKE-0-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-256. Requisito de implementación: opcional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-1 | HPKE-1 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-384. Requisito de implementación: opcional.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-1-KE | HPKE-1-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-384. Requisito de implementación: opcional.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-2 | HPKE-2 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-521. Requisito de implementación: opcional.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-2-KE | HPKE-2-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-521. Requisito de implementación: opcional.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-3 | HPKE-3 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve25519. Requisito de implementación: opcional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-3-KE | HPKE-3-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve25519. Requisito de implementación: opcional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-4 | HPKE-4 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve25519. Requisito de implementación: opcional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5 | HPKE-5 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve448. Requisito de implementación: opcional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5-KE | HPKE-5-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve448. Requisito de implementación: opcional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-6 | HPKE-6 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre curve448. Requisito de implementación: opcional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7 | HPKE-7 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-256. Requisito de implementación: opcional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7-KE | HPKE-7-KE es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado híbrido de clave pública (HPKE) sobre P-256. Requisito de implementación: opcional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HS1 | HS1 es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: HMAC con SHA-1. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
HS256Nota | HS256 es un algoritmo JOSE de firma o MAC (alg en un JWS): HMAC con SHA-256. Requisito de implementación: obligatorio. | alg | RFC 7518, Section 3.2 |
HS384 | HS384 es un algoritmo JOSE de firma o MAC (alg en un JWS): HMAC con SHA-384. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.2 |
HS512 | HS512 es un algoritmo JOSE de firma o MAC (alg en un JWS): HMAC con SHA-512. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.2 |
ML-DSA-44 | ML-DSA-44 es un algoritmo JOSE de firma o MAC (alg en un JWS): ML-DSA. Requisito de implementación: opcional. | alg | RFC 9964 |
ML-DSA-65Nota | ML-DSA-65 es un algoritmo JOSE de firma o MAC (alg en un JWS): ML-DSA. Requisito de implementación: opcional. | alg | RFC 9964 |
ML-DSA-87 | ML-DSA-87 es un algoritmo JOSE de firma o MAC (alg en un JWS): ML-DSA. Requisito de implementación: opcional. | alg | RFC 9964 |
noneNota | none es un algoritmo JOSE de firma o MAC (alg en un JWS): sin firma ni MAC de ningún tipo. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.6 |
PBES2-HS256+A128KW | PBES2-HS256+A128KW es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado basado en contraseña (PBES2) con SHA-256. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.8 |
PBES2-HS384+A192KW | PBES2-HS384+A192KW es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado basado en contraseña (PBES2) con SHA-384. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.8 |
PBES2-HS512+A256KW | PBES2-HS512+A256KW es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado basado en contraseña (PBES2) con SHA-512. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.8 |
PS256 | PS256 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PSS con SHA-256. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.5 |
PS384 | PS384 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PSS con SHA-384. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.5 |
PS512 | PS512 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PSS con SHA-512. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.5 |
RS1 | RS1 es un identificador JOSE de WebCrypto que solo puede aparecer en una JWK: RSASSA-PKCS1-v1_5 con SHA-1. Requisito de implementación: prohibido. | JWK | W3C Web Cryptography API |
RS256Nota | RS256 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PKCS1-v1_5 con SHA-256. Requisito de implementación: recomendado. | alg | RFC 7518, Section 3.3 |
RS384 | RS384 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PKCS1-v1_5 con SHA-384. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.3 |
RS512 | RS512 es un algoritmo JOSE de firma o MAC (alg en un JWS): RSASSA-PKCS1-v1_5 con SHA-512. Requisito de implementación: opcional. | alg | RFC 7518, Section 3.3 |
RSA-OAEP | RSA-OAEP es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado RSAES-OAEP con SHA-1. Requisito de implementación: recomendado, probablemente pasará a ser obligatorio. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-256 | RSA-OAEP-256 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado RSAES-OAEP con SHA-256. Requisito de implementación: opcional. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-384 | RSA-OAEP-384 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado RSAES-OAEP con SHA-384. Requisito de implementación: opcional. | alg | W3C Web Cryptography API |
RSA-OAEP-512 | RSA-OAEP-512 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado RSAES-OAEP con SHA-512. Requisito de implementación: opcional. | alg | W3C Web Cryptography API |
RSA1_5Nota | RSA1_5 es un algoritmo JOSE de gestión de claves (alg en un JWE): cifrado RSAES-PKCS1-v1_5. Requisito de implementación: recomendado, probablemente pasará a ser opcional. | alg | RFC 7518, Section 4.2 |