A128CBC | A128CBC is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CBC without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A128CBC-HS256 | A128CBC-HS256 is a JOSE content encryption algorithm (enc in a JWE): AES-CBC with HMAC with SHA-256. Implementation requirement: required. | enc | RFC 7518, Section 5.2.3 |
A128CTR | A128CTR is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CTR without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A128GCM | A128GCM is a JOSE content encryption algorithm (enc in a JWE): AES-GCM. Implementation requirement: recommended. | enc | RFC 7518, Section 5.3 |
A128GCMKW | A128GCMKW is a JOSE key management algorithm (alg in a JWE): AES-GCM key wrap. Implementation requirement: optional. | alg | RFC 7518, Section 4.7 |
A128KW | A128KW is a JOSE key management algorithm (alg in a JWE): AES key wrap. Implementation requirement: recommended. | alg | RFC 7518, Section 4.4 |
A192CBC | A192CBC is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CBC without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A192CBC-HS384 | A192CBC-HS384 is a JOSE content encryption algorithm (enc in a JWE): AES-CBC with HMAC with SHA-384. Implementation requirement: optional. | enc | RFC 7518, Section 5.2.4 |
A192CTR | A192CTR is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CTR without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A192GCM | A192GCM is a JOSE content encryption algorithm (enc in a JWE): AES-GCM. Implementation requirement: optional. | enc | RFC 7518, Section 5.3 |
A192GCMKW | A192GCMKW is a JOSE key management algorithm (alg in a JWE): AES-GCM key wrap. Implementation requirement: optional. | alg | RFC 7518, Section 4.7 |
A192KW | A192KW is a JOSE key management algorithm (alg in a JWE): AES key wrap. Implementation requirement: optional. | alg | RFC 7518, Section 4.4 |
A256CBC | A256CBC is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CBC without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A256CBC-HS512 | A256CBC-HS512 is a JOSE content encryption algorithm (enc in a JWE): AES-CBC with HMAC with SHA-512. Implementation requirement: required. | enc | RFC 7518, Section 5.2.5 |
A256CTR | A256CTR is a JOSE WebCrypto identifier that may appear only in a JWK: AES-CTR without authentication. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
A256GCM | A256GCM is a JOSE content encryption algorithm (enc in a JWE): AES-GCM. Implementation requirement: recommended. | enc | RFC 7518, Section 5.3 |
A256GCMKW | A256GCMKW is a JOSE key management algorithm (alg in a JWE): AES-GCM key wrap. Implementation requirement: optional. | alg | RFC 7518, Section 4.7 |
A256KW | A256KW is a JOSE key management algorithm (alg in a JWE): AES key wrap. Implementation requirement: recommended. | alg | RFC 7518, Section 4.4 |
dir | dir is a JOSE key management algorithm (alg in a JWE): direct use of a shared symmetric key. Implementation requirement: recommended. | alg | RFC 7518, Section 4.5 |
ECDH-ES | ECDH-ES is a JOSE key management algorithm (alg in a JWE): ephemeral-static ECDH. Implementation requirement: recommended, likely to become required. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A128KW | ECDH-ES+A128KW is a JOSE key management algorithm (alg in a JWE): ephemeral-static ECDH followed by AES key wrap. Implementation requirement: recommended. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A192KW | ECDH-ES+A192KW is a JOSE key management algorithm (alg in a JWE): ephemeral-static ECDH followed by AES key wrap. Implementation requirement: optional. | alg | RFC 7518, Section 4.6 |
ECDH-ES+A256KW | ECDH-ES+A256KW is a JOSE key management algorithm (alg in a JWE): ephemeral-static ECDH followed by AES key wrap. Implementation requirement: recommended. | alg | RFC 7518, Section 4.6 |
Ed25519 | Ed25519 is a JOSE signature or MAC algorithm (alg in a JWS): EdDSA on edwards25519. Implementation requirement: optional.edwards25519 | alg | RFC 9864, Section 2.2 |
Ed448 | Ed448 is a JOSE signature or MAC algorithm (alg in a JWS): EdDSA on edwards448. Implementation requirement: optional.edwards448 | alg | RFC 9864, Section 2.2 |
EdDSANote | EdDSA is a JOSE signature or MAC algorithm (alg in a JWS): EdDSA. Implementation requirement: deprecated. | alg | RFC 9864, Section 2.2 |
ES256Note | ES256 is a JOSE signature or MAC algorithm (alg in a JWS): ECDSA on P-256 with SHA-256. Implementation requirement: recommended, likely to become required.P-256 | alg | RFC 7518, Section 3.4 |
ES256K | ES256K is a JOSE signature or MAC algorithm (alg in a JWS): ECDSA on secp256k1 with SHA-256. Implementation requirement: optional.secp256k1 | alg | RFC 8812, Section 3.2 |
ES384 | ES384 is a JOSE signature or MAC algorithm (alg in a JWS): ECDSA on P-384 with SHA-384. Implementation requirement: optional.P-384 | alg | RFC 7518, Section 3.4 |
ES512 | ES512 is a JOSE signature or MAC algorithm (alg in a JWS): ECDSA on P-521 with SHA-512. Implementation requirement: optional.P-521 | alg | RFC 7518, Section 3.4 |
HPKE-0 | HPKE-0 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-256. Implementation requirement: optional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-0-KE | HPKE-0-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-256. Implementation requirement: optional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-1 | HPKE-1 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-384. Implementation requirement: optional.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-1-KE | HPKE-1-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-384. Implementation requirement: optional.P-384 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-2 | HPKE-2 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-521. Implementation requirement: optional.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-2-KE | HPKE-2-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-521. Implementation requirement: optional.P-521 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-3 | HPKE-3 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve25519. Implementation requirement: optional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-3-KE | HPKE-3-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve25519. Implementation requirement: optional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-4 | HPKE-4 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve25519. Implementation requirement: optional.curve25519 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5 | HPKE-5 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve448. Implementation requirement: optional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-5-KE | HPKE-5-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve448. Implementation requirement: optional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HPKE-6 | HPKE-6 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on curve448. Implementation requirement: optional.curve448 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7 | HPKE-7 is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-256. Implementation requirement: optional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 5.1 |
HPKE-7-KE | HPKE-7-KE is a JOSE key management algorithm (alg in a JWE): Hybrid Public Key Encryption (HPKE) on P-256. Implementation requirement: optional.P-256 | alg | RFC-ietf-jose-hpke-encrypt-22, Section 6.2 |
HS1 | HS1 is a JOSE WebCrypto identifier that may appear only in a JWK: HMAC with SHA-1. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
HS256Note | HS256 is a JOSE signature or MAC algorithm (alg in a JWS): HMAC with SHA-256. Implementation requirement: required. | alg | RFC 7518, Section 3.2 |
HS384 | HS384 is a JOSE signature or MAC algorithm (alg in a JWS): HMAC with SHA-384. Implementation requirement: optional. | alg | RFC 7518, Section 3.2 |
HS512 | HS512 is a JOSE signature or MAC algorithm (alg in a JWS): HMAC with SHA-512. Implementation requirement: optional. | alg | RFC 7518, Section 3.2 |
ML-DSA-44 | ML-DSA-44 is a JOSE signature or MAC algorithm (alg in a JWS): ML-DSA. Implementation requirement: optional. | alg | RFC 9964 |
ML-DSA-65Note | ML-DSA-65 is a JOSE signature or MAC algorithm (alg in a JWS): ML-DSA. Implementation requirement: optional. | alg | RFC 9964 |
ML-DSA-87 | ML-DSA-87 is a JOSE signature or MAC algorithm (alg in a JWS): ML-DSA. Implementation requirement: optional. | alg | RFC 9964 |
noneNote | none is a JOSE signature or MAC algorithm (alg in a JWS): no signature or MAC at all. Implementation requirement: optional. | alg | RFC 7518, Section 3.6 |
PBES2-HS256+A128KW | PBES2-HS256+A128KW is a JOSE key management algorithm (alg in a JWE): password-based encryption (PBES2) with SHA-256. Implementation requirement: optional. | alg | RFC 7518, Section 4.8 |
PBES2-HS384+A192KW | PBES2-HS384+A192KW is a JOSE key management algorithm (alg in a JWE): password-based encryption (PBES2) with SHA-384. Implementation requirement: optional. | alg | RFC 7518, Section 4.8 |
PBES2-HS512+A256KW | PBES2-HS512+A256KW is a JOSE key management algorithm (alg in a JWE): password-based encryption (PBES2) with SHA-512. Implementation requirement: optional. | alg | RFC 7518, Section 4.8 |
PS256 | PS256 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PSS with SHA-256. Implementation requirement: optional. | alg | RFC 7518, Section 3.5 |
PS384 | PS384 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PSS with SHA-384. Implementation requirement: optional. | alg | RFC 7518, Section 3.5 |
PS512 | PS512 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PSS with SHA-512. Implementation requirement: optional. | alg | RFC 7518, Section 3.5 |
RS1 | RS1 is a JOSE WebCrypto identifier that may appear only in a JWK: RSASSA-PKCS1-v1_5 with SHA-1. Implementation requirement: prohibited. | JWK | W3C Web Cryptography API |
RS256Note | RS256 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PKCS1-v1_5 with SHA-256. Implementation requirement: recommended. | alg | RFC 7518, Section 3.3 |
RS384 | RS384 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PKCS1-v1_5 with SHA-384. Implementation requirement: optional. | alg | RFC 7518, Section 3.3 |
RS512 | RS512 is a JOSE signature or MAC algorithm (alg in a JWS): RSASSA-PKCS1-v1_5 with SHA-512. Implementation requirement: optional. | alg | RFC 7518, Section 3.3 |
RSA-OAEP | RSA-OAEP is a JOSE key management algorithm (alg in a JWE): RSAES-OAEP encryption with SHA-1. Implementation requirement: recommended, likely to become required. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-256 | RSA-OAEP-256 is a JOSE key management algorithm (alg in a JWE): RSAES-OAEP encryption with SHA-256. Implementation requirement: optional. | alg | RFC 7518, Section 4.3 |
RSA-OAEP-384 | RSA-OAEP-384 is a JOSE key management algorithm (alg in a JWE): RSAES-OAEP encryption with SHA-384. Implementation requirement: optional. | alg | W3C Web Cryptography API |
RSA-OAEP-512 | RSA-OAEP-512 is a JOSE key management algorithm (alg in a JWE): RSAES-OAEP encryption with SHA-512. Implementation requirement: optional. | alg | W3C Web Cryptography API |
RSA1_5Note | RSA1_5 is a JOSE key management algorithm (alg in a JWE): RSAES-PKCS1-v1_5 encryption. Implementation requirement: recommended, likely to become optional. | alg | RFC 7518, Section 4.2 |