curve448 是形如 By² = x³ + Ax² + x 的 Montgomery 曲线,定义在 448 位素域上,其素数阶子群为 446 位,余因子为 4;估计安全级别为 224 位。状态:推荐用于新系统。
Curve448 是“Goldilocks”素数 2^448 − 2^224 − 1 上的曲线 y² = x³ + 156326x² + x,由 Mike Hamburg 于2015年提出,后被 RFC 7748 采纳。它的群阶为 4·n,其中 n 是 446 位素数,安全强度约为 224 位。
X448 的密钥和共享密钥都是 56 字节。TLS 1.3(x448,IANA 将其标记为推荐)、SSH(curve448-sha512,RFC 8731)和 HPKE(DHKEM(X448, HKDF-SHA512))都定义了它,但它的使用远少于 X25519。与它对应的 Edwards 曲线是 edwards448,用于 Ed448。
各标准中的名称
| 标准 | 名称 |
|---|
| RFC 7748 | curve448 |
| RFC 7748 / RFC 8410 | X448 |
域参数
448 位素域 · 约 224 位安全强度
- 域素数 p
- 0xfffffffffffffffffffffffffffffffffffffffffffffffffffffffeffffffffffffffffffffffffffffffffffffffffffffffffffffffff
- 系数 a
- 0x262a6
- 系数 b
- 0x1
- 基点 x 坐标
- 0x5
- 基点 y 坐标
- 0x7d235d1295f5b1f66c98ab6e58326fcecbae5d34f55545d060f75dc28df3f6edb8027e2346430d211312c4b150677af76fd7223d457b5b1a
- 基点的阶 n
- 0x3fffffffffffffffffffffffffffffffffffffffffffffffffffffff7cca23e9c44edb49aed63690216cc2728dc58f552378c292ab5844f3
- 余因子 h
- 0x4
用于
- TLS 1.3 (x448)
- SSH (curve448-sha512)
- HPKE
← 全部曲线