DHKEM(X25519, HKDF-SHA256)
DHKEM(X25519, HKDF-SHA256),ECH、MLS 和 Oblivious HTTP 所用的 HPKE KEM。
HPKE(RFC 9180)借助 X25519 临时密钥完成封装,从而把 Diffie–Hellman 变成 KEM;32 字节的封装密钥就是发送方的临时公钥。它是加密 ClientHello(ECH)配置的默认 KEM。
显示 28 项中的 28 项
混合公钥加密(HPKE,RFC 9180)的密钥封装机制,包括 ML-KEM 和混合方案。
| 值 | 名称 | Nenc | Npk | Nsk | Nsecret | 认证模式 | 参考文献 |
|---|---|---|---|---|---|---|---|
0x0010 | DHKEM(P-256, HKDF-SHA256)P-256 | 65 | 65 | 32 | 32 | 是 | FIPS 186-4RFC 5869 |
0x0011 | DHKEM(P-384, HKDF-SHA384)P-384 | 97 | 97 | 48 | 48 | 是 | FIPS 186-4RFC 5869 |
0x0012 | DHKEM(P-521, HKDF-SHA512)P-521 | 133 | 133 | 66 | 64 | 是 | FIPS 186-4RFC 5869 |
0x0013 | DHKEM(CP-256, HKDF-SHA256)P-256 | 32 | 32 | 32 | 32 | 是 | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0014 | DHKEM(CP-384, HKDF-SHA384)P-384 | 48 | 48 | 48 | 48 | 是 | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0015 | DHKEM(CP-521, HKDF-SHA512)P-521 | 66 | 66 | 66 | 64 | 是 | FIPS 186-4RFC 6090draft-irtf-cfrg-dnhpke-01 |
0x0016 | DHKEM(secp256k1, HKDF-SHA256)secp256k1 | 65 | 65 | 32 | 32 | 是 | SEC 2draft-wahby-cfrg-hpke-kem-secp256k1-01 |
0x0020说明 | DHKEM(X25519, HKDF-SHA256)curve25519 | 32 | 32 | 32 | 32 | 是 | RFC 5869RFC 7748 |
0x0021 | DHKEM(X448, HKDF-SHA512)curve448 | 56 | 56 | 56 | 64 | 是 | RFC 5869RFC 7748 |
0x0022 | DHKEM(X25519+Elligator, HKDF-SHA256)curve25519 | 32 | 32 | 32 | 32 | 是 | lsd.gnunet.org/lsd0011draft-schanzen-hpke-elligator-kem-01 |
0x0030 | X25519Kyber768Draft00curve25519 | 1120 | 1216 | 2432 | 64 | 否 | draft-westerbaan-cfrg-hpke-xyber768d00-02 |
0x0040 | ML-KEM-512 | 768 | 800 | 64 | 32 | 否 | draft-connolly-cfrg-hpke-mlkem-04 |
0x0041 | ML-KEM-768 | 1088 | 1184 | 64 | 32 | 否 | draft-connolly-cfrg-hpke-mlkem-04 |
0x0042 | ML-KEM-1024 | 1568 | 1568 | 64 | 32 | 否 | draft-connolly-cfrg-hpke-mlkem-04 |
0x0050 | MLKEM768-P256P-256 | 1153 | 1249 | 32 | 32 | 否 | draft-ietf-hpke-pq-04 |
0x0051 | MLKEM1024-P384P-384 | 1665 | 1665 | 32 | 32 | 否 | draft-ietf-hpke-pq-04 |
0x647A说明 | X-Wingcurve25519 | 1120 | 1216 | 32 | 32 | 否 | draft-connolly-cfrg-xwing-kem-06 |
| 范围 | 状态 | 说明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0001–0x000F | unassigned | Unassigned |
| 0x0017–0x001F | unassigned | Unassigned |
| 0x0023–0x002F | unassigned | Unassigned |
| 0x0031–0x003F | unassigned | Unassigned |
| 0x0043–0x004F | unassigned | Unassigned |
| 0x0052–0x6479 | unassigned | Unassigned |
| 0x647B–0xFFFF | unassigned | Unassigned |
来源:Hybrid Public Key Encryption (HPKE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 HPKE KEM Identifiers
DHKEM(X25519, HKDF-SHA256),ECH、MLS 和 Oblivious HTTP 所用的 HPKE KEM。
HPKE(RFC 9180)借助 X25519 临时密钥完成封装,从而把 Diffie–Hellman 变成 KEM;32 字节的封装密钥就是发送方的临时公钥。它是加密 ClientHello(ECH)配置的默认 KEM。
X-Wing,一种把 ML-KEM-768 与 X25519 组合起来的混合 KEM,已为 HPKE 注册。
X-Wing(draft-connolly-cfrg-xwing-kem)对 ML-KEM-768 的秘密值、X25519 的秘密值以及 X25519 公钥值计算 SHA3-256,派生出 32 字节的共享密钥,从而得到一个单一的 KEM:只要任意一个组件仍然安全,它就是安全的。封装密钥为 1,120 字节,公钥为 1,216 字节。
HPKE 的密钥派生函数。
| 值 | 名称 | Nh | 参考文献 |
|---|---|---|---|
0x0001 | HKDF-SHA256 | 32 | RFC 5869 |
0x0002 | HKDF-SHA384 | 48 | RFC 5869 |
0x0003 | HKDF-SHA512 | 64 | RFC 5869 |
0x0010 | SHAKE128 | 32 | draft-ietf-hpke-pq-04 |
0x0011 | SHAKE256 | 64 | draft-ietf-hpke-pq-04 |
0x0012 | TurboSHAKE128 | 32 | draft-ietf-hpke-pq-04 |
0x0013 | TurboSHAKE256 | 64 | draft-ietf-hpke-pq-04 |
| 范围 | 状态 | 说明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0004–0x000F | unassigned | Unassigned |
| 0x0014–0xFFFF | unassigned | Unassigned |
来源:Hybrid Public Key Encryption (HPKE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 HPKE KDF Identifiers
HPKE 的认证加密算法。
| 值 | 名称 | Nk | Nn | Nt | 参考文献 |
|---|---|---|---|---|---|
0x0001 | AES-128-GCM | 16 | 12 | 16 | NIST SP 800-38D |
0x0002 | AES-256-GCM | 32 | 12 | 16 | NIST SP 800-38D |
0x0003 | ChaCha20Poly1305 | 32 | 12 | 16 | RFC 8439 |
0xFFFF | Export-only | — | — | — | RFC 9180 |
| 范围 | 状态 | 说明 |
|---|---|---|
| 0x0000 | reserved | Reserved |
| 0x0004–0xFFFE | unassigned | Unassigned |
来源:Hybrid Public Key Encryption (HPKE)(IANA),获取于 2026-10-20。数据许可证:CC0-1.0。 HPKE AEAD Identifiers